I am trying to use Wireshark, but for some reason it won't capture packets. I've used it once before and it worked just fine, so I can't understand why it's not working right now. The only thing I've done differently since last time was that I opened the command window and run it as administrator, but when I went to use Wireshark again I did run it as administrator as well.

I open Wireshark and it shows me all detectable interfaces, out of which the Wi-Fi I'm connected to shows activity. Same with an Ethernet connection and the loopback interface. I start my capture with no filtering and promiscuous mode on all interfaces. Despite my doing things with my browser (looking up stuff, including http activity) it won't show anything and I always end my capture with no packets despite waiting for a good minute.

Then, when I close the capture, the opening window of wireshark won't show activity on the previously busy interfaces.

I have no idea what's gone wrong and I can't find anything online that explains or solves my problem. I've tried deleting and re-installing Wireshark as well, but to no avail. Any idea?

  • Turn off all filtering.
    – Ron Maupin
    Feb 18, 2023 at 18:41
  • @RonMaupin I have no filtering on.
    – Tita
    Feb 18, 2023 at 18:44
  • 2
    Either you are filtering, or you have not chosen an interface on which to capture. If you claim to have done both, then you need to get on the Wireshark help board.
    – Ron Maupin
    Feb 18, 2023 at 19:01
  • Or the pcap driver is broken. I've had that happen too many times.
    – Ricky
    Feb 18, 2023 at 21:43

1 Answer 1


I had the same issue. I was using it for the first time. As in the above answer by Ron Maupin, I didn't select an interface. When you start wireshark you see in the middle of the window a scrollable list of interfaces eth0, wlan0 etc. Choose whichever you want to monitor and click on start (capture). Or there is wheel button - configure capture - which will pop up a window where you can choose the interface and press start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.