3

Is there any way to change the console speed globally in GNS3. If you have seen GNS3VAULT videos the terminal speed is so fast but I could not find anywhere how to change the speed on GNS3 to get a faster speed. It get really frustrating when you type fast and the console output is not fast enough. I know that in actual Cisco devices you can change the baud rate when you are connecting via console port or change the line speed but this did not work on GNS3. Any help is appreciated.

4
  • Have you tried setting the idle-pc settings.
    – mcgoosh
    Jun 4 '14 at 20:46
  • Yes. idlepc is fine. The CPU is smooth and generally everything is fine except this one. The telnet terminal display is slow ( like when when you console to the device for the first time). Although when I use AUX port it's fast.
    – Fanttazio
    Jun 5 '14 at 10:44
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 10 '17 at 4:08
  • @RonMaupin At that time I tried the suggested fix but did not help. I have now moved on using another product (VIRL)
    – Fanttazio
    Aug 15 '17 at 12:24
2

I don't have your issue, so I cannot duplicate this. However, I believe this to be what you're describing.

Shows Line 0 has a speed of 9600, type CTY is for console

IOU2(config)#do sh line
    Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*     0 CTY              -    -      -    -    -      0       0     0/0       -
    <..snip..>

IOU2(config)#do sh term
Line 0, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600, no parity, 2 stopbits, 8 databits
   <..snip..>

Change the line speed

IOU2(config)#line 0
IOU2(config-line)#speed 115200

Verification:

IOU2(config)#do sh term
Line 0, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 115200/115200, no parity, 2 stopbits, 8 databits
   <..snip..>

In case you're OS has issues, here's what I'm running:

IOU2(config)#do sh ver | i LI
Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Experimental Version 12.4(20090407:185408) [yuiu-redbuild-V124_24_5_6_PIC1 177]
IOU2(config)#
1

This is achieved through using a base configuration for whatever IOS images you want to use.

In that base configuration, all you're doing is changing the line speed of the console port to something that's faster than 9600 (maximum line speed is 115200).

This blog post does a good job of explaining how to set said base configurations.

0

I'm a GNS3 developer, and It's strange nobody has reported this issue.

It seem to be a problem with your computer or the terminal you are using. I recommend to test with a different terminal application.

0

I had the same problem with when running IOS images. My topology contained a single router with an idle-PC setting that meant that CPU levels were low (5%). But the console session was slow. You could see individual characters appearing so that it would take about half a second for a long line to be displayed. I tried many different idle-pc values just in case it was causing a pause in the console handler. I tried a few other things with no luck: Another IOS image. Upgrade to GNS 2.1.4. A different telnet client (inc telnet.exe from DOC command line). I am running windows 10 with Intel core i7 at 2GHz with 16GB RAM. Then I installed the GNS VM under VMWare Workstation Player and built a router to use the VM and the problem went away. I had to downgrade my GNS version a while ago so that one of my old projects would run correctly and so possibly my slow console problem was due to some hidden corruption in my GNS installation. But if anyone else is finding slow console speed then it may be worth considering installing the GNS VM. Good Luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.