2

We currently have the following.

3Com 2900 series switches. Network range 192.168.10.0 Netgear WAG102 Access points Default VLAN of vlan1 on the switches (essentially not configured - default setup) Also some un-managed switches at the edges of the network.

We are now in a position where we need to do the following.

  1. Enable a public access network for wifi throughout the building to exit
  2. In the future, move our IP based phones to their own network

All ports in the switch(s) were by default untagged vlan 1 - this is how everything currently operates (essentially no VLAN)

What I've attempted to do:

To keep everything that is currently running on the network (nearly 200 devices) running without changing their configs I have made VLAN 20 on the switch for the wifi network.

In the WAG102 set the management VLAN to be VLAN 1

reboot the AP to make this take effect - can no longer reach the AP

I have attempted to TAG the port the AP is plugged into as VLAN1 TAGGED , but get the error that VLAN 1 cannot be changed. I have tagged the port as VLAN20 and left it as untagged VLAN 1 but still no joy.

I suppose my question is - how can I leave all my current devices on VLAN 1 (default) and use it as the management VLAN whilst introducing VLAN 20

Sorry if my question isn't articulated particularly well. I'm only attempting to make the VLAN on one switch to begin with (the AP and router are all plugged into this)

Thanks in advance

  • What kind of router do you have? – Ron Trunk Jun 6 '14 at 2:14
  • I have the following. - the main network - VLAN 1 has a netgear UTM25 on it, the guest network just has a BT Broadband router (2wire I think) I don't need to do any routing between the two networks – Alex Hellier Jun 6 '14 at 6:47
2

Assuming you will use VL20 as your guest network, do the following:

  1. Every switch that has guest devices on it should have VL 20 on it.

  2. Configure the security profile on the WAG102 to use VL 20 for the guest SSID (check "enable 802.1 VLAN"). For the management profile, uncheck the Enable 802.1q VLAN box.

  3. Make the AP ports on the switches VLAN 20 tagged and VL 1 untagged.

  4. Make the port for the BT router VL 20 untagged.

  5. If you have switch to switch connections, those ports should be set to VLAN 1 untagged and VL 20 tagged.

  6. Everything else (your internal devices, management interface, etc) should be on VL 1 untagged ports.

  • Hi , thanks for the answer. This is exactly how i've got it configured at this moment in time, but I'm unable to communicate with the WAG102 - its set to management vlan1 in its config. (eek!) – Alex Hellier Jun 6 '14 at 13:06
  • Do you have the Enable 802.1q box unchecked on the management profile? – Ron Trunk Jun 6 '14 at 13:08
  • its currently checked, and Vlan 1 entered into the box – Alex Hellier Jun 6 '14 at 13:18
  • Uncheck it. You want VLAN 1 to be untagged. – Ron Trunk Jun 8 '14 at 2:23
  • ahhhhh! thanks, I'll try this on monday when I'm back at work :) – Alex Hellier Jun 8 '14 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.