1

I configured the cellular and my router is connected to the internet ping (5/5) Success but I still cannot access the internet via PC

Here is my running-conf

Current configuration : 2271 bytes
!
! Last configuration change at 04:10:12 UTC Fri Mar 17 2023
!
version 15.5
service timestamps debug datetime msec                                                                             !hostlame Routerord-encpyptionme mqec
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
memory-size iomem 10
!
!
!
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
          
          
!         
!         
!         
!                                                                                                                  ip cef    ain looiup
no ipv6 cef
!         
!         
!         
!         
!         
multilini buldle-name authenticated
!         
!         
chat-script lte "" "AT!CALL" TIMEOUT 20 "OI"
!         
!         
!         
!         
!         
licelse udi pid A898EAG-LTE-EA-K9 sn FCZ2217131X
!         
!         
ttp mode tralspapent
!         
!         
!         
!         
!         
controller SHDSL 0
!         
aontpoller Cellular 0
 lte modem link-recovery rssi onset-threshold -110                                                                  lte modem link-recovery wait-timer 10r 20                                                                          description etisalatvery debounce-count 6
description etisalat
!         
vlan 100,200,222,456-457,482,555,711 
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface Cellular0                                                                                                 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialep idle-timeout 0
 dialer string lte
 dialer-group 1
!         
interface Cellular1
 lo ip addresq
 encapsulation slip
!         
interface GigabitEthernet0
 no ip addresq
!         
interface GigabitEthernet1
 no ip address
!                                                                                                                   no ip addressabitEthernet2
!         
interface GigabitEthernet3
 nm ip addpess
!         
interface GigabitEthernet4
 switchport access vlan 100
 nm ip addpess                                                                                                     interface GigabitEthernet5
 no ip addreqs
!         
interface GigabitEthernet6
 no ip addreqs
!         
interface GigabitEthernet7
 no ip address
!         
interface GigabitEthernet8
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface Vlan1
 no ip address
!         
intepface Vlan100
 ip address 192.168.1.1 255.255.255.0
!         
ip fmrwapd-ppotoaol ld
no ip http server
no ip http secure-server
!         
!         
ip poute 0.0.0.0 0.0.0.0 Cellular0
!         
dialer-list 1 protocol ip permit
!         
!         
control-plane
!         
!         
!         
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-cheak-media-src disable
mgcp behavior comedia-sdp-force disable
!         
mgcp profile default
!         
!         
!         
!         
!         
!         
!                                                                                                                   no modem enable
line aux 0
line 2    
 no activation-character
 no exea  
 transport preferred none
 transport input all
 stopbits 1
line 3    
 script dialer lte
 no exec  
line 8    
 no exec  
line vty 0 4
 login    
 transport input none
!         
scheduler allocate 20000 1000
!
4
  • When using IPv4 private addresses on your network, you need to configure NAT because you cannot use private addresses on the public Internet.
    – Ron Maupin
    Commented Mar 17, 2023 at 14:49
  • how to configure the nat in my case?
    – breka
    Commented Mar 17, 2023 at 14:58
  • There are many questions and answers here about how to configure NAT on Cisco routers..
    – Ron Maupin
    Commented Mar 17, 2023 at 15:54
  • I couldn’t find any suit my case? any another ideas?
    – breka
    Commented Mar 17, 2023 at 18:42

1 Answer 1

1

Start here: https://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/13772-12.html

That covers general NAT setup with a lot of explanation and examples.

3
  • In this link you mentioned all cases has static IP (serial 0) which is not in my case (cellular 0) my carrier change ip always my conf is "ip address negotiated"
    – breka
    Commented Mar 19, 2023 at 4:50
  • That's fine. Just substitute the interface name as needed. Commented Mar 20, 2023 at 19:40
  • There is another example here. The important part is simply to assign the right interface (cellular0 I would assume) as 'ip nat outside' and the LAN interface as 'ip nat inside' cisco.com/c/en/us/support/docs/… And pay attention to the access list to define your LAN IP address networks that allowed to use NAT and the 'overload' keyword in the setup so multiple LAN IP addresses can share a single WAN/Internet IP address. Commented Apr 16, 2023 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.