1

I have the following configuration. On R1 I do inter-vlan routing. The problem is when I ping the serial interface of ISP1 with PC MA11 the ping packet is not returned to R1. I wanted to add a static route with ip route 10.15.240.0 255.255.255.0 209.165.240.14 so that the packets are returned.

R1 uses OSPF but ISP does not.

However this route is not saved. Why?

Config ISP1:

      Current configuration : 1042 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15241K07-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 209.165.240.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 209.165.240.9 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 4000000
 shutdown
!
interface Serial0/1/0
 ip address 209.165.240.13 255.255.255.252
 clock rate 2000000
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.15.240.0 255.255.255.0 209.165.240.14 
ip route 10.15.241.0 255.255.255.0 209.165.240.14 
!
ip flow-export version 9
!
!
!
no cdp run

Config R1:

    Current configuration : 1987 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
enable password class
!
!
!
!
!
!
ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
!
!
username Administrator password 0 Pasw0rd+
!
!
license udi pid CISCO1941/K9 sn FTX1524HE77-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.240
 encapsulation dot1Q 240
 ip address 10.15.240.9 255.255.255.0
 ip helper-address 10.15.242.13
 ipv6 address 2001:DB8:6:BC00::2/64
 ipv6 ospf 1 area 0
 standby 240 ip 10.15.240.1
 standby 240 priority 150
 standby 240 preempt
!
interface GigabitEthernet0/1.241
 encapsulation dot1Q 241
 ip address 10.15.241.9 255.255.255.0
 ip helper-address 10.15.242.13
 ipv6 address 2001:DB8:6:BC01::2/64
 ipv6 ospf 1 area 0
 standby 241 ip 10.15.241.1
 standby 241 priority 150
 standby 241 preempt
!
interface GigabitEthernet0/1.242
 encapsulation dot1Q 242
 ip address 10.15.242.9 255.255.255.0
 ipv6 address 2001:DB8:6:BC02::2/64
 ipv6 ospf 1 area 0
 standby 242 ip 10.15.242.1
 standby 242 priority 150
 standby 242 preempt
!
interface Serial0/0/0
 ip address 209.165.240.14 255.255.255.252
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 0.0.0.1
 log-adjacency-changes
 network 10.15.240.0 0.0.0.255 area 0
 network 10.15.241.0 0.0.0.255 area 0
 network 10.15.242.0 0.0.0.255 area 0
 network 209.165.240.12 0.0.0.3 area 0
 default-information originate
!
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0 
ip route 0.0.0.0 0.0.0.0 209.165.240.13 
ip route 0.0.0.0 0.0.0.0 209.165.240.9 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

enter image description here

enter image description here

enter image description here

5
  • Shouldn't the next hop for your static route be 209.165.240.9?
    – manish ma
    Commented Mar 19, 2023 at 9:57
  • @manishma No format is ip route dest.network dest.mask local_port OR ip rout dest.network dest.mask ip address of remote router interface...if you specifiy local interface ip address you get error %Invalid next hop address (it's this router)
    – Rubus
    Commented Mar 19, 2023 at 10:12
  • The route is being saved - see it in the config? It's not in the table because the destination isn't reachable - S0/1/0 does not appear to be up. (If you're doing all this in PacketTracer, that's almost certainly part of the problem. PT is crap.)
    – Ricky
    Commented Mar 19, 2023 at 11:29
  • Yeah you are right, it's the local address... so use the next hop IP address: 209.165.240.10
    – manish ma
    Commented Mar 19, 2023 at 11:35
  • @Ricky I removed that entry. Nevertheless I was routing via 209.165.240.14 so that entry should not cause issues
    – Rubus
    Commented Mar 19, 2023 at 23:22

1 Answer 1

4

On ISP1, you have configured 209.165.240.13/30 on interface Serial0/1/0. That interface doesn't seem to be up or even exist (see routing table), so the static route via 209.165.240.14 cannot become active.

Additionally, you should name your interfaces so it's less confusing for you and us.

[ISP1 edited]: the IP subnet configurations for S0/0/0 on R1 and ISP1 don't match, so using 209.165.240.14 as gateway doesn't work.

You do need a static route on ISP1 that includes MA11's subnet. Since serial links are point-to-point you could use S0/0/0 itself.

2
  • I updated the ISP config but it is still not working. (Removed the obsolete route)
    – Rubus
    Commented Mar 19, 2023 at 23:19
  • Updated the answer.
    – Zac67
    Commented Mar 20, 2023 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.