3

I have a cisco ASA 5550 firewall. I lost my image.

I tried to boot from tftp using rommon to upload new image but it doesn't work, now i want to get back to boot from flash but i'm stuck with the tftp.

When i change the confreg it restarts immediately, it doesn't wait for sync command that saves the configuration to the nv-ram, so all changes are lost ad it starts again in tftp.

What can cause this this problem, what should i try?

This is how i proceed :

rommon #0> confreg

Current Configuration Register: 0x00000010
Configuration Summary:
  boot TFTP image

Do you wish to change this configuration? y/n [n]: y
enable boot to ROMMON prompt? y/n [n]:
enable TFTP netboot? y/n [n]:
enable Flash boot? y/n [n]: y
select specific Flash image index? y/n [n]: y/n [n]:
go to ROMMON prompt if netboot fails? y/n [n]:
enable passing NVRAM file specs in auto-boot mode? y/n [n]:
disable display of BREAK or ESC key prompt during auto-boot? y/n [n]:

Current Configuration Register: 0x00000001
Configuration Summary:
  boot default image from Flash

Update Config Regist

Booting system, please wait...
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 8 '17 at 21:06
5

I found the problem!

The firewall has 4 rams (each of 1gb).

I started with two rams inserted and changed the configuration and it worked, the firewall did not restart.

So there is one failing ram. Now we ordered new one to replace it.

| improve this answer | |
  • I've noticed that one i start with 3 rams it reboots immediately, does that make sense, it starts only with 2 or 4 rams?? – Ould Abba Jun 9 '14 at 17:07
  • It may be that the firewall requires the memory to be in a channel, so without both channels being filled it will not boot. – HAL Jun 9 '14 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.