2

I am a learner. I learned somewhere that we could use static and dynamic routing in the network.

I built the simple network shown in the attached picture.

Packet Tracer Network Topology

I configured router8 with static routes to both SUB02 and SUB03.

I configured RIP on router9 with all subnets added, including the inter-routers subnets.

Unfortunately, no traffic can go between SUB01 and SUB02.

What Could be wrong?

I searched the net, Stack Exchange, and even asked AI ChatGPT with no luck.

All ports are UP, no firewalls, no vlans. Just basic configurations for the purpose of testing and learning.

Note: The solution that makes all routers static or dynamic is not the goal, and so please do not post them. The goal is to learn how to get routers to work with one static and the other dynamic.

Attached is the pkt file that has the lab along with all configurations.

The Problematic Lab File Link

UPDATE:

Here is Router8 running config:

Building configuration...

Current configuration : 895 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524DIQ3-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.30 255.255.255.224
 ip helper-address 192.168.0.125
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.0.94 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 192.168.0.126 255.255.255.224
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.0.32 255.255.255.224 192.168.0.93 
ip route 192.168.0.192 255.255.255.224 192.168.0.125 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

And here is Router9 running configuration:

Building configuration...

Current configuration : 883 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524J7R3-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.62 255.255.255.224
 ip helper-address 192.168.0.157
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.0.93 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 192.168.0.158 255.255.255.224
 ip helper-address 192.68.0.157
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

and Here is Router3 running configuration just in case:

Building configuration...

Current configuration : 1276 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
ip dhcp excluded-address 192.168.0.30
ip dhcp excluded-address 192.168.0.62
ip dhcp excluded-address 192.168.0.223
ip dhcp excluded-address 192.168.0.222
!
ip dhcp pool SUB01
 network 192.168.0.0 255.255.255.224
 default-router 192.168.0.30
ip dhcp pool SUB02
 network 192.168.0.32 255.255.255.224
 default-router 192.168.0.62
ip dhcp pool SUB03
 network 192.168.0.192 255.255.255.224
 default-router 192.168.0.222
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524R98Q-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.125 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.0.157 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 192.168.0.222 255.255.255.224
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.0.0 255.255.255.224 192.168.0.126 
ip route 192.168.0.32 255.255.255.224 192.168.0.158 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
5
  • Please edit the question to include all the network device configurations. We cannot guess where you may have gone wrong.
    – Ron Maupin
    Commented Apr 10, 2023 at 2:01
  • @RonMaupin All Configuration attached with a link to the Packet Tracer lab.
    – Shadi
    Commented Apr 10, 2023 at 6:56
  • That really does not help because most of us do not have Packet Tracer. Please put the output from the show running-config command into the question.
    – Ron Maupin
    Commented Apr 10, 2023 at 10:27
  • @RonMaupin The configurations added directly to the question.
    – Shadi
    Commented Apr 10, 2023 at 18:06
  • Has any answer solved your question? Then please accept it or your question will keep popping up here forever. Please also consider voting for useful answers.
    – Zac67
    Commented May 11, 2023 at 13:12

1 Answer 1

2

You are not actually running RIP since only one router is running RIP. RIP will exchange routing information with other RIP routers, but a single router running a routing protocol cannot exchange routing information with router not running the same routing protocol.

You need to either configure all the routers with static routes pointing to the other router, or you need to run a common routing protocol, e.g. RIP, on all of them in order to dynamically exchange routing information.

3
  • I know it gets it to work, but my question boils down to why it would not work with a static route on one router and RIP on the other as long as we have directly connected routes "C". I can see now that the static route is OK and will get us one way to the other router. but the RIP will not. Why? Because We only know from the RIP or the directly connected route about the other router BUT NOT about the subnet behind it. Hence we need RIP or static on all other routers. Thanks.
    – Shadi
    Commented May 12, 2023 at 10:33
  • RIP is a routing protocol. Routing protocols do not route packets, they only exchange routing information with neighbors running the same routing protocol.
    – Ron Maupin
    Commented May 12, 2023 at 12:46
  • Yes, I know. Thanks for being more accurate. What I meant is that without RIP on all routers, there is no way -in our example case- for the routers to get the needed routing information to get into the subnets behind other routers.
    – Shadi
    Commented May 12, 2023 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.