3

I have this topology:

enter image description here

and this configuration:

R1

interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 1 area 0

interface GigabitEthernet0/0
 ip address 192.168.0.1 255.255.255.252
 ip ospf network point-to-point
 ip ospf 1 area 0
!
router ospf 1
 router-id 1.1.1.1

R2

interface GigabitEthernet0/0
 ip address 192.168.0.2 255.255.255.252
 ip ospf network point-to-point
 ip ospf 1 area 0
!
 interface GigabitEthernet0/1
     ip address 192.168.1.1 255.255.255.252
     ip ospf network point-to-point
     ip ospf 1 area 0
!
router ospf 1
 router-id 1.1.1.2

R3

interface GigabitEthernet0/0
 ip address 192.168.1.2 255.255.255.252
 ip ospf network point-to-point
 ip ospf 1 area 0
!
router ospf 1
 router-id 1.1.1.3

On R3 i would like to receive only the loopback of R1 10.10.10.1/32 and not the transit subnet of R1: 192.168.0.1/30. How can i do that?

Thanks

2 Answers 2

2

You might consider Prefix-Suppression. You then influence what you redistribute as LSA 5.

1
  • this is what i was looking for
    – gaetano
    Jun 30, 2023 at 19:30
5

It is possible to filter OSPF updates, but you almost never want to do that. The premise of OSPF is that it builds a map of the network and then finds the best (shortest) path to each network. Each router builds a node map of the network and calculates the path from its point of view.

If you filter LSAs, then you prevent routers from getting the correct view of the network. Again, there may be special edge cases where you want to do that, but they're very rare. The command is

router ospf 1
neighbor a.b.c.d database-filter xx out
1
  • 1
    But as Ron said, don't do that. There is zero useful gain from doing it. Jun 30, 2023 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.