I am trying to transfer a new .bin file to a Cisco 2960x switch. Whenever I do this the CPU spikes to 100% and the maximum transfer rate is 35KB/s. A 28MB file takes 15 min+.

I've tried the following:

  1. Try on 3 different switches, including an idle switch on my bench.
  2. Try a different model of 2960x.
  3. Try different firmware versions, including the recommend 15.2(7)E7.
  4. Clear the config and only set an IP address on the switch.
  5. Try with SCP, TFTP, and HTTP.
  6. Use different computers and software to transfer the file from.
  7. Plug directly in to the switch.

Whenever the transfer starts, I can see with show proc cpu history that the CPU is spiked to 99%.

If I use show proc cpu sort | ex 0.00 I see ssh using all available free cycles when using SCP, and I see exec maxed out when trying to use HTTP. I did not look at what process tftp uses.

This almost appears to be expected behavior. I'm at a loss. Can someone confirm, and/or point me in the right direction?

  • Encryption drives a lot of CPU. Switches have little horsepower in the CPU compared to routers because switching is done in the hardware.
    – Ron Maupin
    Jul 19 at 21:02

1 Answer 1


This is perfectly normal for Cisco switches of this class, including the very sluggish transfer rates when writing to flash. Nothing to worry about.

Nevermind the peaks or sustained load you can see in show proc cpu ... : The switch doesn't do the heavy lifting (in extenso: forwarding traffic from port to port) on the CPU you see reported there (or in SNMP for that matter) - it's got ASICS for that purpose.

  • Don't look to close at the cpu states or you'll be ticked off that blinking the LEDs takes 20-30% of the CPU. Access flash is an expensive process. One would think the 2960X would be new enough to have eMMC / SATA storage.
    – Ricky
    Jul 19 at 21:56
  • Agreed, this behavior is totally normal. The CPU is there for management and very limited traffic processing. The actual packet/frame forwarding and other major switch features are not run on the CPU for the most part. Jul 19 at 23:26
  • Ok. Thanks everyone for the feedback. I've worked with a few different series' of cisco switches. I don't recall experiencing this, however, I can't say I specifically worked with this series. Jul 20 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.