0

Good day all.

I am running through a packet tracer exercise and am stuck on where to go next. Forgive me if I am missing something obvious, I have not touched any cisco networking or networking in about 5 years.

Scenario

2 hosts on vlan 79

  • PC 1: 192.168.79.10
  • PC 2: 192.168.79.20

2 hosts not on vlan

  • PC 1: 192.168.80.10
  • PC 2: 192.168.80.20

packet tracer exercise

I have the 2 PCs on vlan 79, the 192.168.79.0 subnet, which can successfully ping each other. However, I cannot get the two PCs that are on the 192.168.80.0 subnet and not on a vlan to communicate with each other

My Configuration Steps

I am using the default native vlan 1. I know that in a production environment this would be changed to a different vlan.

Switch 0

enable
conf t
vlan 79
name test
exit
interface vlan 79
no shutdown
interface vlan 1
no shutdown
exit
interface gigEthernet 0/1
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 79
exit
interface fa0/1
switchport mode access
switchport access vlan 79
no shutdown

Switch 1

enable
conf t
vlan 79
name test
exit
interface vlan 79
no shutdown
interface vlan 1
no shutdown
exit
interface gigEthernet 0/1
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 79
exit
interface fa0/1
switchport mode access
switchport access vlan 79
no shutdown

Configuration Outputs

Switch 0

enter image description here

enter image description here

Switch 1

enter image description here

enter image description here

I have been trying to debug this for a couple of days but cannot figure out why I can't get the two PC's that are not on a vlan to communicate with one another.

I apologize in advance if I have missed something obvious, but I have watched more than a dozen videos on the matter, numerous google searches, and even resorted to chat GPT just to see if it could spot my error.

Thank you

2
  • General VLAN troubleshooting starts with checking the MAC table, whether you see the expected end nodes' addresses in the expected VLAN.
    – Zac67
    Aug 18 at 13:03
  • It may be helpful to think of that traffic as being on vlan 1, rather than saying "not on a vlan."
    – Ron Trunk
    Aug 18 at 15:31

1 Answer 1

4

You set the interface native (untagged) VLAN to VLAN ID 1 and then only allowed VLAN 79 on the Trunk interface so untagged packets (VLAN 1) cannot pass over it. Add VLAN 1 to the allowed VLAN list on the required interfaces and it should pass just fine.

Trunk interfaces pass only tagged frames and the native VLAN so if you apply a VLAN allow list, that will exclude any unlisted VLAN even if it is the native or untagged VLAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.