1

There are 3 VLANs 10, 20 and 30 on these switchs. Everything such as VTP, DTP are working fine. The problem is that inter-VLAN seems not to work correctly. IP routing is activated on the L3SW (even though it doesn't appear in running configuration, maybe by default). SVIs were configured on L3SW and default-gateway of each vPC is the respective SVI. But the vPCs cannot communicate to the others. There must be something that I missed to make it work. Please help me out. Thankyou a lot!


Diagram

enter image description here


Configuration

L3SW

interface Ethernet0/0
 no switchport
 ip address 10.0.0.2 255.255.255.252
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet0/3
!
interface Vlan10
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan30
 ip address 192.168.3.1 255.255.255.0

SW1

interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet0/1
 switchport access vlan 10
 switchport mode access
!
interface Ethernet0/2
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk

SW2

interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Ethernet0/1
 switchport access vlan 20
 switchport mode access
!
interface Ethernet0/2
 switchport access vlan 30
 switchport mode access
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk

Verification

L3SW

SWL3#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Et0/1       on               802.1q         trunking      1
Et0/2       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/1       1-4094
Et0/2       1-4094

Port        Vlans allowed and active in management domain
Et0/1       1,10,20,30
Et0/2       1,10,20,30

Port        Vlans in spanning tree forwarding state and not pruned
Et0/1       1,10,20,30
Et0/2       1,10,20,30

SWL3#sh ip route
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/30 is directly connected, Ethernet0/0
L        10.0.0.2/32 is directly connected, Ethernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Vlan10
L        192.168.1.1/32 is directly connected, Vlan10
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, Vlan20
L        192.168.2.1/32 is directly connected, Vlan20
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, Vlan30
L        192.168.3.1/32 is directly connected, Vlan30

SWL3#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            10.0.0.2        YES manual up                    up
Ethernet0/1            unassigned      YES unset  up                    up
Ethernet0/2            unassigned      YES unset  up                    up
Ethernet0/3            unassigned      YES unset  up                    up
Vlan10                 192.168.1.1     YES manual up                    up
Vlan20                 192.168.2.1     YES manual up                    up
Vlan30                 192.168.3.1     YES manual up                    up

SW1

SW1#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Et0/0       on               802.1q         trunking      1
Et0/3       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/0       1-4094
Et0/3       1-4094

Port        Vlans allowed and active in management domain
Et0/0       1,10,20,30
Et0/3       1,10,20,30

Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       1,10,20,30
Et0/3       1,10,20,30

SW2

SW2#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan
Et0/0       on               802.1q         trunking      1
Et0/3       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/0       1-4094
Et0/3       1-4094

Port        Vlans allowed and active in management domain
Et0/0       1,10,20,30
Et0/3       1,10,20,30

Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       1,10,20,30
Et0/3       none

I'm working on EVE-NG and get the problem. I tried again in Cisco Packet Tracer and it worked perfectly as expected. :/

1
  • Routing looks fine. What is the result of "ping 192.168.1.2 source vlan 20" on l3sw? What is the route table of the hosts? i.e.,"netstat -rn"
    – Kai Hen
    Aug 20, 2023 at 9:23

2 Answers 2

0

IP routing is activated on the L3SW (even though it doesn't appear in running configuration, maybe by default).

Routing by default depends on the switch model that you haven't told us.

Do make sure ip routing is active - if it's on by default, no ip routing turns it off and also shows up in the running config.

If routing is off by default no ip routing doesn't show in the config but ip routing does.

If it doesn't work that way, EVE-NG might not be functioning correctly.

0

ip cef was enabled after I enabled ip routing. no ip cef made VLANs able to communicate with each other. There might be a bug or something like that on my IOS image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.