1

I have two different AS with different IP ranges and subnets, and the first router stack is running RIP, and the second one is OSPF. I want to configure BGP between "Router-PT Router23" and "Router-PT Router2," and both routers already have their own respective configurations, like the first one having RIP and the second one having OSPF configured, so how can I configure BGP between these two, and do I need to use inter-domain protocols like EIGRP or IBGP, etc., to transfer package AS1's Any Device to AS2's Any Device? 🤔🤔

AS1

AS2

  • Border Gateway 1
Router(config)#
Router(config)#router bgp 1
Router(config-router)#nei
Router(config-router)#neighbor 39.0.0.2 re
Router(config-router)#neighbor 39.0.0.2 remote-as 2
Router(config-router)#net
Router(config-router)#network 14.0.0.0 mas
Router(config-router)#network 14.0.0.0 mask 255.0.0.0
Router(config-router)#network 15.0.0.0 mask 255.0.0.0
Router(config-router)#network 16.0.0.0 mask 255.0.0.0
Router(config-router)#network 17.0.0.0 mask 255.0.0.0
Router(config-router)#%BGP-5-ADJCHANGE: neighbor 39.0.0.2 Up
  • Border Gateway 2
Router(config)#router bgp 2
Router(config-router)#nei
Router(config-router)#neighbor 39.0.0.1 re
Router(config-router)#neighbor 39.0.0.1 remote-as 1
Router(config-router)#%BGP-5-ADJCHANGE: neighbor 39.0.0.1 Up

Router(config-router)#ne
Router(config-router)#netw
Router(config-router)#network 35.0.0.0 mask 255.0.0.0
Router(config-router)#network 36.0.0.0 mask 255.0.0.0
Router(config-router)#network 37.0.0.0 mask 255.0.0.0
Router(config-router)#network 38.0.0.0 mask 255.0.0.0

1 Answer 1

1

Unlike IGPs that use network statement to determine which interfaces (not network) participate in the routing protocol, BGP uses network statements to determine which networks to advertise, but the networks must already exist in the routing table, and they must exactly match what is in the routing table. You can use show ip route to see the routes you have in your routing table from your IGP, and you can advertise those with BGP network statements.

With eBGP, you normally peer between directly connected routers because you do not have a route to a non-connected router in a different AS. It is possible to peer with a non-connected router if you either have a static route, or a common IGP that lets the non-connected router know how to reach their peers. You will also need to allow multihop for eBGP. That really defeats the purpose of an AS because an AS should be a black box to a different AS. Usually ASes peer at the edges with directly connected routers, and then you use iBGP or an IGP to propagate the routes inside the AS.

5
  • I got it, but in the Cisco packet tracer, there is no such thing as eBGP. It only supports BGP and EIGPR.
    – zeel
    Nov 12, 2023 at 7:55
  • Cisco packet tracer, there is no such thing as eBGP I bet there is. The difference between iBGP and eBGP "comes naturally". A router will speak iBGP to a neighbor if that neighbor's AS is the same as the local one, and it will speak eBGP to a neighbor if the neighbor's AS is different from the local one. Nov 12, 2023 at 9:10
  • @zeel, because you have two different AS numbers that you are tying to peer, that is eBGP (between ASes). If you use the same AS number between peers, that is iBGP because it is the same AS. There are different rules for each version.
    – Ron Maupin
    Nov 12, 2023 at 14:02
  • @Marc'netztier'Luethi Can you please guide me on how to implement this? I do some Google and ChatGPT, but no one is talking about the technique you are talking about.
    – zeel
    Nov 12, 2023 at 16:24
  • @zeel, your configurations are for eBGP because you are using two different AS numbers. You want to peer with the edge routers and then propagate the routes into each AS either with redistribution into the IGP used in the AS, or run iBGP inside the AS. Alternatively, you could use static routes or a common IGP in order to tell the internal AS routers how to reach the intended BGP peer in the other AS, and then use multihop in your BGP configuration.
    – Ron Maupin
    Nov 12, 2023 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.