0

I have to made the following setup, but I’ m not sure that is works Before scenarios that works Router over one link L3 connects to one Nk9 switch. On the Router side I have multiple subinterface ( like servers clients voice) subnets. Every subinterface acts as gateway for each above vlans. New design Router connect to one pair of Nexus 9k. So if I create one chanell group by using 2 switch port of Router and create subinterface for portchannel I will have the same results as in initial?

Edit: Unfortunately, I was informed that there will be no more pairs of 9k nexus switches. There will be an ordinary catalyst 9300 series. How can I archive the se result without vpc? case A as described by you is steel working ?. Bellow is my0 design.

         Router (3 vlans)

Switch core 1.////////////Switch core 2

   Some server 1 port in each

Switch 1—-/////////////////// Switch 2

          Switch access

    Clients vlan/ voip vlan
2
  • 1
    Please edit your question to include a good network description or diagram, the network device modes, and your proposed configuration.
    – Ron Maupin
    Commented Jan 17 at 20:13
  • As long as you have vPC configured between the pair of 9k's, this should work. (vpc is cisco's multi-chassis link aggregation technology.)
    – Ricky
    Commented Jan 18 at 1:59

1 Answer 1

1

New design Router connect to one pair of Nexus 9k. So if I create one chanell group by using 2 switch port of Router and create subinterface for portchannel I will have the same results as in initial

No, probably not with the Router's switch module, but with the router's onboard ports you can create subinterfaces.


Case A - Router's Switch Module supports LACP

Usually with Cisco routers, you cannot assign IP addresses to or create subinterfaces with ports of a switch module.

But if the switch module supports LACP (I must admit, I never worked with a switch module in ISR 4000), then the configs could look something like follows.

Please note: this is just IOS-XE / NX-OS pseudo config code. Details may vary, be sure to check/adapt.

Router:

interface port-channel 12
 description L2-PortChannel to Nexus 9k
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30

interface gig0/1/1
 description PortOfSwitchModule to Nexus 9K-1
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30
 channel-group 12 mode active

interface gig0/1/2
 description PortOfSwitchModule to Nexus 9K-2
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30
 channel-group 12 mode active

vlan 10 
 name SwitchModuleVLAN10
vlan 20 
 name SwitchModuleVLAN20
vlan 30 
 name SwitchModuleVLAN30

interface vlan10
ip address 192.168.10.1 255.255.255.0

interface vlan20
ip address 192.168.20.1 255.255.255.0

interface vlan30
ip address 192.168.30.1 255.255.255.0

Switch(es), working VPC setup assumed

interface port-channel 23
 switchport
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30
 vpc 23

interface e1/23
 switchport
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30
 channel-group 23 mode active

Case B - L3 Port Channel on Router

With the onboard ports, or with routed interface modules, you can create a L3 port channel interface on the ISR 4k series, and these can have subinterfaces.

This is a setup I know to be working, I run it in quite a few places with ISR 4000 Series and VPC pairs of Nexus 5500 Switches.

Router:

interface gig0/0/0
 description OnboardInterface0 to Nexus 9k-1
 channel-group 1 mode active

interface gig0/0/1
 description OnboardInterface1 to Nexus 9k-2
 channel-group 1 mode active

interface port-channel 1
 desc L3 PortChannel to Switche(s)

interface port-channel 1.10
 encapsulation dot1q 10
 ip address 192.168.10.1 255.255.255.0
 
interface port-channel 1.20
 encapsulation dot1q 20
 ip address 192.168.20.1 255.255.255.0

interface port-channel 1.30
 encapsulation dot1q 30
 ip address 192.168.30.1 255.255.255.0

Switch(es), working VPC setup assumed

interface port-channel 23
 switchport
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30
 vpc 23

interface e1/23
 switchport
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30
 channel-group 23 mode active

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.