1

I'm currently working on configuring inter-VLAN routing on a Cisco SF302-08 switch. I've already enabled Layer 3 routing, created the VLANs, assigned them to switchports, and configured the switch VLAN interfaces accordingly. However, I'm encountering difficulties at the step where I need to configure a routed port or a static route. Despite attempting these configurations, I'm unable to achieve successful communication between the different VLANs.

The switch's configuration:

show running-config:

v1.4.0.88 / R800_NIK_1_4_194_194 CLI v1.0 set system mode router

! vlan database vlan 10,20 exit

interface vlan 1 
ip address 101.205.25.252 255.255.255.0  
no ip address dhcp 
!
interface vlan 10 
ip address 101.205.10.1 255.255.255.0 
! 
interface vlan 20  
ip address 101.205.20.1 255.255.255.0 
! 
interface fastethernet3  
switchport mode access  
switchport access vlan 10 
! 
interface fastethernet4  
switchport mode access  
switchport access vlan 20 
! 
interface fastethernet5  
switchport trunk allowed vlan add 10,20 
! 
interface fastethernet7  
switchport mode access  
switchport access vlan 10 
! 
interface fastethernet8  
switchport mode access  
switchport access vlan 20 
! 
exit 
ip route 101.205.10.0 /24 101.205.25.254

Consequently, I am seeking assistance to resolve this issue. Any guidance or support offered would be greatly appreciated.

3
  • I do not see where you turned on routing. It is the ip routing global command. Also, your ip route 101.205.10.0 /24 101.205.25.254 command should not be there. A router (a layer-3 switch also has a router module) will automatically route between directly connected networks.
    – Ron Maupin
    Commented Feb 5 at 18:33
  • @RonMaupin I attempted to execute the "ip routing" command, but the output indicates that it is unrecognized.
    – mema
    Commented Feb 6 at 5:54
  • Has any answer solved your question? Then please accept it or your question will keep popping up here forever. Please also consider voting for useful answers.
    – Zac67
    Commented Mar 6 at 21:59

2 Answers 2

0

Some switches also need sdm prefer lanbase-routing in global configuration mode to enable routing. After that you may try to reload, and set ip routing

sdm prefer changes how the switch's ASIC allocates memory for different tables, sdm prefer lanbase-routing allows memory to be allocated to routing.

0

Yes, they can! However, small-business switches are somewhat unlike 'normal' Cisco switches.

  1. set system mode router - enables routing, switch is in L2-only mode by default (deletes configuration and reboots)
  2. ip address <address> <mask/length> from either port, VLAN or port channel context - VLAN is the most common (may be limited to VLAN on small-business switches)
  3. ip route <prefix> <mask/length> <gateway> - adds a static route for each remote subnet that is required. Subnets that are directly attached (see 2.) do not require nor use a static route.

See https://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/CLI_300_1_2_5.pdf for details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.