1

We are providing MPLS Network services to Customers via Ethernet Links. Our CPEs (mainly Cisco) are linked via VLAN Subinterfaces to the PEs (Juniper MX). Due to the increasing demand of Multiple Services (Internet, VPN, Cloud, etc.) im thinking of extending the MPLS Domain from the PEs to the CPEs, singaled via labeled BGP.

Pros:

  • just one single Layer2 underlay Link necessary, Service Virtualisation is based on MPLS Labels, so lower configuration impact.
  • Moving Configuration Complexity away from PE toi CPE

Cons until now:

  • additional Licenses necessary on Cisco Side (AX, or Network Avantage)
  • no IP ACSs possible on the WAN Link
  • Qos has to be done on MPLS-QoS bits so IP-DSCP Values have to be translated to MPLS-QoS

Now i wonder... is it possible to implement Layer2 Services in such a setup? AFAIK Cisco is not supporting BGP Signaled circuits (Kompella). Even in VPLS Setup BGP is only used for Discovery purposes.

But, in my understanding of Martini (LDP Signaled Circuits),it should still be possible in the above mentioned Setup. In Martini's draft a direct LDP Session is established between the two tunnel endpoints only to exchange tunnel information, not to exchange Path information.

Has anyone implemented such a setup and can confirm that this should be possible? Is the configuration straight forward like within a plain LDP domain or are there some specials to mention? Are there any cons i havn't thought of?

1
  • Have you considered QinQ?
    – manish ma
    Commented Feb 15 at 10:43

1 Answer 1

1

Implementing Layer 2 Services Martini (LDP-Signaled Circuits)

Martini uses LDP to signal Layer 2 circuits across an MPLS network. Here's a step-by-step guide to configure Martini pseudowires: Configuration Steps Enable MPLS and LDP on Interfaces:

! On Cisco CPE and Juniper PE
interface GigabitEthernet0/1
 mpls ip
 ip address 192.0.2.1 255.255.255.0
Implementing Layer 2 Services
Martini (LDP-Signaled Circuits)

Martini uses LDP to signal Layer 2 circuits across an MPLS network. Here's a step-by-step guide to configure Martini pseudowires:
Configuration Steps
Enable MPLS and LDP on Interfaces:

! On Cisco CPE and Juniper PE interface GigabitEthernet0/1 mpls ip ip address 192.0.2.1 255.255.255.0

Configure LDP on the Cisco CPE:

! Enable LDP on the router
mpls label protocol ldp
mpls ldp router-id Loopback0 force

Configure xconnect on Cisco CPE:

interface GigabitEthernet0/1.100
 encapsulation dot1Q 100
 xconnect 192.0.2.2 101 encapsulation mpls
```Configure LDP on Juniper PE:

set protocols ldp interface ge-0/0/0.0 set protocols ldp interface lo0.0

Configure pseudowire on Juniper PE:

```set interfaces ge-0/0/0 unit 100 encapsulation vlan-cccset protocols l2circuit neighbor 192.0.2.1 interface ge-0/0/0.100 virtual-circuit-id 101

Kompella (BGP-Signaled Circuits)

While BGP-signaled Layer 2 VPNs are more commonly associated with VPLS (Virtual Private LAN Services), they can also be used for point-to-point services. However, Cisco support for BGP-signaled L2 VPNs (Kompella) may be limited. Configuration Steps Configure BGP for L2VPN on Cisco CPE:

router bgp 65000
 address-family l2vpn evpn
  neighbor 192.0.2.2 activate

Configure BGP for L2VPN on Juniper PE:

set protocols bgp group EVPN type internal
set protocols bgp group EVPN local-address 192.0.2.2
set protocols bgp group EVPN family l2vpn signaling
set protocols bgp group EVPN neighbor 192.0.2.1

Configure interface for L2VPN on Juniper PE:

set interfaces ge-0/0/0 unit 100 family vpls

Configure the L2VPN instance on Juniper PE:

set routing-instances L2VPN instance-type l2vpn
set routing-instances L2VPN interface ge-0/0/0.100
set routing-instances L2VPN protocols vpls neighbor 192.0.2.1

Configure LDP on the Cisco CPE:

! Enable LDP on the router
mpls label protocol ldp
mpls ldp router-id Loopback0 force

Configure xconnect on Cisco CPE:

interface GigabitEthernet0/1.100
 encapsulation dot1Q 100
 xconnect 192.0.2.2 101 encapsulation mpls
```Configure LDP on Juniper PE:

set protocols ldp interface ge-0/0/0.0 set protocols ldp interface lo0.0

Configure pseudowire on Juniper PE:

```set interfaces ge-0/0/0 unit 100 encapsulation vlan-cccset protocols l2circuit neighbor 192.0.2.1 interface ge-0/0/0.100 virtual-circuit-id 101

Kompella (BGP-Signaled Circuits)

While BGP-signaled Layer 2 VPNs are more commonly associated with VPLS (Virtual Private LAN Services), they can also be used for point-to-point services. However, Cisco support for BGP-signaled L2 VPNs (Kompella) may be limited. Configuration Steps Configure BGP for L2VPN on Cisco CPE:

router bgp 65000
 address-family l2vpn evpn
  neighbor 192.0.2.2 activate

Configure BGP for L2VPN on Juniper PE:

set protocols bgp group EVPN type internal
set protocols bgp group EVPN local-address 192.0.2.2
set protocols bgp group EVPN family l2vpn signaling
set protocols bgp group EVPN neighbor 192.0.2.1

Configure interface for L2VPN on Juniper PE:

set interfaces ge-0/0/0 unit 100 family vpls

Configure the L2VPN instance on Juniper PE:

set routing-instances L2VPN instance-type l2vpn
set routing-instances L2VPN interface ge-0/0/0.100
set routing-instances L2VPN protocols vpls neighbor 192.0.2.1
1
  • so, it sin't possible to do it without LDP between CPE and PE? Because Labels are distributed by BGP. Unfortunately i didn't get it tested until now :( Commented Jul 16 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.