4

When I configure MPLS and RSVP on various Juniper devices, label-switched paths are successfully setup and seem to generally work, but the output of show rsvp neighbor always show each neighborship twice:

me@lab-router> show rsvp neighbor                   
RSVP neighbor: 2 learned
Address            Idle Up/Dn LastChange HelloInt HelloTx/Rx MsgRcvd
192.0.2.1           0  0/0  3d 20:26:59        9 36925/36925 71950
192.0.2.1           0  1/0  3d 20:26:59        9 36925/36925 71950

Interestingly, the first one always shows 0/0 as Up/Dn count. Seems there is only one online session between each neighbor after all. Looking at the reason, it says "Down (Node neighbor)":

me@lab-router> show rsvp neighbor detail 
RSVP neighbor: 2 learned
Address: 192.0.2.1 status: Down (Node neighbor)
  Last changed time: 3d 20:28:37, Idle: 0 sec, Up cnt: 0, Down cnt: 0
  Message received: 71971
  Hello: sent 36936, received: 36936, interval: 9 sec
  Remote instance: 0x0, Local instance: 0x53f4e752
  Refresh reduction:  not operational
    Remote end: disabled, Ack-extension: disabled
  Enhanced FRR: Disabled

Address: 192.0.2.1 via: ae0.0 status: Up
  Last changed time: 3d 20:28:37, Idle: 0 sec, Up cnt: 1, Down cnt: 0
  Message received: 71971
  Hello: sent 36936, received: 36936, interval: 9 sec
  Remote instance: 0xdcedac19, Local instance: 0xc712ec1a
  Refresh reduction:  operational
    Remote end: enabled, Ack-extension: enabled
  Enhanced FRR: Enabled
    LSPs (total 9): Phop 5, PPhop 0, Nhop 4, NNhop 0

To rule out any configurations errors/miss-understandings on my end, I already tried to cut down the (RSVP-related) config to just:

me@lab-router> show configuration protocols rsvp   
interface ae0.0;
me@lab-router> show configuration protocols mpls   
interface ae0.0;

Yet, it always shows every neighbor twice under show rsvp neighbor.

Why is that? Looking at JunOS documentation and examples, it doesn't seem that should be that way. What could cause those duplicate neighborships that I'm missing?

Other possibly relevant details: OSPF as IGP, unnumbered point-to-point interfaces between all IGP routers using just the loopback addresses, nothing filtered by any lo0-firewall rules. Tested on different Juniper devices (MX, QFX5k and QFX10k) and different JunOS releases.

1 Answer 1

4

In short, it's because you're seeing link-level and node-level RSVP neighbors, not all vendors do both by default. Most allow you to selectively disable one or the other, which is just one of the reasons you could be seeing one up vs the other down.

Here's an example where both are up just for the sake of example:

jhead@R1> show rsvp neighbor detail
RSVP neighbor: 4 learned

## Notice the "(Node neighbor)" indication.
## 10.0.0.147 is the loopback address of the remote node.

Address: 10.0.0.147 status: Up (Node neighbor)
  Last changed time: 4d 23:58:28, Idle: 0 sec, Up cnt: 1, Down cnt: 0
  Message received: 0
  Hello: sent 44409, received: 44407, interval: 9 sec

  ## Notice the differing "Local instance"
  
  Remote instance: 0x8078e86f, Local instance: 0xae3b0726
  Refresh reduction:  operational
    Remote end: enabled, Ack-extension: enabled
  Enhanced FRR: Enabled
    LSPs (total 298): Phop 149, PPhop 0, Nhop 149, NNhop 0

...

# Notice the "via ae0.0" because the neighbor is bound to this interface.

Address: 10.0.0.140 via: ae0.0 status: Up
  Last changed time: 4d 23:58:29, Idle: 0 sec, Up cnt: 1, Down cnt: 0
  Message received: 52023403
  Hello: sent 6524926, received: 6524683, interval: 9 sec
  Remote instance: 0xc0254b75, Local instance: 0x2fe87a5c
  Refresh reduction:  operational
    Remote end: enabled, Ack-extension: enabled
  Enhanced FRR: Enabled
    LSPs (total 300): Phop 150, PPhop 0, Nhop 150, NNhop 0

...
2
  • 1
    Further to Jordan's answer above, I am fairly certain that your use of OSPF unnumbered interfaces is also triggering this behaviour. Try changing the link to a /31 that doesn't overlap either of the loopback interfaces, flap the interface and see if the behaviour persists. Mar 12 at 7:10
  • Yes, OSPF unnumbered will cause the "overlap" of addresses due to the links not having a "real" address. To be clear however, even if you aren't using unnumbered, you'll still have both neighbors. Mar 12 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.