0

I am new to this and I am having a bit of a issue trying to successfully perform intervlan routing on a stacked L3 switche(s).

I essentially have three SVIs with their corresponding VLANS ( i think) The issue I am facing is that i cannot ping any endpoint to another in a different VLAN.

I feel like I might be missing something stupid simple?

Below is the switch config along with excerpts of the interfaces.

!
!
!
no aaa new-model
switch 1 provision c9200l-48p-4x
switch 2 provision c9200l-48p-4x
switch 3 provision c9200l-48p-4x
switch 4 provision c9200l-48p-4x
switch 5 provision c9200l-48p-4x
!

ip routing
!
!
!
!
!
no ip domain lookup
!
!
!
ip igmp snooping querier
login on-success log
!
!
!
!
system mtu 9198
license boot level network-advantage addon dna-advantage
!
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
memory free low-watermark processor 10626
!
!

!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 ip address 192.168.10.69 255.255.255.0
!
interface GigabitEthernet1/0/1
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/2
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/3
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/4
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/5
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/6
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/7
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/8
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/9
 switchport access vlan 10
 switchport mode access
 speed 1000
!
interface GigabitEthernet1/0/10
 switchport access vlan 10
 switchport mode access
 speed 1000

interface GigabitEthernet1/0/40
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/41
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/42
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/43
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/44
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/45
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/46
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/47
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/48
 switchport access vlan 30
 switchport mode access
 duplex full
 spanning-tree portfast

interface GigabitEthernet2/0/1
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/2
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/3
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/4
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/5
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/6
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/7
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/8
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/9
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/10
 switchport access vlan 10
 switchport mode access
 duplex full
 spanning-tree portfast

!
interface GigabitEthernet2/0/40
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/41
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/42
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/43
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/44
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/45
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/46
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/47
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet2/0/48
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast

interface GigabitEthernet3/0/1
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/2
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/3
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/4
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/5
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/6
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/7
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/8
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/0/9
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!

interface GigabitEthernet4/0/1
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/2
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/3
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/4
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/5
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/6
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/7
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/8
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/9
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!

interface GigabitEthernet4/0/40
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/41
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/42
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/43
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/44
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/45
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/46
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/47
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet4/0/48
 switchport access vlan 30
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast

interface GigabitEthernet5/0/1
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/2
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/3
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/4
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/5
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/6
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/7
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/8
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/9
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!

interface GigabitEthernet5/0/40
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/41
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/42
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/43
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/44
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/45
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/46
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/47
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet5/0/48
 switchport access vlan 20
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast

!
interface Vlan1
 ip address 192.168.10.10 255.255.255.0
!
interface Vlan10
 ip address 10.1.1.1 255.255.255.0
 ip mtu 1500
!
interface Vlan20
 ip address 10.10.1.1 255.255.255.0
!
interface Vlan30
 ip address 10.20.1.1 255.255.255.0
!
!
!
end

Any help is greatly appreciated!

Thank you!

26
  • Did you create the vlans? do show spanning-tree vlan 10 for example
    – Ron Trunk
    Commented Apr 10 at 17:10
  • I did. it output this, as an example sho spanning-tree vlan 10 VLAN0010 Spanning tree enabled protocol rstp Root ID Priority 32778 Address 6c29.d25a.9b00 This bridge is the root Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec Bridge ID Priority 32778 (priority 32768 sys-id-ext 10) Address 6c29.d25a.9b00 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec Aging Time 300 sec Along with the interfaces.
    – Tormentium
    Commented Apr 10 at 17:36
  • Did you configure the correct default gateway on your endpoints? Can you ping them? If the answer is yes, the next thing to check is that routing is enabled. show ip route You should see all your vlan interfaces listed.
    – Ron Trunk
    Commented Apr 10 at 17:59
  • Not sure about that specific model (might be IOS-XE?) but you might have to do a 'no shutdown' under each layer 3 SVI. Basically test as you would from bottom to top. Have a device ping its gateway, if you get a timeout, check for the MAC address showing up in the VLAN MAC table, check the ARP table on the switch, etc. Check the routing table as mentioned. Commented Apr 10 at 18:42
  • performing show ip route gives me this: 10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks C 10.1.1.0/24 is directly connected, Vlan10 L 10.1.1.1/32 is directly connected, Vlan10 C 10.10.1.0/24 is directly connected, Vlan20 L 10.10.1.1/32 is directly connected, Vlan20 C 10.20.1.0/24 is directly connected, Vlan30 L 10.20.1.1/32 is directly connected, Vlan30
    – Tormentium
    Commented Apr 10 at 19:12

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.