3

We recently got 2 new Cisco SG500 Series Switches (1x 24p & 1x 48p in a Stack) for a location. The plan was to have the SG500X do the routing between VLANs. So we went through and got these configured how we thought they should be, but it isn't quite working right. Everything seems to be in order except the link to the Sonicwall isn't passing traffic through correctly. Communication works fine from the Switches but End Devices aren't getting passed to the Sonicwall. There is a default route set to the Sonicwall.

I read a couple things that don't match up with our setup that confused me:

  1. SG500 comes default in 'L2 Mode' & must be set to 'L3 Mode' via #set system mode router
    - Our switch has no such command, the only 'mode' to set is "4-Queue or 8-Queue"
  2. IP Routing must be enabled via #ip routing, and will show in run-config after enabled
    - In the Web UI, It said enabled, but I enabled via CLI anyway, but it doesn't show this anywhere in the run-config

So the setup is: Modem --> Sonicwall --> SG500X --> End Devices

VLAN 1 ~ Administration
VLAN 10 ~ Data (All End Devices)
VLAN 12 ~ Voice (Cisco IP Phones)

Here's the running configuration, there's gotta be something we just missed.

v1.3.0.62 / R750_NIK_1_3_647_260     #I've actually upgraded to the latest firmware 1.3.7  
CLI v1.0  
set system queues-mode 4          

vlan database  
default-vlan vlan 10  
exit  
vlan database  
vlan 1,12   
exit  
voice vlan id 12   

interface vlan 1  
 ip address 192.168.1.1 255.255.255.0   
 no ip address dhcp   
!  
interface vlan 10  
 name Data   
 ip address 192.168.10.1 255.255.255.0   
!  
interface vlan 12  
 name Voice   
 ip address 192.168.12.1 255.255.255.0   
!  
interface gigabitethernet1/1/1  
 channel-group 1 mode auto   
!  
interface gigabitethernet1/1/2  
 channel-group 1 mode auto   
!  
interface gigabitethernet1/1/3  
 channel-group 1 mode auto   
!  
interface gigabitethernet1/1/4  
 channel-group 1 mode auto   
!  
interface gigabitethernet1/1/24  
 flowcontrol auto   
 description "Sonicwall X0"  
 ip address 192.168.11.1 255.255.255.0   
 switchport mode general   
 switchport general allowed vlan add 1,12 tagged   
!  
interface tengigabitethernet1/1/1  
 switchport trunk allowed vlan add 12   
 switchport default-vlan tagged   
!  
interface tengigabitethernet1/1/2  
 switchport trunk allowed vlan add 12   
 switchport default-vlan tagged   
!  
interface Port-channel1  
 description VSCSERVER1  
 switchport mode general   
!  
exit  
ip default-gateway 192.168.11.2   

Hopefully someone can help us out with this, if you need more information just let me know.

Thanks

######### EDIT

SG500X#show ip route
Maximum Parallel Paths: 1 (1 after reset)
IP Forwarding: enabled
Codes: > - best, C - connected, S - static, R - RIP

S 0.0.0.0/0 [1/1] via 192.168.12.1, 00:28:36, gi1/1/24
C 192.168.1.0/24 is directly connected, gi1/1/1
C 192.168.10.0/24 is directly connected, gi1/1/1
C 192.168.12.0/24 is directly connected, gi1/1/1

#
3
  • what do you get when you type "show ip route"?
    – Ron Trunk
    Jun 16, 2014 at 13:35
  • Hi Ron, I've edited the original post with output of show ip route. Currently we've moved on to a different configuration, but i've saved that config and i'd still like to know what the problem was. Thanks Jun 17, 2014 at 19:08
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 8, 2017 at 21:01

1 Answer 1

2

Couple of things I see off-hand that need to be addressed. Your routing table doesn't include the 192.168.11.x network, thus your router doesn't know where to send the data, unless you omitted it from the text. It should be automatically included as a "connected" 'C' route as your others are. Part of the problem may lie in the fact that you are using port 1/1/24 in switchport mode, instead of routed mode.

From the text you included, it looks like your voice network is the default static route for all of your traffic.

I imagine you can ping the 192.168.11.1 interface? Can you ping the 192.168.11.2 interface?

Here's a quick fix to try...

config t# int gi1/1/24

config t-if# no ip address

config t# int vlan 11

config t-if# ip address 192.168.11.1 255.255.255.0

config t-if# int gi1/1/24

config t-if# switchport mode acce

config t-if# switchport acc vlan 11

Verify the 192.168.11.0/24 network is in the routing table and rerun the ip default gateway command if needed. Check for connectivity.

You can also try changing int gi1/1/24 into a routed port with the "no switchport" command. That should also solve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.