3

I'm looking to use auto-negotiation and send Ethernet pause frames across a connection between an Intel X520 NIC and a Stratix IV FPGA using a 10G direct attach copper SFP. Ethtool is telling me that these functions are not supported, and when I try to set them with 'ethtool -A eth2 autoneg on rx on tx on', nothing changes. Intel's webpage says that these functions should be supported for the X520 family. The network driver is ixgbe 3.9.15-k, which supports auto-negotiation and flow control by default. Also, I thought auto-negotiation had to be supported for any 1G/10G connections, as an IEEE standard. Is the problem a compatibility issue, or is there a configuration I'm missing?

Output from ethtool eth2:

Settings for eth2:
        Supported ports: [ FIBRE ]
        Supported link modes:   10000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: No
        Advertised link modes:  10000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 10000Mb/s
        Duplex: Full
        Port: Direct Attach Copper
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: off
        Supports Wake-on: d
        Wake-on: d
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

Output from end of dmesg:

ixgbe 0000:04:00.0: eth2: detected SFP+: 3
ixgbe 0000:04:00.0: eth2: NIC Link is Up 10 Gbps, Flow Control: RX/TX
ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready
eth2: no IPv6 routers present
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 10 '17 at 4:16
3

I'm not sure about the IEEE standard, but Avaya switches only support autonegotiation for 10/100/1000 Mpbs. Autonegotiation isn't supported for 10 Gig connections.

This guy breaks it down a little bit. http://networkn3rd.wordpress.com/2013/04/15/10g-auto-negotiation/

| improve this answer | |
  • Thanks, it looks like I misunderstood how the auto-negotiation is used. The problem remains with the flow control, though. I definitely need the device to support receiving ethernet pause frames, and I think that can happen without auto-negotiation for this connection. – James Jun 19 '14 at 17:57
  • I'm not sure why ethtool says pause frames are unsupported when your link says flow control is enabled. What does your switch say when the link is up? Have you done a packet capture to see if you're sending or receiving pause frames? – Avery Abbott Jun 22 '14 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.