6

I have three Cisco 2960G switches that I pulled from a working environment. All three of them are experiencing the same problem, so I have a hard time believing they have all simply failed.

Here's the problem:

When I plug in the power, all the ports lights flash once and the SYST, RPS, STAT, DUPLX and SPEED lights come on for a second. Then all the lights turn off, except for the SYST light which stays green. Nothing ever appears on the serial console. Holding the Mode button while applying power does nothing.

Do I really have 3 switches that all died at the same time?

  • Serial or USB console? If the config hasn't been reset, it could be locked to one or the other. Does the switch actually function (link, forward traffic)? – Ricky Beam Jun 23 '14 at 16:37
  • Serial console. The switch does not indicate link and devices that are connected do not indicate link, either. – longneck Jun 23 '14 at 16:56
  • I'm also facing the same problem with cisco catalyst 2960G. When I power ON the switch all LED goes green continuously except SYST led shows orange color. Console port also not working. But I found one solution for this when I heatup the board then after switch goes up and working fine and when i restart the switch, again same problem appears. – user21618 Dec 28 '15 at 8:10
7

Open a TAC case as these may be affected by this Field Notice.

This revolves around a known memory issue by parts from a particular supplier that have a high failure rate. These parts have been included in many different platforms including many models of the 2960 line. You can find the main page discussing this issue and providing a number of field notices here.

In particular, the failure can occur during normal operation, but won't interrupt service. It is only after the devices have been power cycled that they fail to boot.

Specifically to your issue, would be this excerpt:

The failure symptom is observed when the switch fails to boot up with no console response (no characters are written to the console).

  • 1
    +2 Even though it was in my email some time ago, I'd completely forgotten about The Big Memory Fiasco(tm). – Ricky Beam Jun 23 '14 at 20:49
  • @RickyBeam, it is a good one to keep stuck to the back of your mind. It is so broad reaching and affects so many different platforms you are almost bound to hit it if you use Cisco at any scale. I know I have already hit it on a ASA 5505 and 2960 myself. – YLearn Jun 23 '14 at 21:56
  • None of mine have, but I "upgrade" memory just about everything. (even soldered more memory in the 1760) – Ricky Beam Jun 23 '14 at 22:16
  • 1
    @RickyBeam, as I understand it, it isn't just the system memory or storage. Rather this can include something attached to the PCB. This is why they RMA them directly and don't offer a system memory replacement option. – YLearn Jun 23 '14 at 22:20
  • 2960G: yes. 28xx and 38xx are memory swaps. ASA SSM: swap, odd as they're DIMM based. – Ricky Beam Jun 24 '14 at 2:00
6

This is not a fix but a workaround to get your switch boot up. It did worked on my 2960G.

WS-2960G has a reset switch SW2 that hasn't been soldered (see picture). By shorting those two soldering points couple times I managed to boot the switch correctly.

It appears that the affected memory will not initialize immediately after the switch is powered, but it will more likely initialize once the power is there and the hard reset applied.

WS-2960G-48 boot

  • This is also true for the regular 2960 ones. And: Oh a FLUKE DMM. :D – sjas Aug 4 '15 at 20:26
  • After further testing it turns out that the DRAM goes bad in those switches. If you have decent soldering skills, you can find the same memory in the Cisco ASA55xx series DRAM memory modules and swap it. That's what I did and it fixed the problem. – Tomeq Aug 5 '15 at 20:59
1

You can fix the DRAM issue heating up the DRAM module using a simple heating gun. Just fixed 1 switch using this method. The issue involves the welding points of the DRAM modules, so you don't need to replace them.

0

The reset SW2 didn't work for me however the heatgun trick worked. What I did was open the cover of the switch c3750 plug in the console cable, and power, started putty. Then I heated up the memory for a few seconds with the switch still on I did a hard reset by jumping SW2 and that worked for me. Now I can access the switch.

Thank you very much

protected by Community Jun 7 at 19:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.