7

The topology diagram below shows multiple CPE devices, each has multiple WAN sub-interface that are dot1q tagged as VLAN 10 and 20 in this example. The PE ME3600 devices has an SVI with an IP address in a /24 range in VLAN 20 and each CPE has a WAN interface encapsualted in VLAN 20 within the same /24. This topology is all configured an working just fine. A CPE can ping .1 and the PE can ping .10 for example.

The layer 2 aggregation device adds a QinQ outer tag to each CPE connection so that at the PE device each layer 2 connection can be differenciated between despite trunking the same VLANs to each CPE with their IPs being in a /24.

enter image description here

The config the ME3600 port is as follows;

interface GigabitEthernet0/1
 switchport trunk allowed vlan none
 switchport mode trunk
 service instance 11 ethernet
  description cust1-LAN
  encapsulation dot1q 101 second-dot1q 10
  rewrite ingress tag pop 2 symmetric
  bridge-domain 10
 !
 service instance 101 ethernet
  description cust1-MGMT
  encapsulation dot1q 101 second-dot1q 20
  rewrite ingress tag pop 2 symmetric
  bridge-domain 20
 !
 service instance 12 ethernet
  description cust2-LAN
  encapsulation dot1q 102 second-dot1q 10
  rewrite ingress tag pop 2 symmetric
  bridge-domain 10
 !
 service instance 102 ethernet
  description cust21-MGMT
  encapsulation dot1q 102 second-dot1q 20
  rewrite ingress tag pop 2 symmetric
  bridge-domain 20
 !
interface Vlan20
 ip address 10.10.10.1 255.255.255.0

What I want to know is;

How can I see the outer tag the ME3600 will apply to frames sent out towards one of the CPEs, lets say 10.10.10.10? Something like show ip cef exact-route or show ip arp that shows the path the traffic will take through the EFPs and EVC back towards the CPE?

The test scenario is that I want to see what outer tag will be applied by the PE device when sending taffic to 10.10.10.15, the 2nd CPE (which allows me to verify that 10.10.10.15 came in on VLAN 102 and was correctly encapsulated from the downstream layer 2 aggregation device which is not Cisco and out of the scope of this question - I'm looking solely at the ME3600)

If I look at the ARP entry for the CPE 10.10.10.10 for example I get output like the following;

show ip arp 10.10.10.10
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.10.10.10             4   0001.1111.1111  ARPA   Vlan20

With the QinQ scenario above the sevice instance under gi0/1 strips off outer VLAN 100 and inner VLAN 20 then bridges to SVI 20. The 3600 must have recorded the way that traffic came in through the EVC to send it back, where can I see that?

10

As soon as I offer a bounty I find the answer, typical!

The magic commaned I needed is show mac-address-table bridge-domain 20

ME3600#show mac-address-table bridge-domain 20
          Mac Address Table
-------------------------------------------

BD      Mac Address       Type        Ports
----    -----------       --------    -----
20      1111.2222.96e2    DYNAMIC     Gi0/1+Efp101
20      1111.2222.3c8e    DYNAMIC     Gi0/1+Efp20
20      1111.2222.4b59    DYNAMIC     Gi0/1+Efp102
  • Here we can see the first MAC is learnt from customer one via service instance 101 (buy looking at service instance 101 on gi0/1 I can see the outer tag will be VLAN ID 101).
  • The second MAC is learnt from a native VLAN 20 on the interface without QinQ
  • The last MAC is learnt from customer 2 via service instance 102 (again by looking at service instance 102 on gi0/1 I see the outer tag will be VLAN ID 102).
1
  • 1
    Congrats you just re-earned the points you spent on the bonus :)
    – This
    Jun 27 '14 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.