1

I have three EX2200c switches. I want use one of them as a core switch and the other two as access layer switches. I created VLANs on all switches, set uplink ports as trunk-mode and all others as access ports. I also set an IP address on all VLANs on the core switch.

I also set up DHCP on the core switch, but I can't get an IP address when computers connect to either access switch.

Even when I manually set the IP address on the computer I can't ping hosts within the same vlan.

So what did I miss ? :)

4
  • 2
    You need to post your configurations (or relevant portions) for us to answer this intelligently.
    – Ryan Foley
    Jun 25, 2014 at 19:33
  • Can you ping hosts on the same VLAN on the same physical switch? If so, check your trunks. Jul 26, 2014 at 3:59
  • On your Core Switch, Could you please provide the output of the following: show interface terse | no-more show vlans | no-more show route | no-more Try a rapid ping to one of the IRB(RVI), created on the Core Switch, from one of the hosts. Capture the output of the following on your Core Switch (CLI mode): monitor traffic no-resolve interface < your_interface_name_here > The above data would help investigate your problem better. The questions which come to my mind on see
    – gsinha
    Aug 15, 2014 at 15:42
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 10, 2017 at 4:38

1 Answer 1

2

Here's a sample config pulled from my own home setup. It's the DHCP, VLAN & Interface part of the config, you can use it as a starting point

system {
    services {
        dhcp {
            domain-name [put your domain];
            name-server {
                [ns1 ip];
                [ns2 ip];
            }
            pool 192.168.1.0/24 {
                address-range low 192.168.1.100 high 192.168.1.200;
                router {
                    192.168.1.1;
                }
            }
            pool 192.168.2.0/24 {
                address-range low 192.168.2.100 high 192.168.2.200;
                router {
                    192.168.2.1;
                }
            }
            pool 192.168.3.0/24 {
                address-range low 192.168.3.100 high 192.168.3.200;
                router {
                    192.168.3.1;
                }
            }
        }
    }
}
interfaces {
    ge-0/0/0 {
        description "Access Switch 1";
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ VLAN1 VLAN2 VLAN3 ];
                }
            }
        }
    }
    ge-0/0/1 {
        description "Access Switch 2";
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ VLAN1 VLAN2 VLAN3 ];
                }
            }
        }
    }
    vlan {
        unit 1 {
            family inet {
                address 192.168.1.1/24;
            }
        }
        unit 2 {
            family inet {
                address 192.168.2.1/24;
            }
        }
        unit 3 {
            family inet {
                address 192.168.3.2/24;
            }
        }
    }
}
vlans {
    VLAN1 {
        vlan-id 1;
        l3-interface vlan.1;
    }
    VLAN2 {
        vlan-id 2;
        l3-interface vlan.2;
    }
    VLAN3 {
        vlan-id 3;
        l3-interface vlan.3;
    }
}
1
  • I did all of this my old config. But fail :) Maybe I missed something. Thanks. I will try again Jun 26, 2014 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.