2

The steps of this manual have been executed in order to configure SSH.

Once SSH has been configured, how to access the switch from a computer using SSH?

The following steps have been executed in order to assign an IP to a switch and subsequently connect to it.

An IP has been assigned to a Cisco Layer3 switch.

interface FastEthernet0
 ip address 20.40.60.80 255.255.255.0
!

A computer (20.40.60.81/24) is connected to Gi0/1

interface GigabitEthernet0/1
!

However, neither from the switch to the computer nor vice versa a ping is successful.

1
  • Are you able to post the entire switch config (sanitized)? – some_guy_long_gone Jul 8 '14 at 13:04
8
interface FastEthernet0
  switchport
  switchport mode access
  switchport access vlan 1
!
interface GigabitEthernet0/1
  switchport
  switchport mode access
  switchport access vlan 1
!
interface vlan 1
  ip address 20.40.60.80 255.255.255.0
!

This should be the bare minimum configuration to get your scenario working, at least some IP connectivity.

The reason it is not working right now is because those two interfaces are in separate broadcast domains, isolating one Ethernet data-link from another. The above configuration assigns the IP address to the SVI in VLAN 1 and places both ports into VLAN 1.

Also, the default configuration applied to Ethernet interfaces would work as well...

!
default interface FastEthernet0
default interface GigabitEthernet0/1
!
2
  • Pinging the Switch works after assigning the IP address to VLAN 1. Thank you. – 030 Jul 8 '14 at 13:21
  • Fa0 is probably the management port. Normal interfaces would have the Fa0/x naming convention. – cpt_fink Jul 9 '14 at 5:28
2

Assign an IP to the management interface

switch(config)# interface ethernet 2/1

switch(config-if)# no switchport

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

Also,

line vty 0 4

Router(config-line)#privilege level 15

Router(config-line)#login local

Router(config-line)#transport input telnet ssh

Router(config-line)#exit

and make sure you generate an RSA key otherwise SSH is not secure it is just telnet =p generate RSA then specify the length of the key 1024 or 2048 are good

crypto key generate rsa

How many bits in the modulus 1024 2048

CustomerRouter(config)#exit

currently you have no routing occuring, you have layer two, with a management IP on your Vlan, you would need to configure a RVI or routing protocol to get things happening, as you see there is nothing in the connfig on interface 0/1

0

For the Switches: Configure three VLANs and assign IPv4 to the interfaces. Two VLANs for data and one for management. Do not use the Default VLAN. Assign the ports to the Correct VLAN. Configure the Trunk to the Router, this should be setup as a router on a stick configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.