2

I have a cisco ASA 5515 and a Cisco 3850 switch in our network. I'm a sys admin by trade and know enough to get a switch up and running but the asa thing is confusing me a bit. This hardware was bought by someone who then left the company and so now I'm tasked with setting it up.

Right now we have a /29 say

9.10.11.24/29

Our private ip space is

10.128.0.0/16

So our asa is online via the management network on

10.128.7.103

Our 3850 is also online via

10.128.7.101

I'm having some issues assigning out public ip space to the ASA and then routing vlan traffic to it.

Right now my vlans are attached to the 3850 like

interface Vlan60
 ip address 10.128.60.1 255.255.255.0
!
interface Vlan70
 ip address 10.128.70.1 255.255.255.0
!

Routing on the 3850 looks like

ip route 0.0.0.0 0.0.0.0 10.128.7.1

The 10.128.7.1 is our old datacenter we are moving away from.. Ideally I'd like to route all traffic out via the ASA.

So it's like

internet <--> ASA <--> 3850 <--> internal lans.

Not sure what I'm really missing to tackle this.

ASA Config

asa# show run
: Saved
:
ASA Version 9.1(1)
!
hostname asa
names
!
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 70.42.246.25 255.255.255.248
!
interface GigabitEthernet0/1
 nameif inside
 security-level 0
 ip address 10.128.8.1 255.255.255.0
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 description STATE Failover Interface
!
interface GigabitEthernet0/5
 description LAN Failover Interface
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 10.128.7.103 255.255.255.0
!
boot system disk0:/asa911-smp-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns server-group DefaultDNS
 domain-name sjc.recurly.net
access-list global_access extended permit icmp any any
pager lines 24
logging enable
logging monitor debugging
logging buffered debugging
logging trap debugging
logging asdm informational
logging host management 10.128.7.54
mtu management 1500
mtu outside 1500
mtu inside 1500
ip verify reverse-path interface outside
failover
failover lan unit primary
failover lan interface folink GigabitEthernet0/5
failover key *****
failover link statelink GigabitEthernet0/4
failover interface ip folink 172.27.48.1 255.255.255.0 standby 172.27.48.2
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
access-group global_access global
route outside 0.0.0.0 0.0.0.0 65.42.246.30 1
route management 10.113.0.0 255.255.0.0 10.128.7.1 1
route management 10.128.0.0 255.255.0.0 10.128.7.1 1
route management 10.242.0.0 255.255.0.0 10.128.7.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server radius-group protocol radius
 accounting-mode simultaneous
 merge-dacl before-avpair
aaa-server radius-group (management) host 10.128.7.81
 key *****
 authentication-port 1812
 accounting-port 1813
user-identity default-domain LOCAL
aaa authentication http console radius-group LOCAL
aaa authentication ssh console radius-group LOCAL
aaa authorization command LOCAL
http server enable
http 10.0.0.0 255.0.0.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 management
ssh timeout 5
ssh version 2
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 10.128.7.101 source management
username shon password Vp4yQWvnJ8bKI5Lz encrypted
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:1fd56c8cffa842a1390f7b3b366852a4
: end
2
  • 1
    When you say "management" network, do you mean "inside" interface? If not, what is the address of the inside interface of the ASA?
    – Ron Trunk
    Jul 9, 2014 at 17:52
  • right now I have the inside interface which is 0/1 set to 10.128.17.106
    – Mike
    Jul 9, 2014 at 18:22

1 Answer 1

6

Enter the following commands on your 3850:

no ip route 0.0.0.0 0.0.0.0 10.128.7.1
ip route 0.0.0.0 0.0.0.0 10.128.17.106

This will direct Internet traffic to your firewall. If you haven't set up NAT on your firewall yet, post a copy of your firewall config and we can modify that for you too.

3
  • thanks.. i added the ASA config. I also switched 10.128.17.1 with 10.128.8.1 on int 0/1.. The funny thing is on the switch when i do a show arp I don't see IP in the arp table
    – Mike
    Jul 10, 2014 at 3:03
  • ok scratch the arp.. its showing up on my 3850 now I see 10.128.8.1 I just don't see the 10.128.8.2 ip i gave the port-group on the 3850 on the ASA.. but I might have not understood how its all setup
    – Mike
    Jul 10, 2014 at 3:08
  • Send me an email (address is in my profile). There is more to do here than can fit easily in a comment.
    – Ron Trunk
    Jul 10, 2014 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.