4

I am having problems connecting from some of my switches to the router/internet. I have a Cisco 1900 series router with four different 2960 series switches. All Gigabit Ethernet ports are configured to be trunk. The router is connected to FF_Switch using the Gig0/1 port while the Gig0/2 port is connected to a Fiber/T Transceiver(Fiber connection converted to RJ45 using Fiber/T Transceiver) passed over fiber connection to another Fiber/T Transceiver, from which it is connected to Gig0/1 of SVOSwitch2. Gig0/2 of SVOSwitch2 connects to Gig0/1 of SVOSwitch3. Gig0/2 of SVOSwitch3 connects to Gig0/1 of SVOSwitch1.

SVOSwitch1 has the ports on VLAN1 and 3, SVOSwitch2 has the ports on VLAN 4 and 5 while SVO Switch 3 has the ports on VLAN 5 and 6.

The problem is that whenever I connect to any of the ports, I can only connect and get DHCP on the ports on VLAN 1 and 4.

The configuration for the router is given below;

    ip dhcp pool FF_SWITCH
network 192.168.1.0 255.255.255.0
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 
default-router 192.168.1.1 
!
ip dhcp pool SVOSwitch1
network 192.168.3.0 255.255.255.0
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 
default-router 192.168.3.1 
!
ip dhcp pool SVOSwitch2
network 192.168.4.0 255.255.255.0
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 
default-router 192.168.4.1 
!
ip dhcp pool SVOSwitchVlanPool1
network 192.168.6.0 255.255.255.0
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 
default-router 192.168.6.1 
!
ip dhcp pool SVOSwitch3
network 192.168.5.0 255.255.255.0
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 
default-router 192.168.5.1 
!
ip dhcp pool SVOSwitchVlanPool2
network 192.168.7.0 255.255.255.0
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 
default-router 192.168.7.1

interface GigabitEthernet0/0
description ### WAN INTERFACE ###
ip address xxx.xxx.xxx.xxx 255.255.xxx.xxx
ip flow ingress
ip nat outside
ip virtual-reassembly in
duplex full
speed auto
no cdp enable
!
interface GigabitEthernet0/1
description ### LAN INTERFACE ###
no ip address
ip flow ingress
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
description ###1st FLR NETWORK ###
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
ip access-group 110 in
ip accounting output-packets
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.3
description ### TNB WIRELESS NETWORK ###
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
ip access-group 110 in
ip accounting output-packets
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.4
description ### TNB 1ST WING NETWORK ###
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0
ip access-group 110 in
ip accounting output-packets
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.5
description ### TNB 2ND WING NETWORK ###
encapsulation dot1Q 5
ip address 192.168.5.1 255.255.255.0
ip access-group 110 in
ip accounting output-packets
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.6
description ### TNB PENTHOUSE NETWORK ###
encapsulation dot1Q 6
ip address 192.168.6.1 255.255.255.0
ip access-group 110 in
ip accounting output-packets
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1.7
description ### TNB OTHER NETWORK ###
encapsulation dot1Q 7
ip address 192.168.7.1 255.255.255.0
ip access-group 110 in
ip accounting output-packets
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0/0
switchport access vlan 100
no ip address
!
interface GigabitEthernet0/0/1
no ip address
!
interface GigabitEthernet0/0/2
no ip address
!
interface GigabitEthernet0/0/3
no ip address
!
interface Vlan1
no ip address
!
interface Vlan100
ip address xxx.xxx.xxd.ddd xxx.xxx.xxx.xxx
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip flow-export source GigabitEthernet0/1
ip flow-export version 9
ip flow-export destination 192.168.1.120 9996
!
ip nat inside source list NAT interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 aaa.aaa.aaa.aaa
!
ip access-list standard NAT
permit 192.168.1.0 0.0.0.255
permit 192.168.3.0 0.0.0.255
permit 192.168.4.0 0.0.0.255
permit 192.168.5.0 0.0.0.255
permit 192.168.6.0 0.0.0.255
!
!
!
snmp-server community public RO
snmp-server community private RW
snmp-server ifindex persist

Please what am I doing wrong?

EDIT:

As Avery Abbott requested, here is it from SVOSwitch3

SVOSwitch3#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    
5    VLAN0005                         active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6
6    VLAN0006                         active    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 


SVOSwitch3#show interface trun    

Port        Mode             Encapsulation  Status        Native vlan
Gi0/1       on               802.1q         trunking      1
Gi0/2       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi0/1       1-4094
Gi0/2       1-4094

Port        Vlans allowed and active in management domain
Gi0/1       1,5-6
Gi0/2       1,5-6

Port        Vlans in spanning tree forwarding state and not pruned
Gi0/1       1,5-6
Gi0/2       1,5-6
SVOSwitch3#show run int gi0/1
Building configuration...

Current configuration : 59 bytes
!
interface GigabitEthernet0/1
 switchport mode trunk
end

SVOSwitch3#show run int gi0/2
Building configuration...

Current configuration : 59 bytes
!
interface GigabitEthernet0/2
 switchport mode trunk
end

And for the running config, I have,

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SVOSwitch3
!
boot-start-marker
boot-end-marker
!
enable secret 5 1/
!
!
!
no aaa new-model
system mtu routing 1500
!
!
!
!         
crypto pki trustpoint TP-self-signed-14
     enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-14
 revocation-check none
 rsakeypair TP-self-signed-14
!
!
crypto pki certificate chain TP-self-signed-14
  quit
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
 switchport access vlan 5
!
interface FastEthernet0/2
 switchport access vlan 5
!
interface FastEthernet0/3
 switchport access vlan 5
!
interface FastEthernet0/4
 switchport access vlan 5
!
interface FastEthernet0/5
 switchport access vlan 5
!
interface FastEthernet0/6
 switchport access vlan 5
!
interface FastEthernet0/7
 switchport access vlan 6
!
interface FastEthernet0/8
 switchport access vlan 6
!
interface FastEthernet0/9
 switchport access vlan 6
!
interface FastEthernet0/10
 switchport access vlan 6
!         
interface FastEthernet0/11
 switchport access vlan 6
!
interface FastEthernet0/12
 switchport access vlan 6
!
interface FastEthernet0/13
 switchport access vlan 6
!
interface FastEthernet0/14
 switchport access vlan 6
!
interface FastEthernet0/15
 switchport access vlan 6
!
interface FastEthernet0/16
 switchport access vlan 6
!
interface FastEthernet0/17
 switchport access vlan 6
!
interface FastEthernet0/18
 switchport access vlan 6
!
interface FastEthernet0/19
 switchport access vlan 6
!
interface FastEthernet0/20
 switchport access vlan 6
!
interface FastEthernet0/21
 switchport access vlan 6
!
interface FastEthernet0/22
 switchport access vlan 6
!
interface FastEthernet0/23
 switchport access vlan 6
!
interface FastEthernet0/24
 switchport access vlan 6
!
interface GigabitEthernet0/1
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.1.9 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.5.1
ip http server
ip http secure-server

That was picked from the SVOSwitch3.

  • 3
    You stated that you're using Gi0/1 for FF_Switch and Gi0/2 for SVOSwitch2, but your router config says Gi0/0 and Gi0/1. Does SVOSwitch2 have all the VLANs created and trunked on Gi0/1 and Gi0/2? Can you provide a "show vlan brief", "show interface trunking", "show run int gi0/1", and "show run int gi0/2" all from SVOSwitch2? – Avery Abbott Jul 15 '14 at 17:14
  • 1
    One thing you are doing wrong: snmp RW is "private" with no ACL on it. You should change the RO and RW communities ASAP as well as applying an snmp ACL on them – Mike Pennington Jul 15 '14 at 18:31
  • Avery Abbott, the requested output has been provided. Kindly advice. – Olanrewaju Olukosi Jul 16 '14 at 6:30
2

All thanks to the comment by Avery Abbott, I was able to solve the problem by making sure that all [cascading] switches have the corresponding vlans created so that the trunks can carry data for that vlan across the switch.

thanks all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.