Skip to main content
edited title
Link
Ron Trunk
  • 68k
  • 5
  • 66
  • 126

Packet Tracer Why do I lose my OSPF routes?

Post Reopened by Ron Maupin
added 4465 characters in body
Source Link
Daniel
  • 81
  • 2
  • 8

R0

Router#show run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.7 area 0
 network 192.168.2.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9

line con 0
!
line aux 0
!
line vty 0 4
 login
end

R1

Router#show run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.4.1 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.2.0 0.0.0.7 area 0
 network 192.168.4.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R2

Router#sh run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.3.2 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.4.2 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.4.0 0.0.0.7 area 0
 network 192.168.3.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R3

Router#sh run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.2 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.3.0 0.0.0.7 area 0
 network 192.168.1.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R0

Router#show run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.7 area 0
 network 192.168.2.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9

line con 0
!
line aux 0
!
line vty 0 4
 login
end

R1

Router#show run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.4.1 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.2.0 0.0.0.7 area 0
 network 192.168.4.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R2

Router#sh run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.3.2 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.4.2 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.4.0 0.0.0.7 area 0
 network 192.168.3.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R3

Router#sh run
Building configuration...

Current configuration : 692 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.2 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.3.0 0.0.0.7 area 0
 network 192.168.1.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
I addted ospf configuration of all 4 routers,
Source Link
Daniel
  • 81
  • 2
  • 8

I created little network and set up OSPF protocol. When I took away one ethernet cable I was hoping to see change in routing table...

But what happened was that the router only showed directly connected networks and none of the OSPF.

Just a note: It still had other routers connected to it. All I removed was one cable out of the network.enter image description hereenter image description here

This is R0 routing table when everything is connected.

C     192.168.1.0/2429 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/1
     192.168.2.0/29 is subnetted, 1 subnets
C       192.168.2.0/24 is directly connected, FastEthernet0/0
     192.168.3.0/29 is subnetted, 1 subnets
O       192.168.3.0/24 [110/2] via 192.168.1.2, 00:00:2249, FastEthernet0/1
     192.168.4.0/29 is subnetted, 1 subnets
O       192.168.4.0/24 [110/2] via 192.168.2.2, 00:00:2249, FastEthernet0/10

This s R0 routing table when I disconnect R1 and R0 (All the ospf networks dissapear)

C     192.168.1.0/2429 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/01

The question is why is it happening. Shouldn't it stay the same except for the one that is disconnected?

R0
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.7 area 0
Router(config-router)#network 192.168.2.0 0.0.0.7 area 0

R1
Router(config)#router ospf 1
Router(config-router)#network 192.168.2.0 0.0.0.7 area 0
Router(config-router)#network 192.168.4.0 0.0.0.7 area 0

R2
Router(config)#router ospf 1
Router(config-router)#network 192.168.4.0 0.0.0.7 area 0
Router(config-router)#network 192.168.3.0 0.0.0.7 area 0

R3
Router(config)#router ospf 1
Router(config-router)#network 192.168.3.0 0.0.0.7 area 0
Router(config-router)#network 192.168.1.0 0.0.0.7 area 0

I created little network and set up OSPF protocol. When I took away one ethernet cable I was hoping to see change in routing table...

But what happened was that the router only showed directly connected networks and none of the OSPF.

Just a note: It still had other routers connected to it. All I removed was one cable out of the network.enter image description here

This is R0 routing table when everything is connected.

C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/1
O    192.168.3.0/24 [110/2] via 192.168.1.2, 00:00:22, FastEthernet0/0
O    192.168.4.0/24 [110/2] via 192.168.2.2, 00:00:22, FastEthernet0/1

This s R0 routing table when I disconnect R1 and R0 (All the ospf networks dissapear)

C 192.168.1.0/24 is directly connected, FastEthernet0/0

The question is why is it happening. Shouldn't it stay the same except for the one that is disconnected?

I created little network and set up OSPF protocol. When I took away one ethernet cable I was hoping to see change in routing table...

But what happened was that the router only showed directly connected networks and none of the OSPF.

Just a note: It still had other routers connected to it. All I removed was one cable out of the network.enter image description here

This is R0 routing table when everything is connected.

     192.168.1.0/29 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/1
     192.168.2.0/29 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet0/0
     192.168.3.0/29 is subnetted, 1 subnets
O       192.168.3.0 [110/2] via 192.168.1.2, 00:00:49, FastEthernet0/1
     192.168.4.0/29 is subnetted, 1 subnets
O       192.168.4.0 [110/2] via 192.168.2.2, 00:00:49, FastEthernet0/0

This s R0 routing table when I disconnect R1 and R0 (All the ospf networks dissapear)

     192.168.1.0/29 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/1

The question is why is it happening. Shouldn't it stay the same except for the one that is disconnected?

R0
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.7 area 0
Router(config-router)#network 192.168.2.0 0.0.0.7 area 0

R1
Router(config)#router ospf 1
Router(config-router)#network 192.168.2.0 0.0.0.7 area 0
Router(config-router)#network 192.168.4.0 0.0.0.7 area 0

R2
Router(config)#router ospf 1
Router(config-router)#network 192.168.4.0 0.0.0.7 area 0
Router(config-router)#network 192.168.3.0 0.0.0.7 area 0

R3
Router(config)#router ospf 1
Router(config-router)#network 192.168.3.0 0.0.0.7 area 0
Router(config-router)#network 192.168.1.0 0.0.0.7 area 0
Post Closed as "Needs more focus" by Ron Maupin
deleted 24 characters in body
Source Link
Ron Maupin
  • 101.1k
  • 26
  • 123
  • 199
Loading
added 185 characters in body
Source Link
Daniel
  • 81
  • 2
  • 8
Loading
added 398 characters in body
Source Link
Daniel
  • 81
  • 2
  • 8
Loading
Source Link
Daniel
  • 81
  • 2
  • 8
Loading