Skip to main content
Commonmark migration
Source Link

I am trying to setup a network that includes an EtherChannel link between two Cisco Layer 3 switches (Catalyst 3750). I am using a collapsed core hierarchical network.

collapsed core topology

The picture above is my topology. On my layer 2 access switches (S1, S2, S3) I have several hosts connected right now, on several VLANs. My issue tho is that a host on for example S2, can't communicate with L3-1 through the EtherChannel between L3-1 and L3-2. I've tried making it a Layer 3 EtherChannel with IP's, and I can ping across, but it's like it wont propagate my tagged VLAN traffic.

Example:

I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1.

 

I make GigabitEthernet2/0/1 switchport access on VLAN 20.

 

HOST-B is connected to a switchport access VLAN 20 port on S2.

 

HOST-B tries to ping L3-2. Succesful.

 

HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

PS. I also have HSRP setup on the Layer 3 switches, for all my VLANs. Also I have a Main Windows Server 2016 Domain Controller connected to L3-1 and a Backup connected to L3-2.

Let me know if you need the IP scope.

I appreciate all help! I just want to know what I have to think of/be sure of is working, to make this network communicate. Any help that can guide me to what i can do to get traffic all the way to the WAN, and so that my hosts on S1, S2 and S3 can connect to the internet. Much appreciated.

CONFIGURATION:

L3-1

Port-Channel:

!
interface Port-channel1
 no switchport
 ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
 no switchport
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
 no switchport
 no ip address
 channel-group 1 mode desirable
!

L3-2 has same configuration on same ports and channel-group. It's IP address is 172.16.0.2 255.255.255.252 instead.

VLAN-config: show vlan brief in cisco terminal

All links between layer-3 and layer-2 switches are trunks. A snippet from L3-2: interface overview from layer 3 switch

S1

VLAN-config: vlan overview on switch

S2

VLAN-config: vlan overview on switch

S3

VLAN-config: vlan overview on switch

I am trying to setup a network that includes an EtherChannel link between two Cisco Layer 3 switches (Catalyst 3750). I am using a collapsed core hierarchical network.

collapsed core topology

The picture above is my topology. On my layer 2 access switches (S1, S2, S3) I have several hosts connected right now, on several VLANs. My issue tho is that a host on for example S2, can't communicate with L3-1 through the EtherChannel between L3-1 and L3-2. I've tried making it a Layer 3 EtherChannel with IP's, and I can ping across, but it's like it wont propagate my tagged VLAN traffic.

Example:

I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1.

 

I make GigabitEthernet2/0/1 switchport access on VLAN 20.

 

HOST-B is connected to a switchport access VLAN 20 port on S2.

 

HOST-B tries to ping L3-2. Succesful.

 

HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

PS. I also have HSRP setup on the Layer 3 switches, for all my VLANs. Also I have a Main Windows Server 2016 Domain Controller connected to L3-1 and a Backup connected to L3-2.

Let me know if you need the IP scope.

I appreciate all help! I just want to know what I have to think of/be sure of is working, to make this network communicate. Any help that can guide me to what i can do to get traffic all the way to the WAN, and so that my hosts on S1, S2 and S3 can connect to the internet. Much appreciated.

CONFIGURATION:

L3-1

Port-Channel:

!
interface Port-channel1
 no switchport
 ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
 no switchport
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
 no switchport
 no ip address
 channel-group 1 mode desirable
!

L3-2 has same configuration on same ports and channel-group. It's IP address is 172.16.0.2 255.255.255.252 instead.

VLAN-config: show vlan brief in cisco terminal

All links between layer-3 and layer-2 switches are trunks. A snippet from L3-2: interface overview from layer 3 switch

S1

VLAN-config: vlan overview on switch

S2

VLAN-config: vlan overview on switch

S3

VLAN-config: vlan overview on switch

I am trying to setup a network that includes an EtherChannel link between two Cisco Layer 3 switches (Catalyst 3750). I am using a collapsed core hierarchical network.

collapsed core topology

The picture above is my topology. On my layer 2 access switches (S1, S2, S3) I have several hosts connected right now, on several VLANs. My issue tho is that a host on for example S2, can't communicate with L3-1 through the EtherChannel between L3-1 and L3-2. I've tried making it a Layer 3 EtherChannel with IP's, and I can ping across, but it's like it wont propagate my tagged VLAN traffic.

Example:

I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1.

I make GigabitEthernet2/0/1 switchport access on VLAN 20.

HOST-B is connected to a switchport access VLAN 20 port on S2.

HOST-B tries to ping L3-2. Succesful.

HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

PS. I also have HSRP setup on the Layer 3 switches, for all my VLANs. Also I have a Main Windows Server 2016 Domain Controller connected to L3-1 and a Backup connected to L3-2.

Let me know if you need the IP scope.

I appreciate all help! I just want to know what I have to think of/be sure of is working, to make this network communicate. Any help that can guide me to what i can do to get traffic all the way to the WAN, and so that my hosts on S1, S2 and S3 can connect to the internet. Much appreciated.

CONFIGURATION:

L3-1

Port-Channel:

!
interface Port-channel1
 no switchport
 ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
 no switchport
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
 no switchport
 no ip address
 channel-group 1 mode desirable
!

L3-2 has same configuration on same ports and channel-group. It's IP address is 172.16.0.2 255.255.255.252 instead.

VLAN-config: show vlan brief in cisco terminal

All links between layer-3 and layer-2 switches are trunks. A snippet from L3-2: interface overview from layer 3 switch

S1

VLAN-config: vlan overview on switch

S2

VLAN-config: vlan overview on switch

S3

VLAN-config: vlan overview on switch

Tweeted twitter.com/StackNetworkEng/status/1182536465227636736
edited tags
Link
Ron Maupin
  • 101.1k
  • 26
  • 123
  • 199

I am trying to setup a network that includes aan EtherChannel link between two Cisco Layer 3 switches (Catalyst 3750). I am using a collapsed core hieriarchicalhierarchical network.

The picture above is my topology. On my layer 2 access switches (S1, S2, S3) I have several hosts connected right now, on several VLANs. My issue tho is that ana host on for example S2, can't talkcommunicate with L3-1 through the EtherChannel between L3-1 and L3-2. I've tried making it a Layer 3 EtherChannel with IP's, and I can ping across, but it's like it wont propagate my VLAN tagged VLAN traffic.

Example: I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1. I make GigabitEthernet2/0/1 switchport access on VLAN 20. HOST-B is connected to a switchport access VLAN 20 port on S2. HOST-B tries to ping L3-2. Succesful. HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1.

I make GigabitEthernet2/0/1 switchport access on VLAN 20.

HOST-B is connected to a switchport access VLAN 20 port on S2.

HOST-B tries to ping L3-2. Succesful.

HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

PS. I also have HSRP set up atsetup on the Layer 3 switches, for all my VLANs. Also I have a Main Windows Server 2016 Domain Controller connected to L3-1 and a Backup connected to L3-2.

I appreciate all help! I just want to know what I have to think of/be sure of is working, to make this network workcommunicate. Any help that can adviseguide me on what to what i can do to get traffic all the way out to the WAN, and so that my hosts on S1, S2 and S3 can connect to the internet is also. Much appreciated.

L3-1
Port-Channel:
!
interface Port-channel1
no switchport
ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
no switchport
no ip address
channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
no switchport
no ip address
channel-group 1 mode desirable
!

L3-1

Port-Channel:

!
interface Port-channel1
 no switchport
 ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
 no switchport
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
 no switchport
 no ip address
 channel-group 1 mode desirable
!

I am trying to setup a network that includes a EtherChannel link between two Cisco Layer 3 switches (Catalyst 3750). I am using a collapsed core hieriarchical network.

The picture above is my topology. On my layer 2 access switches (S1, S2, S3) I have several hosts connected right now, on several VLANs. My issue tho is that an host on for example S2, can't talk with L3-1 through the EtherChannel between L3-1 and L3-2. I've tried making it a Layer 3 EtherChannel with IP's, and I can ping across, but it's like it wont propagate my VLAN tagged traffic.

Example: I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1. I make GigabitEthernet2/0/1 switchport access on VLAN 20. HOST-B is connected to a switchport access VLAN 20 port on S2. HOST-B tries to ping L3-2. Succesful. HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

PS. I also have HSRP set up at the Layer 3 switches, for all my VLANs. Also I have a Main Windows Server 2016 Domain Controller connected to L3-1 and a Backup connected to L3-2.

I appreciate all help! I just want to know what I have to think of/be sure is working, to make this network work. Any help that can advise me on what to do to get all the way out to the WAN, and so that my hosts on S1, S2 and S3 can connect to the internet is also appreciated.

L3-1
Port-Channel:
!
interface Port-channel1
no switchport
ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
no switchport
no ip address
channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
no switchport
no ip address
channel-group 1 mode desirable
!

I am trying to setup a network that includes an EtherChannel link between two Cisco Layer 3 switches (Catalyst 3750). I am using a collapsed core hierarchical network.

The picture above is my topology. On my layer 2 access switches (S1, S2, S3) I have several hosts connected right now, on several VLANs. My issue tho is that a host on for example S2, can't communicate with L3-1 through the EtherChannel between L3-1 and L3-2. I've tried making it a Layer 3 EtherChannel with IP's, and I can ping across, but it's like it wont propagate my tagged VLAN traffic.

Example:

I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1.

I make GigabitEthernet2/0/1 switchport access on VLAN 20.

HOST-B is connected to a switchport access VLAN 20 port on S2.

HOST-B tries to ping L3-2. Succesful.

HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

PS. I also have HSRP setup on the Layer 3 switches, for all my VLANs. Also I have a Main Windows Server 2016 Domain Controller connected to L3-1 and a Backup connected to L3-2.

I appreciate all help! I just want to know what I have to think of/be sure of is working, to make this network communicate. Any help that can guide me to what i can do to get traffic all the way to the WAN, and so that my hosts on S1, S2 and S3 can connect to the internet. Much appreciated.

L3-1

Port-Channel:

!
interface Port-channel1
 no switchport
 ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
 no switchport
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
 no switchport
 no ip address
 channel-group 1 mode desirable
!
Detailed overview of network setup
Source Link
Roy T.
  • 65
  • 1
  • 1
  • 10
Loading
Source Link
Roy T.
  • 65
  • 1
  • 1
  • 10
Loading