Skip to main content
Bumped by Community user
Bumped by Community user
Bumped by Community user
Bumped by Community user
Bumped by Community user
Bumped by Community user
Bumped by Community user
edited title
Link
Ron Maupin
  • 101.2k
  • 26
  • 123
  • 199

%Cannot Cannot create sub-interfacesubinterface

Bumped by Community user
Bumped by Community user
deleted 37 characters in body
Source Link
Zac67
  • 88.1k
  • 4
  • 73
  • 137

I'm trying to connect 4 networks with 1 router, i created 2 sub-interfaces in the router, when i tried to create the 3rd sub-interface i got this output "%Cannot create sub-interface", this is my topology: https://i.gyazo.com/0d7939a1116e10e3792fe5fd843e35d7.png enter image description here

This is my Router's configuration:

hostname Router
!
ip cef
ip ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/0.10
encapsulation dot 1Q 10
ip address 10.1.1.254 255.255.255.0
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.20
no ip address
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/1
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/2
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/3
swithport mode access
switchport nonegotiate
!
interface Vlan1
no ip address 
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

I need to create 4 networks, each network has a unique VLAN. And add default gateway to each VLAN to make the PC's communicate with each other. I know it's much better to put 1 network only and separate the VLAN's by 1 switch. But i want to use more interfaces in a Router, than Switches.

I'm trying to connect 4 networks with 1 router, i created 2 sub-interfaces in the router, when i tried to create the 3rd sub-interface i got this output "%Cannot create sub-interface", this is my topology: https://i.gyazo.com/0d7939a1116e10e3792fe5fd843e35d7.png

This is my Router's configuration:

hostname Router
!
ip cef
ip ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/0.10
encapsulation dot 1Q 10
ip address 10.1.1.254 255.255.255.0
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.20
no ip address
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/1
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/2
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/3
swithport mode access
switchport nonegotiate
!
interface Vlan1
no ip address 
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

I need to create 4 networks, each network has a unique VLAN. And add default gateway to each VLAN to make the PC's communicate with each other. I know it's much better to put 1 network only and separate the VLAN's by 1 switch. But i want to use more interfaces in a Router, than Switches.

I'm trying to connect 4 networks with 1 router, i created 2 sub-interfaces in the router, when i tried to create the 3rd sub-interface i got this output "%Cannot create sub-interface", this is my topology: enter image description here

This is my Router's configuration:

hostname Router
!
ip cef
ip ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/0.10
encapsulation dot 1Q 10
ip address 10.1.1.254 255.255.255.0
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.20
no ip address
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/1
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/2
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/3
swithport mode access
switchport nonegotiate
!
interface Vlan1
no ip address 
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

I need to create 4 networks, each network has a unique VLAN. And add default gateway to each VLAN to make the PC's communicate with each other. I know it's much better to put 1 network only and separate the VLAN's by 1 switch. But i want to use more interfaces in a Router, than Switches.

Bumped by Community user
Bumped by Community user
Bumped by Community user
added 101 characters in body
Source Link
Muath
  • 17
  • 1
  • 4

enter link description hereI'm I'm trying to connect 4 networks with 1 router, i created 2 sub-interfaces in the router, when i tried to create the 3rd sub-interface i got this output "%Cannot create sub-interface", this is my topology: https://i.gyazo.com/0d7939a1116e10e3792fe5fd843e35d7.png

This is my Router's configuration:

hostname Router
!
ip cef
ip ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/0.10
encapsulation dot 1Q 10
ip address 10.1.1.254 255.255.255.0
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.20
no ip address
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/1
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/2
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/3
swithport mode access
switchport nonegotiate
!
interface Vlan1
no ip address 
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

I need to create 4 networks, each network has a unique VLAN. And add default gateway to each VLAN to make the PC's communicate with each other. I know it's much better to put 1 network only and separate the VLAN's by 1 switch. But i want to use more interfaces in a Router, than Switches.

enter link description hereI'm trying to connect 4 networks with 1 router, i created 2 sub-interfaces in the router, when i tried to create the 3rd sub-interface i got this output "%Cannot create sub-interface", this is my topology: https://i.gyazo.com/0d7939a1116e10e3792fe5fd843e35d7.png

This is my Router's configuration:

hostname Router
!
ip cef
ip ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/0.10
encapsulation dot 1Q 10
ip address 10.1.1.254 255.255.255.0
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.20
no ip address
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/1
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/2
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/3
swithport mode access
switchport nonegotiate
!
interface Vlan1
no ip address 
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

I need to create 4 networks, each network has a unique VLAN. And add default gateway to each VLAN to make the PC's communicate with each other. I know it's much better to put 1 network only and separate the VLAN's by 1 switch. But i want to use more interfaces in a Router, than Switches.

I'm trying to connect 4 networks with 1 router, i created 2 sub-interfaces in the router, when i tried to create the 3rd sub-interface i got this output "%Cannot create sub-interface", this is my topology: https://i.gyazo.com/0d7939a1116e10e3792fe5fd843e35d7.png

This is my Router's configuration:

hostname Router
!
ip cef
ip ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/0.10
encapsulation dot 1Q 10
ip address 10.1.1.254 255.255.255.0
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.20
no ip address
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/1
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/2
swithport mode access
switchport nonegotiate
!
!
interface GigabitEthernet0/1/3
swithport mode access
switchport nonegotiate
!
interface Vlan1
no ip address 
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

I need to create 4 networks, each network has a unique VLAN. And add default gateway to each VLAN to make the PC's communicate with each other. I know it's much better to put 1 network only and separate the VLAN's by 1 switch. But i want to use more interfaces in a Router, than Switches.

added 101 characters in body
Source Link
Muath
  • 17
  • 1
  • 4
Loading
Source Link
Muath
  • 17
  • 1
  • 4
Loading