4

I have three switches connected to each other with two links (one of them is a redundant link using STP), but I have configured EtherChannel so that both the links work together as a bundle,

enter image description here

What i know about EtherChannel is, if we bundle two 100Mbps links together, the speed of the bundle will be 200MBps, but the initial status of both the links must be the same.

Now, Before configuring EtherChannel, the speed of each single Fast Ethernet link was 100Mbps and all links were in full-duplex mode,

but after I configured the links to work as a bundle, the mode of each port-channel interface is changed to half-duplex and the speed is changed to 300mbps instead of 200Mbps.

As you can see in the following output,

show interfaces port-channel 1
Port-channel 1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0030.f22d.b05d (bia 0030.f22d.b05d)
  Description: Trunking with SW_Access1
  MTU 1500 bytes, BW 300000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Half-duplex, 300Mb/s

before configuring the etherchannel, the speed and duplex mode of individual links were 100Mbps, and full-duplex respectively.

Why the mode is changed to half-duplex from full-duplex after configuring EtherChannel ? and how come the speed is 3 times of 100Mbps instead of 2 ?

  • 4
    Can you please add the configuration for your physical interfaces in the port-channel and the port-channel itself. Also too, please add the following show commands, "show etherchannel summary", it could be "show port-channel summary" I can't remember for sure on catalyst. – Jordan Head May 15 '15 at 12:44
  • It's "show etherchannel summary". – Jordan Head May 15 '15 at 12:55
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide your own answer and accept it. – Ron Maupin Aug 7 '17 at 14:07
1

interface po1 defines the link(s) to be half-duplex. (show run int po1)

It's 300Mbps because you have three links assigned (and active) in the channel-group. (show etherchannel 1 port-channel)

| improve this answer | |
  • 1
    i get error when I execute this command, interface port-channel 1 after that i executed duplex full and got the error %Command not available for fiber interfaces. – Riley Willow May 17 '15 at 15:13
  • 1
    @riky, on packet tracer if you aggregate some link (also if inactive), the bandwitch of the portchannel appear to be one link more than the summary of the interfaces bandwitch linked. That's happen also on real machine, or is just a bug of packettracer? tx – feligiotti May 17 '15 at 16:05
1

I suspect you have two separate problems:

A: You have accidentally put 3 ports into the same Port-Channel interface B: One or more of the three is configured to auto-negotiate speed/duplex and one or more of the three is hard set speed/duplex at the other end with negotiation disabled.

This causes negotiation to fail so the switch reverts to half-duplex. If both ends are set to auto-negotiate, my next question is if the problem switch is also connected to a Cisco switch on the other side. If it is not, Cisco has a protocol turned on by default that can foil speed/duplex negotiation with non-Cisco equipment and is generally the reason people hard set links. Cisco by default uses a protocol called DTP to try to determine if the link is a trunk or not on the switch it is talking to. DTP can confuse speed/duplex negotiation with non-Cisco gear and results in people hard setting speed/duplex settings when they don't have to. Since I have no need for DTP in my networks, I turn it off with:

switchport nonegotiate (which is sort of confusing because it has NOTHING to do with speed/duplex negotiation and only turns off DTP TRUNK negotiation) and when you turn that off, suddenly you find that speed/duplex negotiation suddenly starts working rock solid where it used to fail.

DTP was created so that I could take an unconfigured Cisco switch right out of the shipping box, plug it in to a trunk port on an existing switch, and it would learn it was plugged into a trunk port and set itself accordingly. If you do not need that feature, turn it off as it intermittently breaks speed/duplex negotiation in random ways when inter-operating with non-Cisco gear (or NICs on edge devices).

| improve this answer | |
  • "You have accidentally put 3 ports into the same Port-Channel interface" are you sure this is an accident? It sounds like he's trying to increase bandwidth on that link. – Ryan Foley Jun 11 '15 at 22:33
  • OP says two channels in and it went to 300 meg when 200 was expected. Must have a third interface in that port channel someplace. – GeorgeB Jun 11 '15 at 22:49
  • I just assumed he would have known that. I guess that's what I get for assuming. Good catch. – Ryan Foley Jun 11 '15 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.