2

I'm looking to set up InterVLAN routing with one layer 3 switch within Packet Tracer (multiswitch), and then have 12 machines connect to these switch. The 12 machines are split between 4 VLAN's as shown below:

enter image description here

I've also configured the switch to split into four DHCP pools with a default router of the respective VLAN. All machines have picked up DHCP, and I've confirmed this by checking the bindings.

The interfaces for all connections (F0/1-12) have been configured as trunks, and IP routing has also been enabled.

With all that in mind, each machine can communicate with one another in the same VLAN, but not in other VLAN's, so I'm thinking there's something I still need to configure.

Here's my switch configuration:

Current configuration : 2800 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1-L3
!
!
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp excluded-address 192.168.40.1 192.168.40.10
!
ip dhcp pool SALES
network 192.168.10.0 255.255.255.0
default-router 192.168.10.2
ip dhcp pool MARKETING
network 192.168.20.0 255.255.255.0
default-router 192.168.20.2
ip dhcp pool IT
network 192.168.30.0 255.255.255.0
default-router 192.168.30.2
ip dhcp pool HR
network 192.168.40.0 255.255.255.0
default-router 192.168.40.2

ip routing
!

interface FastEthernet0/1
switchport access vlan 10
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode trunk
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode trunk
!
interface FastEthernet0/5
switchport access vlan 20
switchport mode trunk
!
interface FastEthernet0/6
switchport access vlan 20
switchport mode trunk
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode trunk
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode trunk
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode trunk
!
interface FastEthernet0/10
switchport access vlan 40
switchport mode trunk
!
interface FastEthernet0/11
switchport access vlan 40
switchport mode trunk
!
interface FastEthernet0/12
switchport access vlan 40
switchport mode trunk

interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
!
interface Vlan20
ip address 192.168.20.2 255.255.255.0
!
interface Vlan30
ip address 192.168.30.2 255.255.255.0
!
interface Vlan40
ip address 192.168.40.2 255.255.255.0
!

Let me know if I'm missing anything here. Thanks.

3
  • I can't answer that question but none of your interfaces needs to be configured as trunk. These are 4 seperate vlans with the routing done by the switch.
    – Peter
    Commented Mar 23, 2016 at 9:29
  • I was under the impression that in order for InterVLAN routing to happen, they need to go over trunk links. So that's not correct? The links should be configured as access ports instead?
    – BabyPython
    Commented Mar 23, 2016 at 10:49
  • Yes, these are access ports. The switch (which has the function of a router in this case) would remove the ethernet header from the source vlan and slab on a header from the destination vlan. Again, I am not sure if this solves your problem.
    – Peter
    Commented Mar 23, 2016 at 11:18

1 Answer 1

1

You'll need to apply the:

switchport mode access

command on all of the interfaces. As the interfaces are currently configured as trunks and you've got PC's connected to those interfaces, the PC traffic will be hitting the switch on the native VLAN (VLAN 1) because they're not tagging their packets. You will be able to able to confirm this using one or both of these commands:

show mac address-table 
show ip arp 

The above commands will tell you which VLAN the switch sees each of the PC's on.

1
  • No worries at all. Glad I could help.
    – OzNetNerd
    Commented Mar 23, 2016 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.