0

I need to configure a Cisco C1113 (router B) to enable BGP Routing between two networks.

I configured my router B, but I would need to make sure that my configuration is correct...

Here is the connexion I established:

         ASN 50624                      ASN 50600           (vlan2)
          ______                         ______            10.1.0.10
10.0.0.0 |      | 169.254.253.1         |      |           10.1.0.11
---------|   A  |-----------------------|  B   |---------- 10.1.0.14
         |______|         169.254.253.2 |______|           10.1.0.24

connexion between router A and B is done through a SFP Fiber

I would need to make sure that my 4 IPs from ASN 50600 are available over the network 10.0.0.0...

Here is the configuration I set:

for interfaces:

enable
configure terminal
interface GigabitEthernet0/1/0
switchport mode access
switchport access vlan 2
interface vlan 2
ip address 10.1.0.10 255.255.255.0
description TS1
end
configure terminal
interface GigabitEthernet0/1/1
switchport mode access
switchport access vlan 2
interface vlan 2
ip address 10.1.0.11 255.255.255.0
description TS 2
end
configure terminal
interface GigabitEthernet0/1/2
switchport mode access
switchport access vlan 2
interface vlan 2
ip address 10.1.0.24 255.255.255.0
description H Preprod
end
configure terminal
interface GigabitEthernet0/1/3
switchport mode access
switchport access vlan 2
interface vlan 2
ip address 10.1.0.14 255.255.255.0
description H Prod
end

and for BGP:

enable 
configure terminal
ip route 10.1.0.0 255.255.255.0 null 0
interface GigabitEthernet0/0/0.2
encapsulation dot1q 2
ip address 169.254.253.2 255.255.255.0
end
enable
configure terminal
router bgp 50600
redistribute connected
redistribute static
bgp router-id 169.254.253.2
bgp log-neighbor-changes
neighbor 169.254.253.1 remote-as 50624
network 10.1.0.0 mask 255.255.255.0
address-family ipv4 unicast
redistribute connected
neighbor 169.254.253.1 default-originate
neighbor 169.254.253.1 advertisement-interval 25
network 10.1.0.0 mask 255.255.255.0
neighbor 169.254.253.1 activate
exit-address-family
address-family ipv4 multicast
redistribute connected
neighbor 169.254.253.1 default-originate
neighbor 169.254.253.1 advertisement-interval 25
network 10.1.0.0 mask 255.255.255.0
neighbor 169.254.253.1 activate
exit-address-family
neighbor 192.254.253.1 activate
end

As I'm not familiar with BGP Protocol, if you can just help me to make sure that configuration is set correctly ?

18
  • Please show us the configuration from the show running-config command, not what you typed in. That will give us the how the router is actually configured. By the way, you cannot route link-local addresses in the 169.254.0.0/16 range. Routers are forbidden to route packets with either source or destination link-local addressing.
    – Ron Maupin
    Commented Apr 22, 2022 at 12:02
  • 1
    I have to disagree with @RonMaupin here. While you are not supposed to advertise link local addresses, you can use them as you've done here. In fact, this is exactly what the largest cloud provider, Amazon, requires you to do.
    – Ron Trunk
    Commented Apr 22, 2022 at 12:10
  • 1
    The configuration of interface vlan 2 is incorrect. The IP address of the interface will be used as the gateway for all hosts on the VLAN.
    – Ron Trunk
    Commented Apr 22, 2022 at 13:41
  • 1
    No. All the ports on VLAN 2 are layer 2 interfaces and do not have IP addresses. The only interface that does is interface VLAN 2.
    – Ron Trunk
    Commented Apr 22, 2022 at 14:17
  • 1
    You seem to have a typo in your config. It says 192 instead of 169. "neighbor 192.254.253.1 activate".
    – tcpipee
    Commented Apr 22, 2022 at 17:36

1 Answer 1

2

The interfaces configured as switchport do not have IP addresses. The virtual interface (VLAN 2) has an IP address, and that is used as the default gateway for the hosts on the VLAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.