5

I want to take a bunch of VLANs from an interface, trunk them through my network, and spit them out on another end. Sounds like simple Q-in-Q to me.

Problem is one end is a 3600X, and the other is a 4900M. The 4900M is simple. The problem I have is with the 3600X and the EVC. Let's say I want to take VLAN 10 from a customer, and carry it on my network as VLAN 100. I will take them from a port on my 3600X and then carry VLAN 100 along with another bunch of unrelated VLANs through my network.

Can I configure a service instance on the customer facing port encapsulating their VLANs (let's say VLAN 10 for this example), then carry the internal VLAN (100) through on my trunks?

Example, 3600X:

interface GigabitEthernet0/1

description FACING CUSTOMER NETWORK
 switchport trunk allowed vlan none
 switchport mode trunk
 service instance 1 ethernet
  encapsulation dot1q 10
  bridge-domain 100



interface GigabitEthernet0/2

description FACING SERVICE PROVIDER CLOUD
 switchport trunk allowed vlan 100
 switchport mode trunk

Then the 4900M will be:

interface GigabitEthernet0/1

description FACING CUSTOMER NETWORK

switchport access vlan 100

switchport mode dot1q-tunnel



interface GigabitEthernet0/2

description FACING SERVICE PROVIDER CLOUD

switchport trunk allowed vlan 100

switchport mode trunk

This doesn't work. I've tried various configs on the 3600 but can't get it working. I am not sure how to config the EVC properly - on the 3600X I suspect I also have to configure a service instance on the trunk facing into the cloud? This unfortunately isn't preferable as I want this to function as a basic, normal trunk (it has about 50 other VLANs on it).

Cheers for any help!

3
  • 1
    encapsulation dot1q 100 --- Is this a typo? You state in your description you want to match customer vlan 10
    – nicotine
    May 13 '14 at 15:44
  • yes, typo, sorry. May 13 '14 at 15:54
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Jan 5 at 18:20
4

Try this:

interface GigabitEthernet0/1
 description FACING CUSTOMER NETWORK
 switchport trunk allowed vlan none
 switchport mode trunk
 service instance 1 ethernet
  encapsulation dot1q default
  bridge-domain 100

interface GigabitEthernet0/2
 description FACING SERVICE PROVIDER CLOUD
 switchport trunk allowed vlan none
 switchport mode trunk
 service instance 1 ethernet
  encapsulation dot1q 100
  rewrite ingress tag pop 1 symmetric
  bridge-domain 100

Above should allow any vlan from customer (C-TAG) and add your vlan 100 on top (S-TAG). 'rewrite ingress tag pop 1 symmetric' strips your S-TAG before traffic is delivered to customer-facing interface via bridge-domain and does reverse in other direction.

Downside is that you need to configure your SP-facing interface to EVC, but honestly with ME3600X this is the only workable way in a long run.

Above is from my head, if it doesn't work let me know and I'll test it myself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.