2

I'm working on configuring a MPLS VPN network.

Here is what I'm working with:

Network Topology

From CE1 I would like to be able to ping the loopback address of CE2 and vice versa, which is not yet possible and I do not know where abouts I am going wrong... The steps I have taken so far are as followed:

Prerequisites:

  • OSPF enabled on P and PE routers advertising inside networks plus loopbacks
  • Enable MPLS on P and PE routers

Steps taken:

  1. On PE and CE routers I have enabled RIP V2
  2. On both PE routers I have enabled VRF for the client (Repeating on PE2)

        PE1(config)#ip  vrf  client1
        PE1(config-vrf)#rd 999:1 
        PE1(config-vrf)#route-target  export  64999 :1
        PE1(config-vrf)#route-target  import  64999 :1
    
  3. Assigned VRF on both PE routers to the interfaces facing the CE routers

  4. Set up of basic BGP on both PE routers I will list my running configuration for both PE router:

PE1 configuration

Current configuration : 2176 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
ip vrf client1
 rd 999:1
 route-target export 64999:1
 route-target import 64999:1
!
no ip domain lookup
!
multilink bundle-name authenticated
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding client1
 ip address 10.1.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
 mpls label protocol ldp
 mpls ip
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!

router ospf 10
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.1.0 0.0.0.3 area 0
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
 !
 address-family ipv4 vrf client1
  redistribute bgp 64999 metric 1
  network 10.0.0.0
  no auto-summary
  version 2
 exit-address-family
!
router bgp 64999
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 64999
 neighbor 4.4.4.4 update-source Loopback0
 !
 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf client1
  redistribute rip metric 1
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

PE2 Configuration

Building configuration...

Current configuration : 2145 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!

ip vrf client2
 rd 999:1
 route-target export 64999:1
 route-target import 64999:1
!
no ip domain lookup
!
multilink bundle-name authenticated
!

archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding client2
 ip address 10.1.1.6 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.9 255.255.255.252
 duplex auto
 speed auto
 mpls label protocol ldp
 mpls ip
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!

router ospf 10
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.1.8 0.0.0.3 area 0
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
 !
 address-family ipv4 vrf client2
  redistribute bgp 64999 metric 1
  no auto-summary
 exit-address-family
!
router bgp 64999
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 64999
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf client2
  redistribute rip metric 1
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
  1. Configured RIP to use the VRF table for PE1 and PE2.

    PE1(config)#router  rip
    PE1(config-router)#address-family  ipv4  vrf  client1
    PE1(config-router-af)#version 2
    PE1(config-router-af)#network 10.0.0.0
    PE1(config-router-af)#no auto-summary
    
  2. Redistribution of routes
    • RIP routes to BGP
    • BGP routes to RIP

After configuration of the above, I have ran the following commands...

CE1 - can only see connected routes on both CE1 and CE2

     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.1.8 is directly connected, Loopback0
C       10.1.1.0 is directly connected, FastEthernet0/0

PE1

PE1#show ip route
Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/11] via 192.168.1.2, 01:02:04, FastEthernet0/1
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/21] via 192.168.1.2, 01:02:04, FastEthernet0/1
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/31] via 192.168.1.2, 01:02:04, FastEthernet0/1
     192.168.1.0/30 is subnetted, 3 subnets
O       192.168.1.8 [110/30] via 192.168.1.2, 01:02:06, FastEthernet0/1
C       192.168.1.0 is directly connected, FastEthernet0/1
O       192.168.1.4 [110/20] via 192.168.1.2, 01:02:06, FastEthernet0/1

and

PE1#show ip route vrf client1
     10.0.0.0/30 is subnetted, 2 subnets
R       10.1.1.8 [120/1] via 10.1.1.1, 00:00:18, FastEthernet0/0
C       10.1.1.0 is directly connected, FastEthernet0/0

PE2

PE2#show ip route

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/31] via 192.168.1.10, 01:08:58, FastEthernet0/1
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/21] via 192.168.1.10, 01:09:08, FastEthernet0/1
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/11] via 192.168.1.10, 01:09:08, FastEthernet0/1
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
     192.168.1.0/30 is subnetted, 3 subnets
C       192.168.1.8 is directly connected, FastEthernet0/1
O       192.168.1.0 [110/30] via 192.168.1.10, 01:08:59, FastEthernet0/1
O       192.168.1.4 [110/20] via 192.168.1.10, 01:09:09, FastEthernet0/1

and

PE2#show ip route vrf client2
     10.0.0.0/30 is subnetted, 3 subnets
B       10.1.1.8 [200/1] via 1.1.1.1, 00:55:41
B       10.1.1.0 [200/0] via 1.1.1.1, 00:55:41
C       10.1.1.4 is directly connected, FastEthernet0/0
  • Why am I only seeing RIP routes in PE1? and only BGP routes in PE2?
  • Should I be seeing the routes for both BGP and RIP to the CE network from PE1 and 2?
  • What am i missing/doing wrong that is not letting me ping from CE1 to CE2 and vice versa?

Addition running configurations

CE2:

CE2#show run
Building configuration...

Current configuration : 1396 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 10.1.1.17 255.255.255.252
!
interface FastEthernet0/0
 ip address 10.1.1.5 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

Thanks in advance!

11
  • The problem is between PE2 and CE2,-- they are not communicating via RIP. Can you post CE2's config?
    – Ron Trunk
    Commented Aug 2, 2016 at 11:32
  • I've added in the config, what could be causing them not to communicate as i can see that RIP is configured
    – JBoH
    Commented Aug 2, 2016 at 11:42
  • Can you ping PE2 from CE2?
    – Ron Trunk
    Commented Aug 2, 2016 at 11:46
  • ping successful for 10.1.1.6 from CE2
    – JBoH
    Commented Aug 2, 2016 at 11:48
  • 1
    Yes you're right i havent added it in!! very silly mistake that i missed!! Thank you very much!! - im a little new to the site, once a problem is solved should i edit it in my answer? as i can now ping to each CE router!
    – JBoH
    Commented Aug 2, 2016 at 12:36

2 Answers 2

1

PE2 is missing

address-family  ipv4  vrf  client1

under the RIP configuration

3
  • Should that not be PE2 is missing network 10.0.0.0 etc under the address-family ipv4 vrf client2? There is no vrf client1 on PE2 and there is already an address-family ipv4 vrf statement under RIP on PE2, just no network 10.0.0.0 under the address family
    – user27899
    Commented Aug 2, 2016 at 13:01
  • @qualeboy For client1 and client2, I must note that in my opinion they should be one and the same. It seems illogical to me to name the VRF differently on each router when they exchange their routes, same rd 999:1, same route-target export and import 64999:1.
    – Law29
    Commented Aug 2, 2016 at 22:18
  • @Law29 they may be different customers with an overlapping VPN. Either way, the solution above wouldn't work. It would need to say create the new vrf, rereference it on the interface, Router BGP etc. The commands above alone would fail is my main point
    – user27899
    Commented Aug 3, 2016 at 1:54
1

PE2 is missing (under RIP address-family ipv4 vrf client2)

version 2
network 10.0.0.0
no auto-summary

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.