1

I have 2 routers R1 and R2 connected back to back. R1 and R2 are ebgp neighbors for address family ipv4 and address family vpnv4. I want to test the following:

--Redistribute a route from R2's global routing table into the vpnv4 address family and advertise the same to R1 under vpnv4 address family. I did below, but can't see the routes being learnt on R1 under vpnv4 address-family. Please suggest what is incorrect.

Below are my current configs: On R1:

Router#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         unassigned      YES unset  administratively down down    
GigabitEthernet0/1         11.11.11.1      YES manual up                    up      
Loopback0                  1.1.1.1         YES manual up                    up      
Loopback111                unassigned      YES unset  up                    up      
Router#sho run | sec router bgp
router bgp 1
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 2
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 !
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
 exit-address-family
Router#

On R2:

        Router#sho ip int bri | i up
GigabitEthernet0/1         11.11.11.2      YES manual up                    up      
Loopback0                  2.2.2.2         YES manual up                    up      
Loopback22                 22.22.22.22     YES manual up                    up      


Router#sho run | sec router bgp
router bgp 2
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
!
 address-family ipv4 vrf TEST22      
  redistribute static metric 10
 exit-address-family
Router#

Router#sho run | sec Null
ip route 100.0.0.0 255.0.0.0 Null0
Router#
4
  • 1
    You need to advertise the routes. You have the connection set up, but you need to tell BGP what to advertise. You can use network statements or a redistribution, with our without controls like route maps.
    – Ron Maupin
    Commented May 18, 2017 at 16:13
  • @Ron Maupin I have already given the redistribute statement
    – fsociety
    Commented May 18, 2017 at 17:01
  • 2
    You are doing that in a different address family than the neighbor. Each address family will only communicate with the corresponding address family.
    – Ron Maupin
    Commented May 18, 2017 at 17:09
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Commented Nov 19, 2022 at 22:49

1 Answer 1

1

As was already pointed out in the comments, each address-family only transfers prefixes to neighbors in that same address-family. You have the redistribution set up on R2 in an address-family in which R1 does not participate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.