2

I have a setup in my GNS3 where I am trying to understand some basic iBGP and eBGP concepts.

Please refer to the diagram (I only took a screenshot of the part which is really required). I have advertised a loopback from R3 and I can see the route in the ip routing table of R10 but I can't ping it from R10.

enter image description here

R3 --> AS300 R8, R10 --> AS100

R3:

!
router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 network 10.0.0.0 mask 255.255.255.252
 neighbor 192.168.0.14 remote-as 100 #eBGP tied on the physical interface.
 neighbor 192.168.0.14 update-source fastEthernet 3/0
 no auto-summary
 !

R8:

!
router ospf 1
router-id 8.8.8.8
network 8.8.8.8 0.0.0.0 area 0
network 192.168.0.28 0.0.0.3 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.10.10 remote-as 100
 neighbor 10.10.10.10 update-source Loopback0
 neighbor 10.10.10.10 next-hop-self
 neighbor 192.168.0.13 remote-as 300
 neighbor 192.168.0.13 update-source fastEthernet 3/0
 no auto-summary
 !

R10:

!
router ospf 1
 router-id 10.10.10.10
 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.0.28 0.0.0.3 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 8.8.8.8 remote-as 100
 neighbor 8.8.8.8 update-source Loopback0
 no auto-summary
!

I can see the route to 3.3.3.3 in routing table of R10 and the next hop i.e. 8.8.8.8 is also reachable but a ping to 3.3.3.3 fails.

Any help is appreciated. Also, if there are some configurations (which would have been done in a better way, I would be happy to learn). Thanks in advance! :)

1
  • Would you let me know if you were able to get it worked with my answer below. If yes, please accept it as the solution. Thanks!
    – Hung Tran
    Commented Feb 15, 2018 at 9:32

2 Answers 2

5

It is because R3 does not know how to return the traffic back to R10. In routing table of R3, it does not have any routes/prefixes located on R10.

R10 learned the prefix 3.3.3.3/32 from R3 via BGP (iBGP session with R8).

On R10, you need to advertise your local networks/prefixes into BGP, so that R3 can learn and know how to return the traffic back to R10.

4

You have made advertisement unidirectional instead of bidirectional, meaning that you only advertised from R3 to R8, but not from R8 to R3.

We can see this from your config:

R3

router bgp 300
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255    #network being advertised

However R10 does not have one being advertised, hence you are missing the network x.x.x.x config.

Cisco IOS IP Routing: BGP Command Reference

network (BGP and multiprotocol BGP)

To specify the networks to be advertised by the Border Gateway Protocol (BGP) and multiprotocol BGP routing processes, use the network command in address family or router configuration mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.