1

Good morning.

For starters, I am less than a noob with cisco products. I can access, so basic trunking for our nec phone systems, etc.

I have a 3750 that I'd like to configure to mimic a multi location scenario. I have read some refer to as inter vlan routing.

VLAN 1: 172.30.1.0/24

VLAN 21: 172.30.21.0/24

VLAN 2: 172.30.2.0/24

etc I was planning to also ensure GW was 172.30.xxx.1 respectively for each VLAN.

VLAN's would need to communicate with each other.

Thoughts?

Thank you in advance. (PS I have my boss a cisco whiz to assist, but his duties really limits his time assisting me)

Terry

1
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer.
    – Ron Maupin
    Commented Dec 31, 2020 at 4:36

2 Answers 2

6

First, you should probably not use VLAN 1 - it's generally not recommended, or if used, used for network device management traffic only. But, to answer your question, yes, you'd be using inter-vlan routing on the Cisco switch. See config below:

! enable layer-3 routing
ip routing

! declare vlans
vlan 1
  name my vlan 1
vlan 21
  name my vlan 21
vlan 2
  name my vlan 2

! turn on the SVI for these three vlans.
int vlan 1
  ip address 172.30.1.1 255.255.255.0
int vlan 21
  ip address 172.30.21.1 255.255.255.0
int vlan 2
  ip address 172.30.2.1 255.255.255.0

! put ports into whatever vlans they need to be in.
! example, ports 1-4 vlan 1, ports 5-8 vlan 21, ports 9-12 vlan 2
int range g1/0/1 - 4
  switchport mode access
  switchport access vlan 1
int range g1/0/5 - 8
  switchport mode access
  switchport access vlan 21
int range g1/0/9 - 12
  switchport mode access
  switchport access vlan 2
1
  • Excellent. I'll give that a whirl and see if anything was missed. Thank you Michael. Will update when I am done.
    – TERRY
    Commented Jun 20, 2018 at 14:01
0

In Cisco catalyst 3750 switch configure Switch virtual interface (SVI) For 3 Vlans and enable " iP routing ". Communication among different Vlan routing is enable .hence different Vlan can communicate .

For example in cisco 3750 multi layered switch

Switch(config) # interface Vlan 1 Switch(config)#ip address 172.30.1.1 255.255.255.0 Switch(config)#no shutdown

Switch(config)# interfàce Vlan 21 Switch(config)#ip address 172.30.21.1 255.255 .255.0 Switch(config)#no shutdown

Switch(config)# interfàce Vlan 2 Switch(config)#ip address 172.30.2.1 255.255.255.0 Switch(config)#no shutdown

Switch(config)# ip routing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.