3

I got two L3 switches (Cisco 3560) with no switcport ports connected to L2 switch (Cisco 2960). It used to work, but when I saved and restarted Packet Tracer -- all ports went into standalone mode. This is the configuration of ports:

Vlan-40-Main (L3):

interface Port-channel5
 no switchport
 ip address 192.168.100.7 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 no ip address
 channel-group 5 mode active
 duplex auto
 speed auto
!
interface FastEthernet0/2
 no switchport
 no ip address
 channel-group 5 mode active
 duplex auto
 speed auto
!

Vlan-30-Main (L3):

interface Port-channel6
 no switchport
 ip address 192.168.100.6 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 no ip address
 channel-group 6 mode active
 duplex auto
 speed auto
!
interface FastEthernet0/2
 no switchport
 no ip address
 channel-group 6 mode active
 duplex auto
 speed auto
!

Upper-Trunk2 (L2):

interface Port-channel1
 switchport mode trunk

interface Port-channel2
 switchport mode trunk

enter image description here

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(SD)           LACP   Fa0/1(I) Fa0/2(I) 
2      Po2(SD)           LACP   Fa0/3(I) Fa0/4(I) 
3      Po3(SU)           LACP   Fa0/5(P) Fa0/6(P) 
1
  • 4
    This is a problem with Packet Tracer. PT is not a real simulator so it doesn’t faithfully duplicate how routers and switches operate.
    – Ron Trunk
    Commented Dec 29, 2021 at 13:29

1 Answer 1

3

You cannot connect a layer-3 channel to a layer-2 trunk channel because the layer-3 channel can only process the native VLAN unless you create subinterfaces for it. Remember that a layer-3 interface on a switch is basically the same as a router interface.

You need something like:

interface Port-channel5
 description Native VLAN
 no switchport
 encapsulation dot1Q <VLAN Number N> native
 ip address 192.168.100.7 255.255.255.0
!
interface Port-channel5.<VLAN Number X>
 description VLAN <VLAN Number X>
 encapsulation dot1Q <VLAN Number X>
 ip address <VLAN X IP address> <VLAN X Mask>
!
interface Port-channel5.<VLAN Number Y>
 description <VLAN Number Y>
 encapsulation dot1Q <VLAN Number Y>
 ip address <VLAN Y IP address> <VLAN Y Mask>
!
interface FastEthernet0/1
 no switchport
 no ip address
 channel-group 5 mode active
!
interface FastEthernet0/2
 no switchport
 no ip address
 channel-group 5 mode active
!
7
  • I tried, but got invalid input error at port-channel subinterface number Commented Dec 29, 2021 at 15:40
  • You probably ran into a Packet Tracer limitation. We use port channel subinterfaces all the time. Packet Tracer is a tool to get you through the CCNA, and it does not support more advanced features of real IOS.
    – Ron Maupin
    Commented Dec 29, 2021 at 15:41
  • Is there another way to do that? I have no choice to use another program :( Commented Dec 29, 2021 at 15:42
  • Either use something that supports more advanced features, or you can rent a rack of equipment (there are several vendors that do this) that you can access remotely to do configuration tests.
    – Ron Maupin
    Commented Dec 29, 2021 at 15:45
  • The weird thing is that it works without subinterfaces until I restart the program... Commented Dec 29, 2021 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.