5

I have to receive some multicast groups for an IPTV platform. I can't use PIM (they don't give me an RP address for the groups...). The provider suggested me to do a join to each multicast group and then distribute the multicast from my switch to the receivers (via PIM), which are in a different VLAN than the interface where i do the join.

Now I have my switch subscribed to some multicast groups but my receivers can't join the group.

My switch configuration is something like:

interface Vlan10
 ip address X.X.X.X 255.255.255.224
 ip pim sparse-mode
 ip igmp join-group 234.X.X.X
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
 ip pim sparse-mode
!

My receivers are in VLAN 20 and I join the Provider groups in the VLAN 10.

Any suggestion or idea to get this working?

I attach an scheme to clarify.

The Mcast Provider 2 is working with PIM without problems and now I have a subscription to a MCAST from provider 1 via join command and would like to receive it in my receivers in vlan 62 enter image description here

  • RS1983, Do you have a RP configured? Do you have the RP address manually configured in the device or is listening for the RP? – user8270 Sep 3 '14 at 16:16
  • Now my doubt is about what rp-address to use, the one in the vlan 10, the one in vlan20 or one created for example in a loopback interface? – RS1983 Sep 3 '14 at 16:19
  • 1
    Just to cover the basics, you do have multicast routing enabled globally, correct? The output of show ip multicast should indicate multicast routing is enabled. If disabled you would need to issue the ip multicast-routing command in configuration mode. – YLearn Sep 3 '14 at 17:39
  • Do you have a diagram on where is your RP in relation to your switch? – user8270 Sep 3 '14 at 18:11
  • I have just added a picture for better explanation – RS1983 Sep 4 '14 at 12:14
4

Remember that "ip igmp join-group" will cause all multicast packets for this group to be forwarded also to the CPU. Probably this is not what you want. Instead talk to your provider and tell them to use "ip igmp static-group" on their side.

3

I have resolved the issue. As you told me , pim must be enabled, sparse-mode in the interface vlan, the rp-address for the multicast group but one command was missing.

ip route-cache distributed

Thanks to everyone!!

2

The static igmp join on your vlan 10 should be enough to get the mcast data into the switch. So since your switch now knows how to get to the mcast data you can cheat and make the RP your switch.

You should be able to do this

ip access-list standard iptv
permit 234.X.X.X    
ip pim rp-address X.X.X.X iptv

where x.x.x.x is the IP of vlan 10 or any other ip on your switch

  • I have tried but without success... – RS1983 Sep 3 '14 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.