1

I have two routers connected to a single switch and both have internet connections. I have configured HSRP and VRRP as follows, This is a test bench I'm using so that's why I'm using both. The HSRP is working as normal on the GigabitEthernet 0/1 interface, but on the vlans they are both active. Here are the configs:

Cisco Router 1
interface GigabitEthernet0/0
ip address 10.21.6.10 255.255.255.0
ip nat outside
exit

interface GigabitEthernet0/1
    ip address 192.168.1.2 255.255.255.0
    standby 0 ip 192.168.1.1
    standby 0 priority 95
    standby 0 preempt
    ip nat inside

interface GigabitEthernet0/1.101
    encapsulation dot1Q 101
    ip address 192.168.101.2 255.255.255.240
    vrrp 1 ip 192.168.101.1
    vrrp 1 priority 95
    ip nat inside

interface GigabitEthernet0/1.102
    encapsulation dot1Q 102
    ip address 192.168.102.2 255.255.255.0
    standby 2 ip 192.168.102.1
    standby 2 preempt
    ip nat inside

interface GigabitEthernet0/1.103
    encapsulation dot1Q 103
    ip address 192.168.103.2 255.255.255.0
    vrrp 3 ip 192.168.103.1
    vrrp 3 priority 140
    ip nat inside

interface GigabitEthernet0/1.104
    encapsulation dot1Q 104
    ip address 192.168.104.2 255.255.255.0
    standby 4 ip 192.168.104.1
    standby 4 priority 95
    standby 4 preempt
    ip nat inside

interface GigabitEthernet0/1.105
    encapsulation dot1Q 105
    ip address 192.168.105.2 255.255.255.0
    vrrp 5 ip 192.168.105.1
    vrrp 5 priority 95
    ip nat inside

interface GigabitEthernet0/1.106
    encapsulation dot1Q 106
    ip address 192.168.106.2 255.255.255.0
    standby 6 ip 192.168.106.1
    standby 6 preempt
    ip nat inside

interface GigabitEthernet0/1.107
    encapsulation dot1Q 107
    ip address 192.168.107.2 255.255.255.192
    vrrp 7 ip 192.168.107.1
    vrrp 7 priority 140
    ip nat inside 

interface GigabitEthernet0/1.108
    encapsulation dot1Q 108
    ip address 192.168.108.2 255.255.255.192
    standby 8 ip 192.168.108.1
    standby 8 priority 95
    standby 8 preempt
    ip nat inside

interface GigabitEthernet0/1.109
    encapsulation dot1Q 109
    ip address 192.168.109.2 255.255.255.0
    vrrp 9 ip 192.168.109.1
    vrrp 9 priority 95
    ip nat inside


Router 2
 int g0/0
    ip address 10.21.6.11 255.255.255.0
    ip nat outside
    no shutdown
    exit
 int g0/1
    ip address 192.168.1.3 255.255.255.0
    standby 0 ip 192.168.1.1
    standby 0 preempt         
    ip nat inside
    no shutdown
    exit
 int g0/1.101
    encapsulation dot1Q 101
    ip address 192.168.101.3 255.255.255.240
    vrrp 1 ip 192.168.101.1
    vrrp 1 priority 140
    ip nat inside
    exit
 int g0/1.102
    encapsulation dot1Q 102
    ip address 192.168.102.3 255.255.255.0
    standby 2 ip 192.168.102.1
    standby 2 priority 95
    standby 2 preempt
    ip nat inside
    exit
 int g0/1.103
    encapsulation dot1Q 103
    ip address 192.168.103.3 255.255.255.0
    vrrp 3 ip 192.168.103.1
    vrrp 3 priority 95
    ip nat inside
    exit
 int g0/1.104
    encapsulation dot1Q 104
    ip address 192.168.104.3 255.255.255.0
    standby 4 ip 192.168.104.1
    standby 4 preempt
    ip nat inside
    exit
 int g0/1.105
    encapsulation dot1Q 105
    ip address 192.168.105.3 255.255.255.0
    vrrp 5 ip 192.168.105.1
    vrrp 5 priority 140
    ip nat inside
    exit
 int g0/1.106
    encapsulation dot1Q 106
    ip address 192.168.106.3 255.255.255.0
    standby 6 ip 192.168.106.1
    standby 6 priority 95
    standby 6 preempt
    ip nat inside
    exit
 int g0/1.107
    encapsulation dot1Q 107
    ip address 192.168.107.3 255.255.255.192
    vrrp 7 ip 192.168.107.1
    vrrp 7 priority 95
    ip nat inside
    exit
 int g0/1.108
    encapsulation dot1Q 108
    ip address 192.168.108.3 255.255.255.192
    standby 8 ip 192.168.108.1
    standby 8 preempt
    ip nat inside
    exit
 int g0/1.109
    encapsulation dot1Q 109
    ip address 192.168.109.3 255.255.255.0
    vrrp 9 ip 192.168.109.1
    vrrp 9 priority 140
    ip nat inside
    exit

Does anyone have any idea on why it would be doing this.

3
  • 4
    If both are active, then they don't see each other as peers. Perhaps you are not trunking all the vlans between the two devices?
    – Ron Trunk
    Commented Oct 3, 2015 at 12:08
  • 1
    To add more detail to Ron's comment, it sounds like the switch is dropping all vlan tags and only allowing the untagged traffic through.
    – cpt_fink
    Commented Oct 4, 2015 at 4:42
  • I found the problem, my team member had set that port to receive monitor traffic and therefor it was not trunking any vlan traffic to the router. Once this was fixed everything started working. I should have been looking closer at the switch, thanks @RonTrunk
    – Wilken
    Commented Oct 4, 2015 at 8:23

1 Answer 1

2

I found the problem, my team member had set that port to receive monitor traffic and therefor it was not trunking any vlan traffic to the router. Once this was fixed everything started working. thanks @RonTrunk

1
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer.
    – Ron Maupin
    Commented Aug 29, 2016 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.