4

We want to set up a LAN-to-LAN tunnel VPN between our company and a customer, but the connection doesn’t work. Here’s the network diagram:

network-diagram

Below the full Cisco ASA configuration:

: Saved
:
ASA Version 9.1(2) 
!
hostname ASA
domain-name mycompany.local
enable password czov.cpL9DkL/AOc encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
ip local pool Pool.Lyon 192.168.69.100-192.168.69.150 mask 255.255.255.0
!
interface GigabitEthernet0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/1
 description LAN
 speed 100
 duplex full
 nameif inside
 security-level 100
 ip address 10.6.9.1 255.255.255.0 
!
interface GigabitEthernet0/2
 description Connexion Internet
 nameif outside
 security-level 0
 ip address 192.168.1.200 255.255.255.0 
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
!
boot system disk0:/asa912-smp-k8.bin
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 10.6.9.5
 name-server 10.3.3.5
 domain-name mycompany.local
object network RemoteLANCustomer
 subnet 172.31.30.84 255.255.255.252
 description Reseau Local Customer
object network LocalLAN
 subnet 10.6.9.0 255.255.255.0
 description LAN mycompany
object network HoteDistantCustomer
 host 109.x.x.4
object network vHANDLYO
 host 10.6.9.5
object service RDP
 service tcp source eq 3389 destination eq 3389 
object network LANTours
 subnet 10.3.7.0 255.255.255.0
access-list outside_cryptomap extended permit ip 10.6.9.0 255.255.255.0 172.31.30.84 255.255.255.252 
access-list outside_access_in extended permit tcp any object vHANDLYO eq 3389 
pager lines 24
logging enable
logging trap notifications
logging asdm debugging
logging host inside 10.3.3.100
mtu inside 1500
mtu outside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm733.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source dynamic LocalLAN interface
nat (inside,outside) source static vHANDLYO vHANDLYO no-proxy-arp
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
route inside 10.0.0.0 255.0.0.0 10.6.9.15 1
route outside 109.x.x.4 255.255.255.255 192.168.1.1 1
route outside 172.31.30.84 255.255.255.252 192.168.1.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.0.0.0 255.0.0.0 inside
snmp-server host inside 10.3.3.50 community ***** version 2c
snmp-server location France
snmp-server contact [email protected]
snmp-server community *****
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 109.x.x.4 
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 set security-association lifetime seconds 3600
crypto map outside_map interface outside
crypto ca trustpool policy
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 3600
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 3600
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 inside
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd dns 10.6.9.5 10.3.3.5 interface inside
dhcpd lease 28800 interface inside
dhcpd domain mycompany.local interface inside
dhcpd option 3 ip 10.6.9.16 10.6.9.15 interface inside
dhcpd option 6 ip 10.6.9.5 10.3.3.5 interface inside
dhcpd option 42 ip 10.6.9.5 10.3.3.5 interface inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 10.6.9.5 source inside
ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
webvpn
 enable outside
 anyconnect image disk0:/anyconnect-win-3.1.08009-k9.pkg 1
 anyconnect enable
 tunnel-group-list enable
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
group-policy GroupPolicy_ClientVPN internal
group-policy GroupPolicy_ClientVPN attributes
 wins-server value 10.6.9.5
 dns-server value 10.6.9.5
 vpn-tunnel-protocol ssl-client 
 default-domain value mycompany.local
group-policy GroupPolicy_109.x.x.4 internal
group-policy GroupPolicy_109.x.x.4 attributes
 vpn-tunnel-protocol ikev1 
username * encrypted privilege 15
username * encrypted privilege 15
tunnel-group 109.x.x.4 type ipsec-l2l
tunnel-group 109.x.x.4 ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
tunnel-group ClientVPN type remote-access
tunnel-group ClientVPN general-attributes
 address-pool Pool.Lyon
 default-group-policy GroupPolicy_ClientVPN
tunnel-group ClientVPN webvpn-attributes
 group-alias ClientVPN enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:a0b795c9e166e7284056fe3de509b867
: end

ISP router configuration is detailled in the network diagram.

On the customer's firewall there isn't any traffic from the Cisco ASA. Can someone explain to me the different step to set up the tunnel properly?

5
  • See if this helps you: forums.juniper.net/t5/SRX-Services-Gateway/…
    – Ron Trunk
    Commented Mar 1, 2016 at 15:40
  • Do you have crypto isakmp enable outside Do you have an agreed set of VPN policies with your customer? It seems you are using the defaults which could negotiate DES and MD5 which are not considered secure. Do you have routing configured correctly on your firewall?
    – Owensteam
    Commented Mar 14, 2016 at 18:33
  • The VPN tunnel needs to terminate on your ASA and the customers Juniper Firewall. I do not believe the ISP's equipment will participate in the VPN tunnel at all. So, the question might be re-titled to VPN between Cisco ASA and Juniper Firewall. Post the configs of both of those devices. Commented May 21, 2016 at 20:57
  • Look at your log. It will tell you which part of the VPN isn't working.
    – Ron Trunk
    Commented May 21, 2016 at 21:38
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Commented Aug 8, 2017 at 2:06

2 Answers 2

2

The setup above will not work as-is, because you have the ASA sitting behind the ISP router. In order for the VPN to work in this implementation you must make use of NAT-T (NAT Traversal). This is because ESP is it's own protocol, and the ISP router does not know what to do with it. By using NAT-T you are encapsulating (re-packing essentially) the ESP packets into UDP packets.

NOTE: Even though the customer is the only device using NAT, NAT-T will need to be configured on both sides so that is can understand what needs done with the traffic.

Enabling NAT-T on an ASA:

hostname(config)# crypto isakmp nat-traversal 3600

The above sets NAT timeout to one hour, this can be reduced if you experience issues.

hostname(config)# crypto ipsec fragmentation before-encryption

Enabling NAT-T on SRX:

As long as the following command is absent from your SRX config, the VPN should come up fine:

no-nat-traversal;

Also on the customer's ISP router you have the ports being forwarded to the inside address of the ASA. You should be forwarding the traffic to the outside interface of the ASA.

-1

This is my first post here, so mostly food for thought.

I had a similar situation like this, however we found it was best to simply just use the ISP provided router for the modem capability. We essentially bridged the ASA to the ISP provided modem/router. Eliminates the need for this double NAT situation and will reduce packet overheads. You'll most likely have to adjust MTU settings also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.