3

i am trying to configure QOS for site to site VPN, i want to dedicate 50% of the bandwidth on the physical interface to VPN traffic, then the remaining to internet traffic. the connection to intranet server is very slow and the internet link is 10 mbps.

this is the Qos configuration i have presently and it is still very slow.

access-list 112 permit ip any 192.168.0.0 0.0.0.255

class-map match-all test-qos
 match access-group 112
policy-map qos-pmap
 class test-qos
  bandwidth percent 50
interface Tunnel0
 ip address 172.16.60.1 255.255.255.252
  qos pre-classify
interface GigabitEthernet0/0
 service-policy output qos-pmap
3
  • 1
    The problem you have is that the physical port is a 1 Gbps port, but you only have 10 Mbps to use. Your QoS assumes that the port is a 1 Gbps port, so normal traffic will use up to 500 Mbps. You will need to do traffic shaping, too.
    – Ron Maupin
    Commented Aug 4, 2016 at 16:16
  • thank you for your response, can you please put me through on this. may be with a sample configuration
    – justin
    Commented Aug 4, 2016 at 16:26
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Commented Aug 14, 2017 at 22:30

1 Answer 1

1

Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

GTS Enabled on the Interface Example This example shows the configuration of two traffic-shaped interfaces on a router. Ethernet interface 0 is configured to limit User Datagram Protocol (UDP) traffic to 1 Mbps. Ethernet interface 1 is configured to limit all output to 5 Mbps.

access-list 101 permit udp any any
interface Ethernet0
 traffic-shape group 101 1000000 125000 125000
!
interface Ethernet1
 traffic-shape rate 5000000 625000 625000

put your 5mbps policy in your policy map and your 10mbps policy on your physical interface.

1
  • hello Ron. i have tried your suggestion but still no improvement. here is what i did Policy Map qos-pmap Class test-qos bandwidth 50 (%) Class class-default Average Rate Traffic Shaping cir 5000000 (bps) int g0/0 bandwidth 15000
    – justin
    Commented Aug 5, 2016 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.