0

So I have an exercise with this topology:

enter image description here

I have configured all the OSPF networks on each router and I made every g0/0 interface (except for the ABR in the middle) a passive interface.

However, I cannot ping from PC11 to PC1 (or any other PC in another area).

Here are the configurations of the routers:

R1 :

interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.99.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.99.0 0.0.0.255 area 0
!
ip classless

R2 :

interface GigabitEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.99.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 network 192.168.3.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.99.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
!
ip classless

R3 :

interface GigabitEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.99.3 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.99.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
!
ip classless

ABR :

interface GigabitEthernet0/0
 ip address 192.168.99.4 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.16.99.4 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.99.0 0.0.0.255 area 0
 network 172.16.99.0 0.0.0.255 area 2

R11 :

interface GigabitEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.16.99.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
 no ip address
shutdown
!
router ospf 1
log-adjacency-changes
passive-interface GigabitEthernet0/0
network 172.16.2.0 0.0.0.255 area 2
network 172.16.3.0 0.0.0.255 area 2
network 172.16.1.0 0.0.0.255 area 2
network 172.16.99.0 0.0.0.255 area 2

R12 :

interface GigabitEthernet0/0
 ip address 172.16.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.16.99.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 network 172.16.1.0 0.0.0.255 area 2
 network 172.16.3.0 0.0.0.255 area 2
 network 172.16.99.0 0.0.0.255 area 2
 network 172.16.2.0 0.0.0.255 area 2

R13 :

interface GigabitEthernet0/0
 ip address 172.16.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.16.99.3 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 network 172.16.1.0 0.0.0.255 area 2
 network 172.16.2.0 0.0.0.255 area 2
 network 172.16.99.0 0.0.0.255 area 2
 network 172.16.3.0 0.0.0.255 area 2

Here is the output from show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.99.3      1   FULL/DROTHER    00:00:32    192.168.99.3    GigabitEthernet0/0
192.168.99.2      1   FULL/BDR        00:00:32    192.168.99.2    GigabitEthernet0/0
192.168.99.1      1   FULL/DROTHER    00:00:32    192.168.99.1    GigabitEthernet0/0
172.16.99.1       1   FULL/DROTHER    00:00:32    172.16.99.1     GigabitEthernet0/1
172.16.99.2       1   FULL/DROTHER    00:00:32    172.16.99.2     GigabitEthernet0/1
172.16.99.3       1   FULL/BDR        00:00:32    172.16.99.3     GigabitEthernet0/1

And here is the output from show ip ospf database

            OSPF Router with ID (192.168.99.4) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.99.4    192.168.99.4    12          0x80000002 0x000ad9 1

                Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
172.16.99.0     192.168.99.4    3           0x80000001 0x00ec80

                Router Link States (Area 2)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.99.4    192.168.99.4    12          0x80000001 0x00bad6 1

                Summary Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
192.168.99.0    192.168.99.4    8           0x80000001 0x00c0ff

What am I missing here?

Thanks in advance.

5
  • Please edit you question to include all the router configurations. We cannot simply guess where you may have gone wrong.
    – Ron Maupin
    Commented Mar 17, 2022 at 19:53
  • 2
    Never use an image for text. Simply copy the text and paste it into the post and use the Preformatted-text option (right next to the Image option you did use). Also, we need the full router configurations. You only provided a routing table.
    – Ron Maupin
    Commented Mar 17, 2022 at 20:02
  • It is very confusing because you are including network statements for networks for which you have no interfaces. The network statements only tell OSPF which interfaces should be included in the OSPF process, not which networks to advertise. The easiest thing to do when using passive interfaces and all the interfaces in the same area is to use network 0.0.0.0 255.255.255.255 area <area>. Why deal with figuring wildcard masks and separate network statements? Also, the routing table for the ABR would be something for us to see.
    – Ron Maupin
    Commented Mar 17, 2022 at 22:24
  • Thanks Ron. It is how the teacher asked us (and taught us) to do it.
    – gabone
    Commented Mar 18, 2022 at 11:10
  • That is only useful if you need to only include some interfaces in the OSPF process, and not include others. Also, never put in network statements that do not cover any interface; you are not telling OSPF what to advertise.
    – Ron Maupin
    Commented Mar 18, 2022 at 12:23

1 Answer 1

2

Rather than simply giving you an answer, here's a strategy to troubleshoot OSPF problems.

If you're not seeing routes, then likely some routers are failing to become neighbors. Use show ip ospf neighbor brief to check that a router has all the neighbors it should.

If routers are not neighbors, check that they are pingable from each other. Then check the ospf parameters. debug ospf neighbors will report on ospf parameter mismatches.

If the routers are neighbors, but you're not seeing routes, start with the router sourcing the route and work your way back. Make sure the source router is actually advertising the route. If the routes don't cross the ABR, check that the area types are correct.

This will not solve every ospf problem, but it will give you the information you need to troubleshoot further.

6
  • Hey Ron, thanks for the reply, all routers seem to have all proper neighbours. I have tried the debug command but there is not debug ospf on my version of packet tracer. All pings in the same area are successful but nothing gets through the ABR. I also checked the areas, they are all correct. I can't find the problem. Could you tell me just where the problem is? Not the answer, just where the problem is. Thanks.
    – gabone
    Commented Mar 19, 2022 at 17:07
  • Edit your answer to include show ip route from the ABR
    – Ron Trunk
    Commented Mar 19, 2022 at 17:15
  • Hmmm, it shows no OSPF on the ABR (on the other routers yes) Gateway of last resort is not set 172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks C 172.16.99.0/24 is directly connected, GigabitEthernet0/1 L 172.16.99.4/32 is directly connected, GigabitEthernet0/1 192.168.99.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.99.0/24 is directly connected, GigabitEthernet0/0 L 192.168.99.4/32 is directly connected, GigabitEthernet0/0
    – gabone
    Commented Mar 19, 2022 at 17:25
  • Your ABR has neighbors? What state are they in?
    – Ron Trunk
    Commented Mar 19, 2022 at 18:37
  • Neighbor ID Pri State Dead Time Address Interface 192.168.99.1 1 2WAY/DROTHER 00:00:38 192.168.99.1 GigabitEthernet0/0 192.168.99.3 1 FULL/DR 00:00:39 192.168.99.3 GigabitEthernet0/0 192.168.99.2 1 FULL/BDR 00:00:30 192.168.99.2 GigabitEthernet0/0 172.16.99.2 1 FULL/BDR 00:00:39 172.16.99.2 GigabitEthernet0/1 172.16.99.3 1 FULL/DR 00:00:39 172.16.99.3 GigabitEthernet0/1 172.16.99.1 1 2WAY/DROTHER 00:00:38 172.16.99.1 GigabitEthernet0/1
    – gabone
    Commented Mar 19, 2022 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.