0

Hi guys thank you for your all answers!! I finally solved it. The IP is overlapping because of duplicate vlans. I replace same vlans to new vlans and it worked.

How can I make my VLAN connected to the OSPF? I tried to ping the pc to the server from right to left and its not working.

This is my topology. These are the ospf lines, and each of router have switch that connected to my vlans.

enter image description here

GREEN = VLAN 10 PINK = VLAN 20 BLUE = VLAN 30 PURPLE = VLAN 40

These are my sub interfaces for my vlan that is encapsulate in routers.

interface GigabitEthernet0/0.10
encapsulation dot1Q 10

ip address 192.168.0.1 255.255.255.240

interface GigabitEthernet0/0.20
encapsulation dot1Q 20

ip address 192.168.0.17 255.255.255.240

interface GigabitEthernet0/0.30
encapsulation dot1Q 30

ip address 192.168.0.33 255.255.255.240

interface GigabitEthernet0/0.40
encapsulation dot1Q 40

ip address 192.168.0.49 255.255.255.240

These are the OSPF network I assigned:

router ospf 1

log-adjacency-changes

network 192.168.0.0 0.0.0.15 area 0

network 192.168.0.16 0.0.0.15 area 0

network 192.168.0.32 0.0.0.15 area 0

network 192.168.0.48 0.0.0.15 area 0

====== This is my ip subnets I cut for each vlans.

14 SUBNETS = (16) 4 BORROWED BITS

VLAN 10 (SERVER) G0/0.10 192.168.0.1 FA0/1-5 192.168.0.0 - 192.168.0.15

VLAN 20 (CPTS) G0/0.20 192.168.0.17 FA0/6-10 192.168.0.16 - 192.168.0.31

VLAN 30 (KGD OFFICE) G0/0.30 192.168.0.33 FA0/11-15 192.168.0.32 - 192.168.0.47

VLAN 40 (SK KGD) G0/0.40 192.168.0.49 FA0/16-20 192.168.0.48 - 192.168.0.63

NATIVE 21-24 (TRUNK)

=== My router configurations

router 0 serial ports config: 

interface Serial0/0/0
 
ip address 192.168.0.161 255.255.255.240
 
clock rate 2000000

interface Serial0/0/1
 
no ip address
 
clock rate 2000000
 
shutdown

interface Serial0/1/0
 
ip address 192.168.0.65 255.255.255.240

interface Serial0/1/1
 
ip address 192.168.0.145 255.255.255.240
 
clock rate 2000000

router 1 serial ports config:

interface Serial0/0/0
 
ip address 192.168.0.81 255.255.255.240
 
clock rate 2000000

interface Serial0/0/1
 
ip address 192.168.0.78 255.255.255.240

clock rate 2000000
!

router 2 serial ports config:

interface Serial0/0/1

ip address 192.168.0.158 255.255.255.240

interface Serial0/1/0
 
no ip address
 
clock rate 2000000
 
shutdown

interface Serial0/1/1
 
ip address 192.168.0.142 255.255.255.240
 
clock rate 2000000

router 3 serial ports config:

interface Serial0/0/0
 
ip address 192.168.0.97 255.255.255.240
 
clock rate 2000000

interface Serial0/0/1
 
ip address 192.168.0.94 255.255.255.240

router 4 serial ports config:

interface Serial0/0/0
 
ip address 192.168.0.177 255.255.255.240
 
clock rate 2000000

interface Serial0/0/1
 
ip address 192.168.0.174 255.255.255.240

router 5 serial ports config:

interface Serial0/0/0

ip address 192.168.0.113 255.255.255.240
 
clock rate 2000000

interface Serial0/0/1

ip address 192.168.0.110 255.255.255.240

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

interface Serial0/1/1

ip address 192.168.0.190 255.255.255.240

router 6 serial ports config:

interface Serial0/0/0

ip address 192.168.0.129 255.255.255.240

interface Serial0/0/1

ip address 192.168.0.126 255.255.255.240

show ip ospf interface output:

Router(config)#do show ip ospf interface

GigabitEthernet0/0.10 is up, line protocol is up

Internet address is 192.168.0.1/28, Area 0

Process ID 1, Router ID 192.168.0.161, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 192.168.0.161, Interface address 192.168.0.1

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:08

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

GigabitEthernet0/0.20 is up, line protocol is up

Internet address is 192.168.0.17/28, Area 0

Process ID 1, Router ID 192.168.0.161, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 192.168.0.161, Interface address 192.168.0.17

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:09

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

GigabitEthernet0/0.30 is up, line protocol is up

Internet address is 192.168.0.33/28, Area 0

Process ID 1, Router ID 192.168.0.161, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 192.168.0.161, Interface address 192.168.0.33

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:08

Index 3/3, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

GigabitEthernet0/0.40 is up, line protocol is up

Internet address is 192.168.0.49/28, Area 0

Process ID 1, Router ID 192.168.0.161, Network Type BROADCAST, Cost: 1

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 192.168.0.161, Interface address 192.168.0.49

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:09

Index 4/4, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

14
  • Please edit your question to include your router configurations. Paste the text -- do not use images. We won't create configurations for you, but we can help you correct the ones you have.
    – Ron Trunk
    Jul 19 at 18:06
  • @RonTrunk will do, I'm sorry. Jul 19 at 18:24
  • Your network statements do not match all the interface networks. The simple thing for all addresses in the same area is to simply use the network 0.0.0.0 255.255.255.255 area 0 statement. That will include all interfaces in Area 0. You can use the passive-interface command to prevent neighbors on any interface while still advertising the network on that interface.
    – Ron Maupin
    Jul 19 at 18:54
  • @RonMaupin but I have a subnetted mask which is 255.255.240 because I have 14 subnets that covers in 16 subnets. In that case, I still can use net 0.0.0.0 and 255.255.255.255 in network? Sorry sir. I can't follow the instructions given to me hope u understand thank you for answering. Jul 19 at 23:34
  • You have not configured OSPF correctly. On each ospf router, type network 0.0.0.0 255.255.255.255 area 0 under the router ospf 1 command.
    – Ron Trunk
    Jul 20 at 12:20

2 Answers 2

1

The IP is overlapping because of duplicate vlans. I replace same vlans to new vlans that makes every vlans is different to each other and it works.

0

The network statements in OSPF tell OSPF which interfaces should participate in OSPF. The problem I see is that none of your interfaces are covered by your OSPF network statements.

  • network 192.168.0.64 0.0.0.15 area 0 covers the 192.168.0.64 to 192.168.0.79 range
  • network 192.168.0.160 0.0.0.15 area 0 covers the 192.168.0.160 to 192.168.0.175 range
  • network 192.168.0.144 0.0.0.15 area 0 covers the 192.168.0.144 to 192.168.0.159 range

None of your interfaces are addressed in those ranges, so none of those network statements do anything. There are several ways to handle it (least-specific to most-specific:

  • network 0.0.0.0 255.255.255.255 area 0 covers interfaces with any network address (all addressed interfaces in your router would participate in the OSPF process)
  • network 192.168.0.0 0.0.0.255 area 0 covers any interfaces addressed in the 192.168.0.0 to 192.168.0.255 range (all four interfaces you have listed in your question)
  • network 192.168.0.0 0.0.0.127 area 0 covers any interfaces addressed in the 192.168.0.0 to 192.168.0.127 range (all four interfaces you have listed in your question)
  • network 192.168.0.0 0.0.0.63 area 0 covers any interfaces addressed in the 192.168.0.0 to 192.168.0.63 range (all four interfaces you have listed in your question)
  • network 192.168.0.0 0.0.0.31 area 0 covers any interfaces addressed in the 192.168.0.0 to 192.168.0.31 range (interfaces GigabitEthernet0/0.10 and GigabitEthernet0/0.20), and network 192.168.0.32 0.0.0.31 area 0 covers any interfaces addressed in the 192.168.0.32 to 192.168.0.63 range (interfaces GigabitEthernet0/0.30 and GigabitEthernet0/0.40)
  • network 192.168.0.0 0.0.0.15 area 0 covers any interfaces addressed in the 192.168.0.0 to 192.168.0.15 range (interface GigabitEthernet0/0.10), network 192.168.0.16 0.0.0.15 area 0 covers any interfaces addressed in the 192.168.0.16 to 192.168.0.31 range (interface GigabitEthernet0/0.20), network 192.168.0.32 0.0.0.15 area 0 covers any interfaces addressed in the 192.168.0.32 to 192.168.0.47 range (interface GigabitEthernet0/0.30), and network 192.168.0.48 0.0.0.15 area 0 covers any interfaces addressed in the 192.168.0.48 to 192.168.0.63 range (interface GigabitEthernet0/0.40)

You can get exactly specific with:

network 192.168.0.1 0.0.0.0 area 0    !for interface GigabitEthernet0/0.10
network 192.168.0.17 0.0.0.0 area 0   !for interface GigabitEthernet0/0.20
network 192.168.0.33 0.0.0.0 area 0   !for interface GigabitEthernet0/0.30
network 192.168.0.49 0.0.0.0 area 0   !for interface GigabitEthernet0/0.40

Your OSPF network statement(s) must cover any interface(s) that you want to participate in OSPF, but none of your OSPF network statements covers any of your interfaces.

6
  • thank you for your detailed answer to my problem! I will try it! Thank you so much for helping me! Jul 20 at 10:25
  • Still not working sir i tried all your solutions :( but still thank you so much! Jul 20 at 12:54
  • @cisconewbie4545 Type show ip ospf interface brief and post the output.
    – Ron Trunk
    Jul 20 at 13:18
  • @RonTrunk how do I do that? It says invalid input and arrowed in brief word. Sorry. Jul 20 at 14:10
  • @cisconewbie4545 TRy it without the word brief. PacketTracer isn't exactly the same as real routers
    – Ron Trunk
    Jul 20 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.