6

A client has the following configuration:

The entire network is on VLAN1, with the subnet 172.16.0.0/16 - performing a redesign of their network is not an option at this point, as they're a 24/7 facility that cannot currently afford downtime (yeah, I know).

The client wishes to trunk two switches together:

1: Cisco 6509 running IOS 12.3

2: Dell F10 S48-10

The Cisco 6509 module 8 is equipped with 10gbps links - the client wants to use four of those links to trunk to the Force10. The problem that I have run into is that the Force10 does not allow tagged traffic on VLAN1, and spanning-tree pvst on the S48-10 rejects the untagged BPDU on VLAN1 from the 6509.

I've tried this configuration with the following settings - the LACP link works, but the Force10 rejects the BPDU from VLAN1 of the Cisco switch saying "Rejected untagged BPDU on VLAN1", and subsequently shuts the port down. Attempting to tag VLAN1 fails on the Force10 - that functionality is not allowed.

Force 10 Configuration

protocol spanning-tree pvst
no disable
!
!
interface range Te0/40 - 43
 description Port Channel 2 Member
 no ip address
!  
 port-channel-protocol LACP 
  port-channel 2 mode active 
 no shutdown
!

interface Port-channel 2
 description TenGig Uplink to Cisco 6509
 no ip address
 switchport
 no shutdown

Cisco 6509 configuration

!
spanning-tree mode pvst
!
interface range TenGigabitEthernet8/1 - 4
 switchport
 switchport mode trunk
 channel-protocol lacp
 channel-group 2 mode active
!
interface port-channel2
 no ip address
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk 
 no shutdown
! 

I feel that either I'm missing something very simple, or this may need to be fully converted off VLAN1 before the configuration will function. I was able to try every variant of this configuration that I could, except for forcing "trunk native vlan 1" on the Cisco side. I have not been able to obtain equipment to sandbox this configuration yet. :(

Thoughts?

1
  • 1
    It looks like the F10 is already expecting VLAN 1 to be tagged but it is coming across untagged.
    – YLearn
    Commented Jun 17, 2014 at 21:02

3 Answers 3

6

Configure your Force10 with portmode hybrid and no spanning-tree pvst err-disable cause invalid-pvst-bpdu on the interface which faces the Cisco 6500... Reference: Force10 - Cisco STP Interoperability paper.

This is the complete configuration for your Port-channel (however, see the warning below)

interface Port-channel 2
 portmode hybrid
 switchport
 no spanning-tree pvst err-disable cause invalid-pvst-bpdu
!

As described in the aforementioned white paper, the Force10 "Hybrid Mode" is required for an untagged Vlan1 on the trunk port. Note that hybrid mode accepts both tagged and untagged frames; however, it will err-disable when it sees the PVST+ BPDU from the Catalyst 6500. Thus, I recommended that you also use no spanning-tree pvst err-disable cause invalid-pvst-bpdu.

Warning:

According to at least one blog I found, hybrid mode must be configured before any switchport command; this means you might need to unbundle Port-channel 2 and add it again with portmode hybrid. Sadly, I can't confirm this myself since I don't have a Force10.

Also note that the Force10 needs manual configuration for each Vlan which gets tagged; I'm assuming you've already tagged your Force10 Vlans.

5
  • Mike, I believe that second command re: invalid-pvst-bpdu was the only thing I was lacking from my config. I will try this out and let you know, but I think you nailed it. The Short Answer for Best Practices: DON'T USE VLAN 1 Commented Jun 18, 2014 at 3:22
  • 2
    This did the trick - the only command that was missing from my configuration was "no spanning-tree pvst err-disable cause invalid-pvst-bpdu" inside the interface in question. Thanks Mike! Commented Jun 18, 2014 at 4:32
  • 1
    @PantherModern you're most welcome. I agree about Vlan 1 for user data traffic. I am also curious, does portmode hybrid show up anywhere in the Force10's running configuration? Commented Jun 18, 2014 at 10:55
  • Mike: We didn't have to unbundle and rebundle links - just adding the single command fixed the issue! :) Commented Jun 19, 2014 at 18:05
  • Oops forgot to add: Portmode Hybrid was already on - I had added that later on. Commented Jun 19, 2014 at 18:23
1

vlan dot1q tag native

However, support for it varies from platform to platform.

And if you want to enable/disable native tagging per port (after flipping the above switch): Cat6500 IEEE 802.1Q Tunneling

5
  • "switchport trunk native vlan 1" on Cisco - on the Force10, it would be "inteface vlan 1 untagged <int>" combined with "portmode hybrid" - Do you think it will work with VLAN1 specified as native, and another created just as throwaway for the LACP team to exist on? Commented Jun 17, 2014 at 20:42
  • Either the 6500 has to tag vlan1 or the f10 needs to untag it. Pick one. :-)
    – Ricky
    Commented Jun 17, 2014 at 20:47
  • The F10 cannot tag VLAN1. Commented Jun 17, 2014 at 20:50
  • If the f10 isn't tagging vlan1, why does it complain that the 6500 isn't tagging it?
    – Ricky
    Commented Jun 17, 2014 at 21:44
  • No idea why - a F10 eng told me that "this is by design". :/ Commented Jun 17, 2014 at 21:47
0

You actually can tag VLAN 1 on a force10 switch if you change the native VLAN. The restriction is, you cant tag the native vlan and as VLAN 1 by default is the native vlan you cant tag it. You cant even put an IP on it unless the native vlan is changed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.