2

The routers on a stick are running VRRP on g0/0.10, g0/0.20 and g0/0.30.
On switches, ports fa0/1-8 are on VLAN 10, fa0/23 and fa0/24 are configured as trunk port, with allowed VLANs 10, 20 and 30.

Show VRRP on HQ2 shows that all VRRP are as master, but on HQ1, they show as init, router are 2900 running IOS 15.1 and switch are 3560 running IOS 12.2,
I had the router on a stick running on 1 router and 1 switch with no problem and also VRRP running on a single switch with no problem, but there is something I do not understand here! there is no other config on router and switches.
address on HQ2 have been change to x.x.x.253. config HQ1

 HQ1>show run
          ^
% Invalid input detected at '^' marker.

HQ1>ena
Current configuration : 1712 bytes  
version 15.4  
hostname HQ1  
ip cef  
redundancy  
interface GigabitEthernet0/0  
 no ip address  
 duplex auto  
 speed auto  
interface GigabitEthernet0/0.10  
 encapsulation dot1Q 10  
 ip address 192.168.222.254 255.255.255.0  
 vrrp 1 ip 192.168.222.100 
interface GigabitEthernet0/0.20  
 encapsulation dot1Q 20  
 ip address 192.168.223.254 255.255.255.0  
 vrrp 2 ip 192.168.223.100  
interface GigabitEthernet0/0.30  
 encapsulation dot1Q 30 native  
 ip address 192.168.224.254 255.255.255.0  
 vrrp 3 ip 192.168.224.100  
interface GigabitEthernet0/1  
 ip address 200.100.0.14 255.255.255.252  
 duplex auto  
 speed auto  
interface Serial0/0/0  
 ip address 10.1.1.1 255.255.255.252  
 clock rate 2000000  

Configuration on the other router is the same except that address for g0/0.10 .20 and .30 terminate with 253 instead of 254 and of course the address for the serial connection is different. also discover a bad port on the switch so both VRRP are saying master now, so they do not communicate.

enter image description here

HQ1(config-subif)#do show vrrp  
GigabitEthernet0/0.10 - Group 1  
  State is Backup  
  Virtual IP address is 192.168.222.100  
  Virtual MAC address is 0000.5e00.0101  
  Advertisement interval is 1.000 sec  
  Preemption enabled  
  Priority is 100  
  Master Router is 192.168.222.253, priority is 150  
  Master Advertisement interval is 1.000 sec  
  Master Down interval is 3.609 sec (expires in 3.369 sec)  

GigabitEthernet0/0.20 - Group 2  
  State is Backup  
  Virtual IP address is 192.168.223.100  
  Virtual MAC address is 0000.5e00.0102  
  Advertisement interval is 1.000 sec  
  Preemption enabled  
  Priority is 100  
  Master Router is 192.168.223.253, priority is 150  
  Master Advertisement interval is 1.000 sec  
  Master Down interval is 3.609 sec (expires in 3.153 sec)  

GigabitEthernet0/0.30 - Group 3  
  State is Master  
  Virtual IP address is 192.168.224.100  
  Virtual MAC address is 0000.5e00.0103  
  Advertisement interval is 1.000 sec  
  Preemption enabled  
  Priority is 100  
  Master Router is 192.168.224.254 (local), priority is 100  
  Master Advertisement interval is 1.000 sec  
  Master Down interval is 3.609 sec  

HQ2#show vrrp  
GigabitEthernet0/0.10 - Group 1  
  State is Master  
  Virtual IP address is 192.168.222.100  
  Virtual MAC address is 0000.5e00.0101  
  Advertisement interval is 1.000 sec  
  Preemption enabled  
  Priority is 150  
  Master Router is 192.168.222.253 (local), priority is 150  
  Master Advertisement interval is 1.000 sec  
  Master Down interval is 3.414 sec  

GigabitEthernet0/0.20 - Group 2  
  State is Master  
  Virtual IP address is 192.168.223.100  
  Virtual MAC address is 0000.5e00.0102  
  Advertisement interval is 1.000 sec  
  Preemption enabled  
  Priority is 150  
  Master Router is 192.168.223.253 (local), priority is 150  
  Master Advertisement interval is 1.000 sec  
  Master Down interval is 3.414 sec  

GigabitEthernet0/0.30 - Group 3  
  State is Master  
  Virtual IP address is 192.168.224.100  
  Virtual MAC address is 0000.5e00.0103  
  Advertisement interval is 1.000 sec  
  Preemption enabled  
  Priority is 150  
  Master Router is 192.168.224.253 (local), priority is 150  
  Master Advertisement interval is 1.000 sec  
  Master Down interval is 3.414 sec  
  • How do you have the routers with the same addresses? Each router needs its own address. You should also edit your question to include the router configurations. – Ron Maupin Aug 10 '16 at 23:44
  • It appears you have some misconfiguration on the switches. If the VRRP routers can't communicate on the LAN, each will think it's the master. You should make sure that you set the VRRP priorities and the STP priorities so that layer-2 and layer-3 traffic will flow the same direction. The router with the high VRRP priority should connect to the switch with the low STP priority. – Ron Maupin Aug 11 '16 at 0:44
  • @Ron Maupin I found a bad port on f0/24 on one switch, that is why it was staying at init. just to be sure f0/23 and f0/24 should be set as trunk right ? I will only be able to continue tomorrow as the place is closed – Yves Laurin Aug 11 '16 at 1:27
  • OK. You should post an answer and accept it, otherwise the question just keeps popping up forever, looking for an answer. – Ron Maupin Aug 11 '16 at 1:28
  • @Ron Maupin Doesn't posting an answer terminate the tread ? because it is not solve yet. just the init thing is gone – Yves Laurin Aug 11 '16 at 1:57
1

OK, I found the problem, for some reason erasing the startup-config did not really erased everything, So I went in rommon and reset HQ2 to factory default and it is working.

  • After you erase a startup configuration, you must reload the device before configuring it. Also, that doesn't erase the VLAN database on a switch. – Ron Maupin Aug 11 '16 at 14:30
  • @RonMaupin reload was done, but VLAN info was not erase, I will try that to solve my last weird problem – Yves Laurin Aug 11 '16 at 14:38
  • You can go into VLAN database mode from the enable prompt, and you can fix the VLAN database. – Ron Maupin Aug 11 '16 at 14:39
  • @RonMaupin Since I have the startup config in notepad++, I deleted the startup and vlan.dat and I am reloading both of my switch right now – Yves Laurin Aug 11 '16 at 14:57
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer. – Ron Maupin Nov 10 '16 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.