3

I my current setup is as follows:

Cisco ASA port 1  | internet  | outside | vlan2
Cisco ASA port 2  | intranet  | inside  | vlan1 - dhcp 10.1.10.100 - 254

This is what I am attempting to accomplish:

Cisco ASA port 1  | internet  | outside | vlan2
Cisco ASA port 2  | intranet  | inside  | vlan1 - dhcp 10.1.10.100 - 254
Cisco ASA port 3  | intranet  | inside  | vlan3 - static 10.1.10.10 - 99

I am unsure as to how to accomplish this, after searching for similar solutions, I have yet to come across a solution that is like what I need. The reason I want this done, is we have 30+ PC's that receive their IP's dynamically, including phones, pads etc ... However we have a few static devices, such as a few windows servers, printers and a few other devices that are intended to be static.

Here is my current configuration, so that you might better understand what I have, vs. what I am attempting: (I will be filtering sensitive data, but will attempt to leave most of the config intact)

 Result of the command: "show run"

: Saved
:
ASA Version 8.2(5) 
!
hostname HOST
enable password xxxxxxxxxxxxxxxx
passwd xxxxxxxxxxxxxxxxxxxxx
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.1.10.100 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 74.xx.xx.225 255.255.255.248 
!
ftp mode passive
object-group network PPTP-server
object-group network hst-10.1.10.122
 description VPN-Server
object-group network DM_INLINE_NETWORK_1
 network-object 192.xx.xx.0 255.255.255.0
 network-object 192.xx.xx.0 255.255.255.0
access-list outside_access_in extended permit tcp any interface outside eq pptp 
access-list outside_access_in extended permit icmp any any 
access-list outside_1_cryptomap extended permit ip 10.1.10.0 255.255.255.0 object-group DM_INLINE_NETWORK_1 
access-list inside_nat0_outbound extended permit ip 10.1.10.0 255.255.255.0 192.xx.xx.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 10.1.10.0 255.255.255.0 192.xx.xx.0 255.255.255.0 
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 10.1.10.0 255.255.255.0
static (inside,outside) tcp interface pptp 10.1.10.122 pptp netmask 255.255.255.255 
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 74.xx.xx.230 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.1.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group5
crypto map outside_map 1 set peer 63.xx.xx.xx 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 170
 authentication pre-share
 encryption 3des
 hash sha
 group 5
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 75.75.75.75 75.75.76.76
dhcpd auto_config outside
!
dhcpd address 10.1.10.104-10.1.10.254 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 63.xx.xx.xx type ipsec-l2l
tunnel-group 63.xx.xx.xx ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect pptp 
  inspect icmp 
!
service-policy global_policy global
 : end

I think being layer 3 is an issue? Not sure? Any help achieving what I am looking for would be appreciated! also notice there is a VPN site-to-site tunnel set up. The configuration cannot interfere with that.

3

I am assuming you want the devices to be in the same network.

If so, you already have all that set up. Just set the static IP addresses on the servers/printers/..., and connect them to the same VLAN as your dynamic devices. Since your DHCP range is .100-.254, using addresses below .100 as on statically set up devices, won't cause any problems (collisions).

If you wish, you can connect them to the same switch as DHCP devices, or just set the port3 to vlan1 and connect them there.

  • So simply setting static IP addresses is all I need to do? The ASA will automatically acknowledge their IP without resigning it to another device causing collision?? – Zak Oct 9 '13 at 17:48
  • 1
    Since your DHCP range is from .100 to .254, ASA will give only those IPs to devices asking for them via DHCP. It doesnt even have to know anything exists on .2-.99 IPs. – mulaz Oct 9 '13 at 17:54
  • actually your address pool sems to be from .104-.254, judging by the asa config :) – mulaz Oct 9 '13 at 17:56
  • My apologies -- You are correct .. .104 - .254 -- Ok I will assign .10-.99 as static .. Thank you! Will mark answered once I verify! – Zak Oct 9 '13 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.