virtual-service connect csr_mgmt console brings up a login prompt. Anyone know the credentials?

My issue is I am trying to use the REST API which first requires you to authenticate for a token. cURL works fine but I would prefer to use a browser and our friends at Cisco failed to set the CORS header ‘Access-Control-Allow-Origin’. I was hoping to get at the NGINX within the service container (VM) running on IOS-XE and set that...

BTW, disabling CORS on the browser for dev/testing does not work, and the fetch api ain't fully baked (with no-cors) yet either. Setting up a host file (so I can spoof the ip address to be a URL on the same origin/domain) don't work either.


...when the scalpel fails, pick up the axe and hack! CORS Bypass plugins; Yes...!

Good lord, that was a multiday journey through the innerds of XHR and Fetch.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.