2

I'm setting up my voip system and having trouble getting things off the ground.
In my lab environment I have the following:

isr4331 router: 10.3.222.100
be6km server: 10.3.222.101
3650 switch:  10.1.222.1
workstation:  10.1.1.1
Internet T-1: 65.xx.xx.xx/30 

To install the be6km I need to have internt access to the be6km and the workstation. I'm not concerned about securty at the moment as I have a firewall this will all sit behind once the configuration is complete.

my confguration for the router:

    !
    !
   interface GigabitEthernet0/0/0
    description ***uplink to 3650-1 10.1.222.1 ***
    ip address 10.3.222.100 255.255.0.0
    negotiation auto
   !
   interface GigabitEthernet0/0/1
    description ****INTERNET*****
    ip address 65.xx.xx.xx 255.255.255.248
    negotiation auto
   !
   interface GigabitEthernet0/0/2
    no ip address
    shutdown
    no negotiation auto
    !
   interface Vlan1
    no ip address
    shutdown
   !
   ip default-gateway 65.xx.xx.xx
   ip forward-protocol nd
   no ip http server
   no ip http secure-server
   ip tftp source-interface GigabitEthernet0
   ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1
   !
   !
   !
   !
   !
   control-plane
   !
   !

My configuration for the switch

 !
   interface GigabitEthernet0/0
    vrf forwarding Mgmt-vrf
    no ip address
    negotiation auto
   !
   interface GigabitEthernet1/0/1
    description *******TO ISR4331*****
    switchport access vlan 103
    switchport mode access
   !
   interface GigabitEthernet1/0/2
    description ***MAINVOIP*****
    switchport access vlan 103
    switchport mode access
   !
   interface GigabitEthernet1/0/3
    switchport access vlan 103
    switchport mode access
   !

   !
   interface Vlan1
    no ip address
    shutdown
   !
   interface Vlan100
    description COMP Wired Data VLAN
    ip address 10.1.222.1 255.255.0.0
   !
   interface Vlan103
    description COMP Wired VOIP VLAN
    ip address 10.3.222.1 255.255.0.0
    ip helper-address 10.3.222.102
   !
   interface Vlan104
    description COMP Wireless VOIP VLAN
    ip address 10.4.222.1 255.255.0.0
    ip helper-address 10.3.222.102
   !
   interface Vlan105
    description Wireless Data VLAN
    ip address 10.5.222.1 255.255.0.0
    ip helper-address 10.1.7.7
   !
   interface Vlan200
    ip address 65.xx.xx.xx 255.255.255.248
   !
   ip default-gateway 65.xx.xx.xx
   ip forward-protocol nd
   ip http server
   ip http authentication local
   ip http secure-server
   ip route 0.0.0.0 0.0.0.0 65.xx.xx.xx
   !

This the new configuration:

   switch 1 provision ws-c3650-48pd
   !
   !
   !
   !
   !
   ip routing
   !
   !

   !
   !
   interface GigabitEthernet0/0
    description Trunk to 3650-1
    vrf forwarding Mgmt-vrf
    no ip address
    negotiation auto
   !
   interface GigabitEthernet1/0/1
    description Link to ISR4331
    no switchport
    ip address 10.0.0.2 255.255.255.252
   !
   interface GigabitEthernet1/0/2
    description ***MAINVOIP*****
    switchport access vlan 103
    switchport mode access
   !
   interface GigabitEthernet1/0/3
    switchport access vlan 100
    switchport mode access

   interface Vlan1
    no ip address
    shutdown
   !
   interface Vlan100
    description COMP Wired Data VLAN
    ip address 10.1.222.1 255.255.0.0
    ip helper-address 10.1.7.7
   !
   interface Vlan103
    description COMP Wired VOIP VLAN
    ip address 10.3.222.1 255.255.0.0
    ip helper-address 10.3.222.102
   !
   interface Vlan104
    description COMP Wireless VOIP VLAN
    ip address 10.4.222.1 255.255.0.0
    ip helper-address 10.3.222.102
   !
   interface Vlan105
    description Wireless Data VLAN
    ip address 10.5.222.1 255.255.0.0
    ip helper-address 10.1.7.7
   !
   router ospf 1
    auto-cost reference-bandwidth 100000
    network 0.0.0.0 255.255.255.255 area 0
   !
   ip forward-protocol nd
   ip http server
   ip http authentication local
   ip http secure-server
   !
   ip access-list extended AutoQos-4.0-Acl-Default
    permit ip any any
   !
   logging trap debugging
   logging host 10.1.10.117
   !

Router

   !
   !
   !
   interface GigabitEthernet0/0/0
    description Link to 3650-1
    ip address 10.0.0.1 255.255.255.252
    negotiation auto
   !
   interface GigabitEthernet0/0/1
    description ****INTERNET*****
    ip address 65.xx.xx.xx 255.255.255.248
    negotiation auto
   !
   interface GigabitEthernet0/0/2
    no ip address
    shutdown
    no negotiation auto
   !
   interface Service-Engine0/1/0
   !
   interface Service-Engine0/2/0
   !
   interface Service-Engine0/4/0
   !
   interface Service-Engine1/0/0
   !
   interface GigabitEthernet0
    vrf forwarding Mgmt-intf
    no ip address
    shutdown
    negotiation auto
   !
   interface Vlan1
    no ip address
    shutdown
   !
   router ospf 1
    auto-cost reference-bandwidth 100000
    passive-interface GigabitEthernet0/0/1
    network 0.0.0.0 255.255.255.255 area 0
    default-information originate
   !
   ip forward-protocol nd
   no ip http server
   no ip http secure-server
   ip tftp source-interface GigabitEthernet0
   ip route 0.0.0.0 0.0.0.0 65.xx.218.193
   !
   !
   !

    !
    !
    !
    !
   !
   mgcp behavior rsip-range tgcp-only
   mgcp behavior comedia-role none
   mgcp behavior comedia-check-media-src disable
   mgcp behavior comedia-sdp-force disable
   !
   mgcp profile default
   !
   !
   !
   !
   !
   !
   line con 0
    stopbits 1
   line aux 0
    stopbits 1
   line vty 0 4
    login
   !
   !
   end

1 Answer 1

0

You are not routing for VLANs 100, 104, 105, and 200. There are a couple of ways to do this.


Routing on the router:

Router configuration:

interface GigabitEthernet0/0/0
 description Trunk to 3650-1
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/0.100
 encapsulation dot1Q 100
 ip address 10.1.222.100 255.255.0.0
 ip helper-address 10.3.222.102
!
interface GigabitEthernet0/0/0.103
 encapsulation dot1Q 103
 ip address 10.3.222.100 255.255.0.0
 ip helper-address 10.3.222.102
!
interface GigabitEthernet0/0/0.104
 encapsulation dot1Q 104
 ip address 10.4.222.100 255.255.0.0
 ip helper-address 10.3.222.102
!
interface GigabitEthernet0/0/0.105
 encapsulation dot1Q 105
 ip address 10.5.222.100 255.255.0.0
 ip helper-address 10.3.222.102
!
ip route 0.0.0.0 0.0.0.0 65.xx.218.193
!
no ip default-gateway 65.xx.218.193
! Don't use the default gateway command for a router that is routing. You use the default route. The router *is* the gateway.

The host gateways, including the switch, should be set to the router address for the correct VLAN.

Switch configuration:

interface GigabitEthernet1/0/1
 description Trunk to ISR4331
 switchport mode trunk
 switchport nonegotiate
!
interface Vlan100
 description COMP Wired Data VLAN
 ip address 10.1.222.1 255.255.0.0
!
interface Vlan103
 description COMP Wired VOIP VLAN
 no ip address
!
interface Vlan104
 description COMP Wireless VOIP VLAN
 ip address 10.4.222.1 255.255.0.0
 no ip address
!
interface Vlan105
 description Wireless Data VLAN
 ip address 10.5.222.1 255.255.0.0
 no ip address
!
ip default-gateway 10.1.222.100
!
no interface Vlan200
! The network cannot be defined on both the switch and the router if separated by layer-3.

Or, you can do LAN routing on the switch if it is a layer-3 switch, but the Internet is routed on the router:

Router configuration:

interface GigabitEthernet0/0/0
 description Link to 3650-1
 ip address 10.0.0.1 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 65.xx.218.193
!
no ip default-gateway 65.xx.218.193
! Don't use the default gateway command for a router that is routing. You use the default route. The router *is* the gateway.
router ospf 1
 log-adjacency-changes
 auto-cost reference-bandwidth 100000
 passive interface GigabitEthernet0/0/1
 network 0.0.0.0 255.255.255.255 area 0
 default-information originate

Switch configuration:

ip routing
!
interface GigabitEthernet1/0/1
 description Link to ISR4331
 no switchport
 ip address 10.0.0.2 255.255.255.252
!
no interface Vlan200
! The network cannot be defined on both the switch and the router if separated by layer-3.
!
no ip default-gateway 65.xx.218.193
no ip route 0.0.0.0 0.0.0.0 65.xx.218.193
!
router ospf 1
 log-adjacency-changes
 auto-cost reference-bandwidth 100000
 network 0.0.0.0 255.255.255.255 area 0

Instead of OSPF, you could use another routing protocol, or use static routes, which do not scale.

The host gateways, including the switch, should be set to the switch VLAN address for the correct VLAN.


EDIT:

Since you have not configured NAT this is one way to do that:

Router configuration:

interface GigabitEthernet0/0/0
 description Link to 3650-1
 ip address 10.0.0.1 255.255.255.252
 ip nat inside
!
interface GigabitEthernet0/0/1
 description ****INTERNET*****
 ip address 65.xx.218.195 255.255.255.248
 ip nat outside
!
ip nat inside source list 10 interface GigabitEthernet0/0/1 overload
!
access-list 10 permit 10.0.0.0 0.255.255.255
!

This will translate any 10.0.0.0/8 address to the public internet address assigned to your Internet interface (GigabitEthernet0/0/1).

8
  • That makes perfect sense. I'll try RIPv2 I don't have access to the devices at the moment...first thing I will try out to your recommendations. Thanks. Commented Mar 21, 2017 at 2:58
  • I have a layer-3 switch so I tried the 2nd configuration you provided. I checked a couple times to make sure the config is correct but I'm still not getting a ping out from my workstation....Instead of trying to use RIPv2 I stayed with the OSPF. Commented Mar 21, 2017 at 15:47
  • Did you enable ip routing on the switch? What about injecting the default route on the router in OSPF with the default-information originate command? You should edit your question to include the new configurations you are attempting. Be sure to clearly mark the new configuration as an edit following the current information in your question.
    – Ron Maupin
    Commented Mar 21, 2017 at 15:53
  • Ron, I did put the ip routing in on the switch. since OSPF wasn't working I tried RIPv2. From the 10.1.1.1/16 workstation I am now able to ping 10.0.0.1, 10.0.0.2, 10.3.222.101, and 65.xx.218.195. I am not able to ping 10.3.222.100 or 65.xx.218.193 Commented Mar 21, 2017 at 18:40
  • Could you ping the 10.0.0.2 switch address from the router, and the router 10.0.0.1 address from the switch? Then try to ping the 10.0.0.1 router address from different VLANs. Also, you will need to configure NAT to get from the privately addressed network to the public Internet. Also, with RIPv2, you will need to make sure that you use no auto-summary.
    – Ron Maupin
    Commented Mar 21, 2017 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.