1

I read something a cisco. It said OSPF and default route, defaul gateway, arent good friends...

See my architecture below :

simple architecture

Now in that diagram, I'd like PC1 to be able to reach PC2...

To reach any black area, I told R1 to leave through C.

How can make A and F communicate without A FLOOD OF static routes ? i.e I don't wanna waste the OSFP routing in the middle.

What I did right now is for instance :

  • To reach C, R3 must leave by R2's black interface is is connected to.

Am I forced to use static routing if I want PC1 (A) and PC 2 (F) to communicate ? That will mean I have to configure statically all intermediate routes... Hence making OSPF uselesss except for the middle routers

UPDATE

After talking with Ron Maupin in the answer below, we decided to update the question. Please, click on the link below to see the complete (the real one) diagramm of the network :

enter image description here

Here are the configs :

R1

hostname R1
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX15242RKT
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.14.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.15.2 255.255.255.248
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
 clock rate 2000000
!
interface Serial0/1/0
 ip address 192.168.1.129 255.255.255.192
 clock rate 2000000
!
interface Serial0/1/1
 ip address 192.168.12.2 255.255.255.248
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 log-adjacency-changes
 area 100 authentication message-digest
 redistribute static subnets 
 network 192.168.12.0 0.0.0.7 area 100
 network 192.168.15.0 0.0.0.7 area 100
 network 192.168.14.0 0.0.0.255 area 100
 network 192.168.1.128 0.0.0.63 area 100
!
ip classless
ip route 10.10.10.0 255.255.255.0 192.168.1.130 
ip route 10.100.100.0 255.255.255.0 192.168.1.130 
!
ip flow-export version 9
!
!
!
no cdp run
!

line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

R2

hostname R2
!
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524PDUV
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.2.129 255.255.255.192
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/0
 ip address 192.168.12.1 255.255.255.248
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
!
interface Serial0/1/1
 ip address 192.168.23.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 log-adjacency-changes
 area 100 authentication message-digest
 redistribute static subnets 
 network 192.168.23.0 0.0.0.255 area 100
 network 192.168.12.0 0.0.0.7 area 100
 network 192.168.2.128 0.0.0.63 area 100
!
router rip
!
ip classless
ip route 172.23.1.0 255.255.255.0 192.168.2.130 
!
ip flow-export version 9
!
no cdp run

!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

R3

hostname R3
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524LCOJ
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.34.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
!
interface Serial0/0/1
 ip address 192.168.3.129 255.255.255.192
 clock rate 2000000
!
interface Serial0/1/0
 ip address 192.168.23.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
!
interface Serial0/1/1
 ip address 192.168.14.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 log-adjacency-changes
 area 100 authentication message-digest
 redistribute static subnets 
 network 192.168.23.0 0.0.0.255 area 100
 network 192.168.34.0 0.0.0.255 area 100
 network 192.168.14.0 0.0.0.255 area 100
 network 192.168.3.128 0.0.0.63 area 100
!
router rip
!
ip classless
ip route 172.21.1.0 255.255.255.0 192.168.3.130 
!
ip flow-export version 9
!
!
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

R4

hostname R4
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524G5F7
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.4.129 255.255.255.192
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/0
 ip address 192.168.15.1 255.255.255.248
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 agitel
!
interface Serial0/1/1
 ip address 192.168.34.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf authentication-key agitel
 ip ospf message-digest-key 1 md5 agitel
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 log-adjacency-changes
 area 100 authentication message-digest
 redistribute static subnets 
 network 192.168.34.0 0.0.0.255 area 100
 network 192.168.15.0 0.0.0.7 area 100
 network 192.168.4.128 0.0.0.63 area 100
!
ip classless
ip route 172.18.1.0 255.255.255.0 192.168.4.130 
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

SIEGE

hostname SIEGE
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 99
 ip address 10.10.10.3 255.255.255.0
!
interface FastEthernet0/0.3
 encapsulation dot1Q 100
 ip address 10.100.100.3 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0
 ip address 192.168.1.130 255.255.255.192
!
interface Serial0/1
 no ip address
 clock rate 2000000
 shutdown
!
ip classless
ip route 192.168.12.0 255.255.255.248 192.168.1.129 
ip route 192.168.15.0 255.255.255.248 192.168.1.129 
ip route 192.168.14.0 255.255.255.0 192.168.1.129 
ip route 192.168.23.0 255.255.255.0 192.168.1.129 
ip route 192.168.34.0 255.255.255.0 192.168.1.129 
ip route 192.168.2.128 255.255.255.192 192.168.1.129 
ip route 192.168.3.128 255.255.255.192 192.168.1.129 
ip route 192.168.4.128 255.255.255.192 192.168.1.129 
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

ALPHA

hostname ALPHA
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX15242012
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 ip address 172.21.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/1/0
 ip address 192.168.3.130 255.255.255.192
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.23.0 255.255.255.0 192.168.3.129 
ip route 192.168.2.128 255.255.255.192 192.168.3.129 
ip route 192.168.12.0 255.255.255.248 192.168.3.129 
ip route 192.168.1.128 255.255.255.192 192.168.3.129 
ip route 192.168.14.0 255.255.255.0 192.168.3.129 
ip route 192.168.34.0 255.255.255.0 192.168.3.129 
ip route 192.168.15.0 255.255.255.248 192.168.3.129 
ip route 192.168.4.128 255.255.255.192 192.168.3.129 
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

BETA

hostname BETA
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524U7E9
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 ip address 172.18.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/1/0
 ip address 192.168.4.130 255.255.255.192
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.34.0 255.255.255.0 192.168.4.129 
ip route 192.168.23.0 255.255.255.0 192.168.4.129 
ip route 192.168.14.0 255.255.255.0 192.168.4.129 
ip route 192.168.2.128 255.255.255.192 192.168.4.129 
ip route 192.168.3.128 255.255.255.192 192.168.4.129 
ip route 192.168.1.128 255.255.255.192 192.168.4.129 
ip route 192.168.12.0 255.255.255.248 192.168.4.129 
ip route 192.168.15.0 255.255.255.248 192.168.4.129 
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

TT

hostname TT
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX152423MK
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 ip address 172.23.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/1/0
 ip address 192.168.2.130 255.255.255.192
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 192.168.23.0
!
ip classless
ip route 192.168.12.0 255.255.255.248 192.168.2.129 
ip route 192.168.1.128 255.255.255.192 192.168.2.129 
ip route 192.168.23.0 255.255.255.0 192.168.2.129 
ip route 192.168.14.0 255.255.255.0 192.168.2.129 
ip route 192.168.34.0 255.255.255.0 192.168.2.129 
ip route 192.168.15.0 255.255.255.248 192.168.2.129 
ip route 192.168.3.128 255.255.255.192 192.168.2.129 
ip route 192.168.4.128 255.255.255.192 192.168.2.129 
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

UPDATE 2 : Routing tables

R1 ip Routes

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
S       10.10.10.0/24 [1/0] via 192.168.1.130
S       10.100.100.0/24 [1/0] via 192.168.1.130
     172.18.0.0/24 is subnetted, 1 subnets
O E2    172.18.1.0/24 [110/20] via 192.168.15.1, 01:22:45, Serial0/0/1
     172.21.0.0/24 is subnetted, 1 subnets
O E2    172.21.1.0/24 [110/20] via 192.168.14.1, 01:09:31, Serial0/0/0
     172.23.0.0/24 is subnetted, 1 subnets
O E2    172.23.1.0/24 [110/20] via 192.168.12.1, 01:21:42, Serial0/1/1
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.128/26 is directly connected, Serial0/1/0
L       192.168.1.129/32 is directly connected, Serial0/1/0
     192.168.2.0/26 is subnetted, 1 subnets
O       192.168.2.128/26 [110/128] via 192.168.12.1, 01:32:41, Serial0/1/1
     192.168.3.0/26 is subnetted, 1 subnets
O       192.168.3.128/26 [110/128] via 192.168.14.1, 01:32:51, Serial0/0/0
     192.168.4.0/26 is subnetted, 1 subnets
O       192.168.4.128/26 [110/128] via 192.168.15.1, 01:32:51, Serial0/0/1
     192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.12.0/29 is directly connected, Serial0/1/1
L       192.168.12.2/32 is directly connected, Serial0/1/1
     192.168.14.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.14.0/24 is directly connected, Serial0/0/0
L       192.168.14.2/32 is directly connected, Serial0/0/0
     192.168.15.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.15.0/29 is directly connected, Serial0/0/1
L       192.168.15.2/32 is directly connected, Serial0/0/1
O    192.168.23.0/24 [110/128] via 192.168.12.1, 01:32:41, Serial0/1/1
                     [110/128] via 192.168.14.1, 01:32:41, Serial0/0/0
O    192.168.34.0/24 [110/128] via 192.168.14.1, 01:32:51, Serial0/0/0
                     [110/128] via 192.168.15.1, 01:32:51, Serial0/0/1
end

R2 ip route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
O E2    10.10.10.0/24 [110/20] via 192.168.12.2, 01:10:19, Serial0/1/0
O E2    10.100.100.0/24 [110/20] via 192.168.12.2, 01:10:09, Serial0/1/0
     172.18.0.0/24 is subnetted, 1 subnets
O E2    172.18.1.0/24 [110/20] via 192.168.23.2, 01:24:41, Serial0/1/1
                      [110/20] via 192.168.12.2, 01:24:41, Serial0/1/0
     172.21.0.0/24 is subnetted, 1 subnets
O E2    172.21.1.0/24 [110/20] via 192.168.23.2, 01:11:27, Serial0/1/1
     172.23.0.0/24 is subnetted, 1 subnets
S       172.23.1.0/24 [1/0] via 192.168.2.130
     192.168.1.0/26 is subnetted, 1 subnets
O       192.168.1.128/26 [110/128] via 192.168.12.2, 01:34:42, Serial0/1/0
     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.128/26 is directly connected, Serial0/0/0
L       192.168.2.129/32 is directly connected, Serial0/0/0
     192.168.3.0/26 is subnetted, 1 subnets
O       192.168.3.128/26 [110/128] via 192.168.23.2, 01:34:32, Serial0/1/1
     192.168.4.0/26 is subnetted, 1 subnets
O       192.168.4.128/26 [110/192] via 192.168.23.2, 01:34:32, Serial0/1/1
                         [110/192] via 192.168.12.2, 01:34:32, Serial0/1/0
     192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.12.0/29 is directly connected, Serial0/1/0
L       192.168.12.1/32 is directly connected, Serial0/1/0
O    192.168.14.0/24 [110/128] via 192.168.23.2, 01:34:32, Serial0/1/1
                     [110/128] via 192.168.12.2, 01:34:32, Serial0/1/0
     192.168.15.0/29 is subnetted, 1 subnets
O       192.168.15.0/29 [110/128] via 192.168.12.2, 01:34:42, Serial0/1/0
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial0/1/1
L       192.168.23.1/32 is directly connected, Serial0/1/1
O    192.168.34.0/24 [110/128] via 192.168.23.2, 01:34:32, Serial0/1/1

R3 ip route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
O E2    10.10.10.0/24 [110/20] via 192.168.14.2, 01:10:58, Serial0/1/1
O E2    10.100.100.0/24 [110/20] via 192.168.14.2, 01:10:48, Serial0/1/1
     172.18.0.0/24 is subnetted, 1 subnets
O E2    172.18.1.0/24 [110/20] via 192.168.34.2, 01:25:20, Serial0/0/0
     172.21.0.0/24 is subnetted, 1 subnets
S       172.21.1.0/24 [1/0] via 192.168.3.130
     172.23.0.0/24 is subnetted, 1 subnets
O E2    172.23.1.0/24 [110/20] via 192.168.23.1, 01:24:17, Serial0/1/0
     192.168.1.0/26 is subnetted, 1 subnets
O       192.168.1.128/26 [110/128] via 192.168.14.2, 01:35:21, Serial0/1/1
     192.168.2.0/26 is subnetted, 1 subnets
O       192.168.2.128/26 [110/128] via 192.168.23.1, 01:35:21, Serial0/1/0
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.128/26 is directly connected, Serial0/0/1
L       192.168.3.129/32 is directly connected, Serial0/0/1
     192.168.4.0/26 is subnetted, 1 subnets
O       192.168.4.128/26 [110/128] via 192.168.34.2, 01:35:11, Serial0/0/0
     192.168.12.0/29 is subnetted, 1 subnets
O       192.168.12.0/29 [110/128] via 192.168.23.1, 01:35:21, Serial0/1/0
                        [110/128] via 192.168.14.2, 01:35:21, Serial0/1/1
     192.168.14.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.14.0/24 is directly connected, Serial0/1/1
L       192.168.14.1/32 is directly connected, Serial0/1/1
     192.168.15.0/29 is subnetted, 1 subnets
O       192.168.15.0/29 [110/128] via 192.168.34.2, 01:35:11, Serial0/0/0
                        [110/128] via 192.168.14.2, 01:35:11, Serial0/1/1
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial0/1/0
L       192.168.23.2/32 is directly connected, Serial0/1/0
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial0/0/0
L       192.168.34.1/32 is directly connected, Serial0/0/0

R4 ip route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
O E2    10.10.10.0/24 [110/20] via 192.168.15.2, 01:11:34, Serial0/1/0
O E2    10.100.100.0/24 [110/20] via 192.168.15.2, 01:11:24, Serial0/1/0
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.1.0/24 [1/0] via 192.168.4.130
     172.21.0.0/24 is subnetted, 1 subnets
O E2    172.21.1.0/24 [110/20] via 192.168.34.1, 01:12:43, Serial0/1/1
     172.23.0.0/24 is subnetted, 1 subnets
O E2    172.23.1.0/24 [110/20] via 192.168.34.1, 01:24:53, Serial0/1/1
                      [110/20] via 192.168.15.2, 01:24:53, Serial0/1/0
     192.168.1.0/26 is subnetted, 1 subnets
O       192.168.1.128/26 [110/128] via 192.168.15.2, 01:36:02, Serial0/1/0
     192.168.2.0/26 is subnetted, 1 subnets
O       192.168.2.128/26 [110/192] via 192.168.34.1, 01:36:02, Serial0/1/1
                         [110/192] via 192.168.15.2, 01:36:02, Serial0/1/0
     192.168.3.0/26 is subnetted, 1 subnets
O       192.168.3.128/26 [110/128] via 192.168.34.1, 01:36:02, Serial0/1/1
     192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.4.128/26 is directly connected, Serial0/0/0
L       192.168.4.129/32 is directly connected, Serial0/0/0
     192.168.12.0/29 is subnetted, 1 subnets
O       192.168.12.0/29 [110/128] via 192.168.15.2, 01:36:02, Serial0/1/0
O    192.168.14.0/24 [110/128] via 192.168.34.1, 01:36:02, Serial0/1/1
                     [110/128] via 192.168.15.2, 01:36:02, Serial0/1/0
     192.168.15.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.15.0/29 is directly connected, Serial0/1/0
L       192.168.15.1/32 is directly connected, Serial0/1/0
O    192.168.23.0/24 [110/128] via 192.168.34.1, 01:36:02, Serial0/1/1
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial0/1/1
L       192.168.34.2/32 is directly connected, Serial0/1/1

SIEGE ip route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
O E2    10.10.10.0/24 [110/20] via 192.168.15.2, 01:11:34, Serial0/1/0
O E2    10.100.100.0/24 [110/20] via 192.168.15.2, 01:11:24, Serial0/1/0
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.1.0/24 [1/0] via 192.168.4.130
     172.21.0.0/24 is subnetted, 1 subnets
O E2    172.21.1.0/24 [110/20] via 192.168.34.1, 01:12:43, Serial0/1/1
     172.23.0.0/24 is subnetted, 1 subnets
O E2    172.23.1.0/24 [110/20] via 192.168.34.1, 01:24:53, Serial0/1/1
                      [110/20] via 192.168.15.2, 01:24:53, Serial0/1/0
     192.168.1.0/26 is subnetted, 1 subnets
O       192.168.1.128/26 [110/128] via 192.168.15.2, 01:36:02, Serial0/1/0
     192.168.2.0/26 is subnetted, 1 subnets
O       192.168.2.128/26 [110/192] via 192.168.34.1, 01:36:02, Serial0/1/1
                         [110/192] via 192.168.15.2, 01:36:02, Serial0/1/0
     192.168.3.0/26 is subnetted, 1 subnets
O       192.168.3.128/26 [110/128] via 192.168.34.1, 01:36:02, Serial0/1/1
     192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.4.128/26 is directly connected, Serial0/0/0
L       192.168.4.129/32 is directly connected, Serial0/0/0
     192.168.12.0/29 is subnetted, 1 subnets
O       192.168.12.0/29 [110/128] via 192.168.15.2, 01:36:02, Serial0/1/0
O    192.168.14.0/24 [110/128] via 192.168.34.1, 01:36:02, Serial0/1/1
                     [110/128] via 192.168.15.2, 01:36:02, Serial0/1/0
     192.168.15.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.15.0/29 is directly connected, Serial0/1/0
L       192.168.15.1/32 is directly connected, Serial0/1/0
O    192.168.23.0/24 [110/128] via 192.168.34.1, 01:36:02, Serial0/1/1
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial0/1/1
L       192.168.34.2/32 is directly connected, Serial0/1/1

ALPHA ip route

Gateway of last resort is not set

     172.21.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.21.1.0/24 is directly connected, GigabitEthernet0/0
L       172.21.1.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/26 is subnetted, 1 subnets
S       192.168.1.128/26 [1/0] via 192.168.3.129
     192.168.2.0/26 is subnetted, 1 subnets
S       192.168.2.128/26 [1/0] via 192.168.3.129
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.128/26 is directly connected, Serial0/1/0
L       192.168.3.130/32 is directly connected, Serial0/1/0
     192.168.4.0/26 is subnetted, 1 subnets
S       192.168.4.128/26 [1/0] via 192.168.3.129
     192.168.12.0/29 is subnetted, 1 subnets
S       192.168.12.0/29 [1/0] via 192.168.3.129
S    192.168.14.0/24 [1/0] via 192.168.3.129
     192.168.15.0/29 is subnetted, 1 subnets
S       192.168.15.0/29 [1/0] via 192.168.3.129
S    192.168.23.0/24 [1/0] via 192.168.3.129
S    192.168.34.0/24 [1/0] via 192.168.3.129

BETA ip route

Gateway of last resort is not set

     172.18.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.18.1.0/24 is directly connected, GigabitEthernet0/0
L       172.18.1.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/26 is subnetted, 1 subnets
S       192.168.1.128/26 [1/0] via 192.168.4.129
     192.168.2.0/26 is subnetted, 1 subnets
S       192.168.2.128/26 [1/0] via 192.168.4.129
     192.168.3.0/26 is subnetted, 1 subnets
S       192.168.3.128/26 [1/0] via 192.168.4.129
     192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.4.128/26 is directly connected, Serial0/1/0
L       192.168.4.130/32 is directly connected, Serial0/1/0
     192.168.12.0/29 is subnetted, 1 subnets
S       192.168.12.0/29 [1/0] via 192.168.4.129
S    192.168.14.0/24 [1/0] via 192.168.4.129
     192.168.15.0/29 is subnetted, 1 subnets
S       192.168.15.0/29 [1/0] via 192.168.4.129
S    192.168.23.0/24 [1/0] via 192.168.4.129
S    192.168.34.0/24 [1/0] via 192.168.4.129

TT ip route

Gateway of last resort is not set

     172.23.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.23.1.0/24 is directly connected, GigabitEthernet0/0
L       172.23.1.1/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/26 is subnetted, 1 subnets
S       192.168.1.128/26 [1/0] via 192.168.2.129
     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.128/26 is directly connected, Serial0/1/0
L       192.168.2.130/32 is directly connected, Serial0/1/0
     192.168.3.0/26 is subnetted, 1 subnets
S       192.168.3.128/26 [1/0] via 192.168.2.129
     192.168.4.0/26 is subnetted, 1 subnets
S       192.168.4.128/26 [1/0] via 192.168.2.129
     192.168.12.0/29 is subnetted, 1 subnets
S       192.168.12.0/29 [1/0] via 192.168.2.129
S    192.168.14.0/24 [1/0] via 192.168.2.129
     192.168.15.0/29 is subnetted, 1 subnets
S       192.168.15.0/29 [1/0] via 192.168.2.129
S    192.168.23.0/24 [1/0] via 192.168.2.129
S    192.168.34.0/24 [1/0] via 192.168.2.129

2 Answers 2

0

If you include the R2 C interface, and the R5 D interface in the OSPF routing, then you would need to set up a static route to the R1 A network on R2 and the a static route to the R6 F network on R5, and redistribute the static routes into OSPF. At the same time, you could create a static default route on R1 pointing to R2, and a static default route on R6 pointing to R5.

Since you have not included the router configurations (you should really do that when asking such a question), I cannot give you the details.


Edit:

You will not be able to reach any of the PC networks from any of the other PCs because your routers with the PCs do not have routes to those other networks.

As I suggested, you should use default routes on those routers:

TT:

no ip route 192.168.12.0 255.255.255.248 192.168.2.129 
no ip route 192.168.1.128 255.255.255.192 192.168.2.129 
no ip route 192.168.23.0 255.255.255.0 192.168.2.129 
no ip route 192.168.14.0 255.255.255.0 192.168.2.129 
no ip route 192.168.34.0 255.255.255.0 192.168.2.129 
no ip route 192.168.15.0 255.255.255.248 192.168.2.129 
no ip route 192.168.3.128 255.255.255.192 192.168.2.129 
no ip route 192.168.4.128 255.255.255.192 192.168.2.129 
ip route 0.0.0.0 0.0.0.0 192.168.2.129 
!

Alpha:

no ip route 192.168.23.0 255.255.255.0 192.168.3.129 
no ip route 192.168.2.128 255.255.255.192 192.168.3.129 
no ip route 192.168.12.0 255.255.255.248 192.168.3.129 
no ip route 192.168.1.128 255.255.255.192 192.168.3.129 
no ip route 192.168.14.0 255.255.255.0 192.168.3.129 
no ip route 192.168.34.0 255.255.255.0 192.168.3.129 
no ip route 192.168.15.0 255.255.255.248 192.168.3.129 
no ip route 192.168.4.128 255.255.255.192 192.168.3.129 
ip route 0.0.0.0 0.0.0.0 192.168.3.129 
!

Beta:

no ip route 192.168.34.0 255.255.255.0 192.168.4.129 
no ip route 192.168.23.0 255.255.255.0 192.168.4.129 
no ip route 192.168.14.0 255.255.255.0 192.168.4.129 
no ip route 192.168.2.128 255.255.255.192 192.168.4.129 
no ip route 192.168.3.128 255.255.255.192 192.168.4.129 
no ip route 192.168.1.128 255.255.255.192 192.168.4.129 
no ip route 192.168.12.0 255.255.255.248 192.168.4.129 
no ip route 192.168.15.0 255.255.255.248 192.168.4.129 
ip route 0.0.0.0 0.0.0.0 192.168.4.129 
!
11
  • Awesome. You've totally understood my query. I did everything you said before posting. BUT I have no clue on how to redistribute the static routes into OSPF ... This is where I'm stuck Commented Aug 1, 2017 at 14:29
  • Under the OSPF router configurations, use the redistribute static command. You add the subnets keyword to the end of the command if you are using networks smaller than the default network class. For example, if your 10.0.0.0 prefix is larger than /8, the command would be redistribute static subnets.
    – Ron Maupin
    Commented Aug 1, 2017 at 14:35
  • I have a mix of default prefixes with non default (like /24 and /27, /13 etc..). Now I did as you said, and PC 1 (or PC2) can contact any black router .... But now I get destination host unreachble when trying to reach for instance R5 D from PC 1 or R2 C from PC 2... Now is the time to post my config ? Could I just post you my packet tracer file...because My configs are rmore complex than the diagram (though accurate with the situation) I posted... Commented Aug 1, 2017 at 15:18
  • The packet tracer file will not work since many people here do not have packet tracer. You should edit the question to include the text router configurations from a show running-config, and use the Preformatted text feature ({})..
    – Ron Maupin
    Commented Aug 1, 2017 at 15:21
  • I added the update. Please see it in my OP Commented Aug 1, 2017 at 15:58
1

The real question is: why aren't R1 and R6 running OSPF on their interfaces? OSPF implementations have the passive-interface feature which allows OSPF to not share information across an interface whilst still allowing that interface's subnet to be added to the OSPF database. This is exactly what we want for interfaces to leaf subnets, such as the interfaces to PC1 and PC2.

Static routing between routers is a poor idea. It's easier to configure and simpler to operate a whole network with every interface running OSPF than it is to mix OSPF and static routing. This is a point a lot of beginning network designers miss, thus making their networks more complex in the mistaken belief that they are making them simpler.

But to give an answer. R2 has the interfaces B-C, R2-R3, R2-R4, R2-R5 in OSPF. R2's configuration looks like router ospf 1, network (subnet of B-C) area 0, network (subnet of R2-R3) area 0, network (subnet of R2-R4) area 0, network (subnet of R2-R5) area 0. On R2 create a static route for 10.0.0.0/8 with the next-hop being the address of B: ip route 10.0.0.0 255.0.0.0 (address of B) . Then on R2 add this static route into OSPF: router ospf 1, redistribute static route-map A route-map A permit 10, match ip address prefix-list A, ip prefix-list A permit 10.0.0.0/8. That A route-map permits network 10.0.0.0/8.

You'll notice that we use a route-map to control every route entering the redistribution. This is because it's very easy to add static routes which we don't want in the main OSPF routing table (eg, to act as a discard destination). You'll also notice that we do an exact-match of the prefix, as this is best behaviour which prevents nasty surprises.

We only configure the static route and its redistribution into OSPF on the nearest OSPF router(s) to the static segment. In this network, each of the static routes is configured and redistributed exactly once (10.0.0.0/8 at R2, 20.0.0.0/8 at R5). Multiple definitions of a static route and multiple redistributions are a common misunderstanding, Trust OSPF to carry the route information it has been provided with.

R5 is similarly configured to R2.

R3 and R4 have no static routes, no redistribution. You just list the interface subnets router ospf ..., network ... area 0, network ... area 0, ...

3
  • Please see my update in my OP Commented Aug 1, 2017 at 15:58
  • I suppose the fundamental question remains: are all these routers capable of running OSPF? Because if they can then your life will be 100x better than messing about with so many static routes. And is your question that you want to do a "default-information originate ..." on R1 pointing into SIEGE?
    – vk5tu
    Commented Aug 1, 2017 at 16:27
  • Not just that... I also want PCs behing SIEGE, ALPHA, TT, BETA to be able to ping each other without any constraint....PLease see I added all current routing tables Commented Aug 1, 2017 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.