1

I'm currently playing around with a Cisco 819 LTE-integrated (C819G-4G-G-K9) router at my summer place to get a better LTE-signal and control that the ISP router provides me.

Currently I'm stuck at where the clients cannot ping internet (1.1.1.1 or 8.8.8.8) while the router is able to. The clients can ping the router.

  • Client IP: 10.0.1.12 (VL20)
  • IOS: Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.3(3)M3

If anyone would have an idea why this goes wrong, I would appreciate if you could help me. I have read the other similar posts without success.

sh run:

Router#sh run

Building configuration...

WLAN_AP_SM: Config command is not supported

Current configuration : 2382 bytes

!

! Last configuration change at 20:50:24 UTC Wed Jul 4 2018

version 15.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

no service password-recovery

!

hostname Router

!

boot-start-marker

boot-end-marker

!

aqm-register-fnf

no aaa new-model

!

ip dhcp excluded-address 10.0.1.2 10.0.1.10

!

ip dhcp pool cable

network 10.0.1.0 255.255.255.0

defaul.1.1

dns-server 1.1.1.1

!

no ip domain lookup

ip cef

no ipv6 cef

!

multilink bundle-name authenticated !

chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"

!

license udi pid C819G-4G-G-K9 sn FCZ182191J3

!

vtp mode transent

!

controller Cellular 0

!

vlan 20

name transfer

!

interface Cellular0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulatioip

dialer in-band

dialer string lte

dialer-group 1

!

interface FastEthernet0

no ip address

!

Interface FastEthernet1

!

interface FastEthernet2

switchport access vlan 20

no ip address

!

interface FastEthernet3

no ip address

!

interface GigabitEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0

no ip address

shutdown

clock rate 2000000

!

interface Vlan1

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Vlan20

ip address 10.0.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

ip default-gateway 10.0.0.1

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip nat inside source list NAT interface Cellular0 overload

ip route 0.0.0.0 0.0.0.0 Cellular0

!

ip access-list extended NAT

permit ip 10.0.0.0 0.0.0.255 any

!

dialer-list 1 protocol ip permit

!

access-list 1 permit 0.0.0.0 255.255.255.0

access-list 1 permit 0.0.0.0 0.0.0.255

!

control-plane

!

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!

mgcp profile default

!

line con 0

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

stopbits 1

line 3

script dialer lte

no exec

rxspeed 100000000

txspeed 50000000

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

!

end

And a sh ip route:

Router#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

a - application route

+ - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected, Cellular0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 10.0.1.0/24 is directly connected, Vlan20

L 10.0.1.1/32 is directly connected, Vlan20

90.0.0.0/32 is subnetted, 1 subnets

C 90.232.20.89 is directly connected, Cellular0

Router#
2

Your NAT access list does not include your client subnet. You’ll need to run the following:

config terminal
  ip access-list extended NAT
  permit ip 10.0.1.0 0.0.0.255 any

This will allow hosts on both internal sinners to be properly NATted on the way out your WAN interface.

I apologize for any formatting issues; I blame my phone :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.